aboutsummaryrefslogtreecommitdiff
path: root/www/apache20
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-01-26 10:00:11 +0000
committerClement Laforet <clement@FreeBSD.org>2005-01-26 10:00:11 +0000
commitc54346f8c384c59401c3a8464761d530d1f5c652 (patch)
treeb8bbc5e4a35e2f8ec8fb88890698e3ed6967cae0 /www/apache20
parent7c124b24fac3c881d480534c498d3fbad42e3d30 (diff)
downloadports-c54346f8c384c59401c3a8464761d530d1f5c652.tar.gz
ports-c54346f8c384c59401c3a8464761d530d1f5c652.zip
Changes in Makefile.modules.3rd
o Major change(s) - in some cases, modules are still built as static modules, making modules selection useless and generate a non-desired httpd o Minor change(s) - apxs detection is done only if port isn't a server one. - Mark modules ports as IGNORED if apaxhe is built statically - fix make show-modules when when WITH_ALL_STATIC_MODULES is defined Most issues discovered by: Jason Mealins <jason_mealins@bigfix.com>
Notes
Notes: svn path=/head/; revision=127400
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile.modules.3rd30
1 files changed, 21 insertions, 9 deletions
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index 6d2768b22d02..ef076d6b4fee 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -18,15 +18,6 @@ OVERRIDABLE_VARS= SRC_FILE MODULENAME SHORTMODNAME WRKSRC \
PKGNAMESUFFIX
-.if exists(${APXS})
-APXS_PREFIX!= ${APXS} -q prefix
-. if defined(AP_GENPLIST) && ${APXS_PREFIX} != ${PREFIX}
-IGNORE= PREFIX must be egal to APXS_PREFIX.
-. endif
-.else
-APXS_PREFIX= ${APXS:S/\/sbin\/apxs//}
-.endif
-
.if exists(${APXS_PREFIX}/include/apache2/http_core.h)
WITH_APACHE2= YES
. if defined (WANT_APACHE)
@@ -59,6 +50,18 @@ IGNORE= "Unknown apache version"
.endif
.if !defined(PORT_IS_SERVER)
+.if exists(${APXS})
+APXS_PREFIX!= ${APXS} -q prefix 2> /dev/null || true
+. if defined(APXS_PREFIX)
+IGNORE= : Your apache does not support DSO modules
+. endif
+. if defined(AP_GENPLIST) && ${APXS_PREFIX} != ${PREFIX}
+IGNORE?= PREFIX must be egal to APXS_PREFIX.
+. endif
+.else
+APXS_PREFIX= ${APXS:S/\/sbin\/apxs//}
+.endif
+
.if defined(WITH_APACHE2)
AP_BUILDEXT= la
PLIST_SUB+= APACHEMODDIR="libexec/apache2"
@@ -147,6 +150,14 @@ ${module}_PLIST_SUB= "@comment "
.if ${WANT_APACHE} == common13
# dirty hack to make sure all modules are disabled before we select them
CONFIGURE_ARGS+= --disable-module="all"
+.elif ${WANT_APACHE} == common2
+CONFIGURE_ARGS+= --disable-access --disable-auth \
+ --disable-charset-lite --disable-include \
+ --disable-log-config --disable-env --disable-setenvif \
+ --disable-mime --disable-status --disable-autoindex \
+ --disable-asis --disable-cgid --disable-cgi \
+ --disable-negotiation --disable-dir --disable-imap \
+ --disable-actions --disable-userdir --disable-alias
.endif
.if defined(WITH_MODULES)
@@ -243,6 +254,7 @@ _CONFIGURE_ARGS!= \
fi; done
CONFIGURE_ARGS+= ${_CONFIGURE_ARGS}
.elif defined(WITH_STATIC_APACHE) || defined(WITH_ALL_STATIC_MODULES)
+WITH_STATIC_MODULES= ${APACHE_MODULES}
. if ${WANT_APACHE} == common13
. for module in ${APACHE_MODULES}
CONFIGURE_ARGS+= --enable-module=${module}