aboutsummaryrefslogtreecommitdiff
path: root/www/apache22
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2007-09-09 14:55:17 +0000
committerClement Laforet <clement@FreeBSD.org>2007-09-09 14:55:17 +0000
commitd1f1fe2acc8a1b8c3d6141a7271a85e38e8c24c8 (patch)
tree917c97c0c9eb2cff11eff1d10562d1f1b6e61d28 /www/apache22
parent21219460d98cbcc7d06cee3b4979ca5094c6edde (diff)
downloadports-d1f1fe2acc8a1b8c3d6141a7271a85e38e8c24c8.tar.gz
ports-d1f1fe2acc8a1b8c3d6141a7271a85e38e8c24c8.zip
- Update to 2.2.6
- Fix restart when profiles are used [1] Submitted by: Jarrod Sayers <jarrod at netleader dot com dot au>
Notes
Notes: svn path=/head/; revision=199199
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile7
-rw-r--r--www/apache22/distinfo12
-rw-r--r--www/apache22/files/apache22.sh.in28
-rw-r--r--www/apache22/files/patch-Makefile.in6
-rw-r--r--www/apache22/files/patch-docs_conf_extra_httpd-ssl.conf.in16
-rw-r--r--www/apache22/pkg-plist2
6 files changed, 33 insertions, 38 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index d1e617163c55..a6472bba2c72 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -8,14 +8,13 @@
#
PORTNAME= apache
-PORTVERSION= 2.2.4
-PORTREVISION= 2
+PORTVERSION= 2.2.6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%\//clement\/:aprmysql/}
DISTNAME= httpd-${PORTVERSION}
DISTFILES= ${DISTNAME}.tar.bz2 \
- apr_dbd_mysql.rev-57.c:aprmysql
+ apr_dbd_mysql.rev-93.c:aprmysql
DIST_SUBDIR= apache22
EXTRACT_ONLY= ${DISTNAME}.tar.bz2
@@ -175,7 +174,7 @@ show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
post-extract:
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/apr_dbd_mysql.rev-57.c \
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/apr_dbd_mysql.rev-93.c \
${WRKSRC}/srclib/apr-util/dbd/apr_dbd_mysql.c
post-patch:
diff --git a/www/apache22/distinfo b/www/apache22/distinfo
index 230abd9dd3c6..2da41d6f245f 100644
--- a/www/apache22/distinfo
+++ b/www/apache22/distinfo
@@ -1,6 +1,6 @@
-MD5 (apache22/httpd-2.2.4.tar.bz2) = 536c86c7041515a25dd8bad3611da9a3
-SHA256 (apache22/httpd-2.2.4.tar.bz2) = 08ab82eae6418e265d361730e7eadc7d6966dffdb66ee07bd4d9af3f2b28dfc8
-SIZE (apache22/httpd-2.2.4.tar.bz2) = 4930375
-MD5 (apache22/apr_dbd_mysql.rev-57.c) = 506293fef131712113c145260809a894
-SHA256 (apache22/apr_dbd_mysql.rev-57.c) = f72719995221cd3cb9515ef55d2c4e6d8c0aad08fbf22626eb45be0655833f19
-SIZE (apache22/apr_dbd_mysql.rev-57.c) = 24130
+MD5 (apache22/httpd-2.2.6.tar.bz2) = 203bea91715064f0c787f6499d33a377
+SHA256 (apache22/httpd-2.2.6.tar.bz2) = f27cd9df50a2acd9df8f37520f62f6ce51758689d425ead5883e75ff5ed6548c
+SIZE (apache22/httpd-2.2.6.tar.bz2) = 4717066
+MD5 (apache22/apr_dbd_mysql.rev-93.c) = a9914273d9f27b3c1fbf9bb50e10627f
+SHA256 (apache22/apr_dbd_mysql.rev-93.c) = 79893740a58c96fba6e04f800e950ec42d8128e034056ff8a5770e0d3acc4919
+SIZE (apache22/apr_dbd_mysql.rev-93.c) = 49110
diff --git a/www/apache22/files/apache22.sh.in b/www/apache22/files/apache22.sh.in
index 87ad36a1023a..1ff6101c637b 100644
--- a/www/apache22/files/apache22.sh.in
+++ b/www/apache22/files/apache22.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/www/apache22/files/Attic/apache22.sh.in,v 1.3 2007-03-17 16:03:24 clement Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache22/files/Attic/apache22.sh.in,v 1.4 2007-09-09 14:55:17 clement Exp $
#
# PROVIDE: apache22
@@ -88,21 +88,17 @@ if [ -n "$2" ]; then
fi
else
if [ "x${apache22_profiles}" != "x" -a "x$1" != "x" ]; then
- if [ "x$1" != "xrestart" ]; then
- for profile in ${apache22_profiles}; do
- echo "===> apache22 profile: ${profile}"
- %%PREFIX%%/etc/rc.d/apache22%%RC_SUBR_SUFFIX%% $1 ${profile}
- retcode="$?"
- if [ "0${retcode}" -ne 0 ]; then
- failed="${profile} (${retcode}) ${failed:-}"
- else
- success="${profile} ${success:-}"
- fi
- done
- exit 0
- else
- restart_precmd=""
- fi
+ for profile in ${apache22_profiles}; do
+ echo "===> apache22 profile: ${profile}"
+ %%PREFIX%%/etc/rc.d/apache22%%RC_SUBR_SUFFIX%% $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
fi
fi
diff --git a/www/apache22/files/patch-Makefile.in b/www/apache22/files/patch-Makefile.in
index 9950f566999e..0eaa6e441c58 100644
--- a/www/apache22/files/patch-Makefile.in
+++ b/www/apache22/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun Nov 13 06:33:15 2005
-+++ Makefile.in Sat Dec 3 22:10:42 2005
+--- Makefile.in.orig Tue Apr 24 13:08:01 2007
++++ Makefile.in Sun Sep 9 11:57:06 2007
@@ -31,9 +31,11 @@
install-conf:
@echo Installing configuration files
@@ -40,7 +40,7 @@
$(RSYNC) --exclude .svn -rlpt --numeric-ids $(top_srcdir)/docs/manual/ $(DESTDIR)$(manualdir)/; \
else \
cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir); \
- cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null; \
+ cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
fi
+.endif
diff --git a/www/apache22/files/patch-docs_conf_extra_httpd-ssl.conf.in b/www/apache22/files/patch-docs_conf_extra_httpd-ssl.conf.in
index 15ca7ef1e237..1d109a1b7896 100644
--- a/www/apache22/files/patch-docs_conf_extra_httpd-ssl.conf.in
+++ b/www/apache22/files/patch-docs_conf_extra_httpd-ssl.conf.in
@@ -1,13 +1,13 @@
---- docs/conf/extra/httpd-ssl.conf.in.orig Sun Oct 30 19:40:45 2005
-+++ docs/conf/extra/httpd-ssl.conf.in Sun Oct 30 19:41:50 2005
+--- docs/conf/extra/httpd-ssl.conf.in.orig Wed Mar 7 08:33:58 2007
++++ docs/conf/extra/httpd-ssl.conf.in Sun Sep 9 11:59:51 2007
@@ -77,8 +77,8 @@
DocumentRoot "@exp_htdocsdir@"
ServerName www.example.com:443
ServerAdmin you@example.com
--ErrorLog @exp_logfiledir@/error_log
--TransferLog @exp_logfiledir@/access_log
-+ErrorLog @exp_logfiledir@/httpd-error.log
-+TransferLog @exp_logfiledir@/httpd-access.log
+-ErrorLog "@exp_logfiledir@/error_log"
+-TransferLog "@exp_logfiledir@/access_log"
++ErrorLog "@exp_logfiledir@/httpd-error.log"
++TransferLog "@exp_logfiledir@/httpd-access.log"
# SSL Engine Switch:
# Enable/Disable SSL for this virtual host.
@@ -15,8 +15,8 @@
# Per-Server Logging:
# The home of a custom SSL log file. Use this when you want a
# compact non-error SSL logfile on a virtual host basis.
--CustomLog @exp_logfiledir@/ssl_request_log \
-+CustomLog @exp_logfiledir@/httpd-ssl_request.log \
+-CustomLog "@exp_logfiledir@/ssl_request_log" \
++CustomLog "@exp_logfiledir@/httpd-ssl_request.log" \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
diff --git a/www/apache22/pkg-plist b/www/apache22/pkg-plist
index 31eb11ce2ace..cce925cee69b 100644
--- a/www/apache22/pkg-plist
+++ b/www/apache22/pkg-plist
@@ -305,6 +305,7 @@ www/apache22/error/include/bottom.html
www/apache22/error/include/spacer.html
www/apache22/error/include/top.html
www/apache22/icons/README
+www/apache22/icons/README.html
www/apache22/icons/a.gif
www/apache22/icons/a.png
www/apache22/icons/alert.black.gif
@@ -432,7 +433,6 @@ www/apache22/icons/screw2.gif
www/apache22/icons/screw2.png
www/apache22/icons/script.gif
www/apache22/icons/script.png
-www/apache22/icons/small/README.txt
www/apache22/icons/small/back.gif
www/apache22/icons/small/back.png
www/apache22/icons/small/binary.gif