aboutsummaryrefslogtreecommitdiff
path: root/www/apache24
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-09-22 18:50:18 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-09-22 18:50:18 +0000
commit5e7c85a03abff9312cc4c353f532afb844c2b14c (patch)
tree598570eebe02044563d917685aa323fb265792a5 /www/apache24
parent5e1d38ca3b874653ad61e2732a8a152d5133ab5f (diff)
downloadports-5e7c85a03abff9312cc4c353f532afb844c2b14c.tar.gz
ports-5e7c85a03abff9312cc4c353f532afb844c2b14c.zip
apache24
- remove check if apr is build with threads - bump PORTREVISION - adopt new pkg-plist @dir @with hat apache@
Notes
Notes: svn path=/head/; revision=368986
Diffstat (limited to 'www/apache24')
-rw-r--r--www/apache24/Makefile15
-rw-r--r--www/apache24/Makefile.modules37
-rw-r--r--www/apache24/pkg-plist27
3 files changed, 11 insertions, 68 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index fac4b1b77aca..a3525e1c56c7 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -12,7 +12,7 @@ MAINTAINER= apache@FreeBSD.org
COMMENT= Version 2.4.x of Apache web server
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
- libapr-1.so.0.5.1:${PORTSDIR}/devel/apr1 \
+ libapr-1.so:${PORTSDIR}/devel/apr1 \
libpcre.so:${PORTSDIR}/devel/pcre
CONFLICTS_INSTALL= caudium14-1.* \
@@ -154,14 +154,13 @@ post-install:
# place for module configuration samples
@${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}/modules.d
${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}${EXAMPLESDIR}/modules.d
-
-# suppress warning for non binary files
- -@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/* \
- ${STAGEDIR}${PREFIX}/bin/* \
- ${STAGEDIR}${PREFIX}/libexec/apache24/*.so 2>/dev/null
+# strip returns an error for non binary files, but we have a big mix
+ -${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/* 2>/dev/null
+ -${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ -${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/apache24/mod_*.so
.if ${PORT_OPTIONS:MLOG_FORENSIC}
- @${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${STAGEDIR}${PREFIX}/sbin
.endif
# maintainer only, check for new modules
diff --git a/www/apache24/Makefile.modules b/www/apache24/Makefile.modules
index ef7fbf9ed58b..4383e000795a 100644
--- a/www/apache24/Makefile.modules
+++ b/www/apache24/Makefile.modules
@@ -18,19 +18,6 @@
.if defined(_PREMKINCLUDED)
-# check if APR was build with thread support
-.if exists(${APR_CONFIG})
-APR_LIBS!= ${SH} ${APR_CONFIG} --libs | ${SED} -e 's/-//g'
-. if defined(APR_LIBS) && !empty(APR_LIBS)
-_T=pthread
-. for lib in ${APR_LIBS}
-. if ${_T:M${lib}}
-APR_HAS_THREADS= yes
-. endif
-. endfor
-. endif
-.endif # exists APR_CONFIG
-
# check if APR-util module exists
.if exists(${APU_CONFIG})
. if ${PORT_OPTIONS:MLDAP} || ${PORT_OPTIONS:MAUTHNZ_LDAP}
@@ -47,15 +34,6 @@ IGNORE= SESSION_CRYPTO requires APR-util to have crypto openssl support build in
. endif
. endif
-# XXX apache24 needs only the apu-header
-# perhaps we get in future the possibility to package dedicated APU modules
-#
-#. if ${PORT_OPTIONS:MDBD} || ${PORT_OPTIONS:MAUTHN_DBD}
-#. if !exists(${APU_DBD_MYSQL}) && !exists(${APU_DBD_PGSQL}) && !exists(${APU_DBD_SQLITE3})
-#IGNORE= AUTHN_DBD and DBD requires APR-util to have DBD support build in.\
-# Please rebuild APR at last with one DBD backend
-#. endif
-#. endif
.endif # exists APU_CONFIG
# =============================================
@@ -80,12 +58,6 @@ CONFIGURE_ARGS+= --with-mpm=event
.else
IGNORE= Unknown MPM:
.endif
-
-.if ${PORT_OPTIONS:MMPM_WORKER} || ${PORT_OPTIONS:MMPM_EVENT}
-. if exists(${APR_CONFIG}) && !defined(APR_HAS_THREADS)
-IGNORE= requires APR threads. Please rebuild APR with THREAD support
-. endif
-.endif
# =============================================
# build develop/example modules only with additional confirmation
@@ -152,13 +124,4 @@ CONFIGURE_ARGS+= --with-libxml2=${LOCALBASE}/include/libxml2
CONFIGURE_ARGS+= --without-libxml2
.endif
-.if defined(APR_HAS_THREADS)
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-.else
-. if exists(${APR_CONFIG}) && ${PORT_OPTIONS:MMEM_CACHE}
-IGNORE= MEM_CACHE requires APR threads. Please rebuild APR with THREAD support
-. endif
-.endif
-
.endif # _PREMKINCLUDED
diff --git a/www/apache24/pkg-plist b/www/apache24/pkg-plist
index 906b72e155df..a4fe1a22e5df 100644
--- a/www/apache24/pkg-plist
+++ b/www/apache24/pkg-plist
@@ -1,7 +1,3 @@
-@comment keep the next three lines on top (only required for old pkg_... tools)
-@exec mkdir -p %D/%%ETCDIR%%/envvars.d
-@exec mkdir -p %D/%%ETCDIR%%/extra
-@exec mkdir -p %D/%%ETCDIR%%/Includes
bin/ab
bin/htdbm
bin/htdigest
@@ -548,22 +544,7 @@ sbin/split-logfile
%%WWWDIR%%/icons/world2.png
%%WWWDIR%%/icons/xml.png
@unexec rm -f %D/%%ETCDIR%%/httpd.conf.bak 2> /dev/null || true
-@dirrmtry %%ETCDIR%%/Includes
-@dirrmtry %%ETCDIR%%/envvars.d
-@dirrmtry %%ETCDIR%%/extra
-@dirrmtry %%ETCDIR%%/modules.d
-@dirrmtry %%ETCDIR%%
-@dirrmtry include/apache24
-@dirrmtry libexec/apache24
-@dirrm %%DATADIR%%/build
-@dirrm %%DATADIR%%
-@dirrm %%EXAMPLESDIR%%/extra
-@dirrm %%EXAMPLESDIR%%/modules.d
-@dirrm %%EXAMPLESDIR%%
-@dirrmtry %%WWWDIR%%/cgi-bin
-@dirrmtry %%WWWDIR%%/data
-@dirrm %%WWWDIR%%/error/include
-@dirrm %%WWWDIR%%/error
-@dirrm %%WWWDIR%%/icons/small
-@dirrm %%WWWDIR%%/icons
-@dirrmtry %%WWWDIR%%
+@dir %%ETCDIR%%/Includes
+@dir %%ETCDIR%%/envvars.d
+@dir %%ETCDIR%%/extra
+@dir %%WWWDIR%%/data