aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1997-10-23 16:40:02 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1997-10-23 16:40:02 +0000
commitd7422c6406bbada531509be80cee1d6a122f98b0 (patch)
tree2ab1faf3a49ef5ee1786b3d7420366fcea0f8d07 /www/apache2
parentf5b49da05bd32be8ee05d7a59652d6c84fd1fb52 (diff)
downloadports-d7422c6406bbada531509be80cee1d6a122f98b0.tar.gz
ports-d7422c6406bbada531509be80cee1d6a122f98b0.zip
Compile with -funsigned-char instead of (unsigned char) cast
and not replace Apache functions now
Notes
Notes: svn path=/head/; revision=8345
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/files/patch-ab51
2 files changed, 0 insertions, 53 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 96bc898574ca..9d7bbd9cc276 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -17,8 +17,6 @@ MAINTAINER= ache@freebsd.org
# VERS_ID = mods-1.0/me
post-patch:
- @cp /usr/include/md5.h ${WRKSRC}/src/main/freebsd_md5.h
- @cp /usr/include/fnmatch.h ${WRKSRC}/src/main/freebsd_fnmatch.h
@cd ${WRKSRC}/conf && \
for I in access.conf-dist srm.conf-dist; do \
sed -e "s#@@ServerRoot@@#${PREFIX}/www#g" < $${I} > $${I}.new; \
diff --git a/www/apache2/files/patch-ab b/www/apache2/files/patch-ab
deleted file mode 100644
index c815f9f2b384..000000000000
--- a/www/apache2/files/patch-ab
+++ /dev/null
@@ -1,51 +0,0 @@
-*** src/main/fnmatch.h.orig Thu Oct 16 22:57:01 1997
---- src/main/fnmatch.h Wed Oct 22 22:44:12 1997
-***************
-*** 35,40 ****
---- 35,44 ----
-
- /* This file has been modified by the Apache Group. */
-
-+ #ifdef __FreeBSD__
-+ #include "freebsd_fnmatch.h"
-+ extern int is_fnmatch(const char *);
-+ #else
- #ifndef _FNMATCH_H_
- #define _FNMATCH_H_
-
-***************
-*** 50,52 ****
---- 54,57 ----
- extern int is_fnmatch(const char *);
-
- #endif /* !_FNMATCH_H_ */
-+ #endif /* !FreeBSD */
-*** src/main/fnmatch.c.orig Thu Oct 16 22:57:01 1997
---- src/main/fnmatch.c Wed Oct 22 22:40:52 1997
-***************
-*** 34,39 ****
---- 34,40 ----
- * SUCH DAMAGE.
- */
-
-+ #ifndef __FreeBSD__
- #if defined(LIBC_SCCS) && !defined(lint)
- static char sccsid[] = "@(#)fnmatch.c 8.2 (Berkeley) 4/16/94";
- #endif /* LIBC_SCCS and not lint */
-***************
-*** 169,175 ****
- }
- return (ok == negate ? NULL : pattern);
- }
-!
-
- /* This function is an Apache addition */
- /* return non-zero if pattern has any glob chars in it */
---- 170,176 ----
- }
- return (ok == negate ? NULL : pattern);
- }
-! #endif /* !FreeBSD */
-
- /* This function is an Apache addition */
- /* return non-zero if pattern has any glob chars in it */