aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-11 05:16:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-11 05:16:07 +0000
commit77e237414b37fb0d1d73af4e890b6fe661144913 (patch)
tree5eaef4affe306410a8184623ad9e44ea9864ed1c /www/apache2
parentc082ec23b091bfad3611025453d6f0213974e866 (diff)
downloadports-77e237414b37fb0d1d73af4e890b6fe661144913.tar.gz
ports-77e237414b37fb0d1d73af4e890b6fe661144913.zip
- Disable THREADS by default (many ports people reported problems around
threads) - Bump port revision - Added two more "POSIX expr" patch target for 5-CURRENT PR: 36981 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=57559
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 42fb552410d9..3d83bc636c3a 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.35
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.apache.org/dist/httpd/ \
http://apache.mirrorcentral.com/dist/httpd/ \
@@ -46,7 +47,7 @@ RC_SUB= -e 's,@@PREFIX@@,${PREFIX},g'
MAKE_ENV+= NOPORTDOCS=YES
.endif
-.if !defined(WITHOUT_THREADS)
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
.endif
@@ -73,7 +74,7 @@ PLIST_SUB+= SUEXEC=""
PLIST_SUB+= SUEXEC="@comment "
.endif
-.if !defined(WITHOUT_CACHE) && !defined(WITHOUT_THREADS)
+.if !defined(WITHOUT_CACHE) && defined(WITH_THREADS)
SHARED_MODULES+= cache file-cache disk-cache mem_cache
PLIST_SUB+= MODCACHE=""
.else
@@ -89,7 +90,7 @@ PLIST_SUB+= MODPROXY="@comment "
.if ${WITH_MPM} != "prefork"
PKGNAMESUFFIX= -${WITH_MPM}
-.if defined(WITHOUT_THREADS)
+.if !defined(WITH_THREADS)
IGNORE= "requires threads for ${WITH_MPM} mpm"
.endif
.endif
@@ -112,8 +113,11 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -exec ${RM} -f {} \;
@${SED} ${RC_SUB} ${FILESDIR}/apache.sh >${WRKDIR}/apache2.sh
.if ${OSVERSION} >= 500032
+.for ltfile in srclib/pcre/ltmain.sh srclib/apr/build/ltmain.sh \
+ srclib/apr-util/xml/expat/conftools/ltmain.sh
@${PERL} -pi.orig -e 's|expr|expr --|' \
- ${WRKSRC}/srclib/apr/build/ltmain.sh
+ ${WRKSRC}/${ltfile}
+.endfor
.endif
pre-install: