aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-11-09 03:22:49 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-11-09 03:22:49 +0000
commitc032fc783b4303e969c85f06f44815a2dd5ab765 (patch)
treeff3f18d4a8dba3d61ee7185b13970946bd64023b /www/apache2
parent303e86725f710f760faa82d606c26cc1ff9ccc9e (diff)
downloadports-c032fc783b4303e969c85f06f44815a2dd5ab765.tar.gz
ports-c032fc783b4303e969c85f06f44815a2dd5ab765.zip
- fix LDAP deps (typo) [1]
- fix nasty typo in DBM code (missing + in LIB_DEPENDS=) - remove NO_{ERROR;WWWDATE;CGI;ICONS;WWW} and utilize WITHOUT_WWW and WITH_CUSTOM_WWW [2] - HTTP_PORT => WITH_HTTP_PORT and IPV6_ONLY => WITH_IPV6_ONLY [3] - add support for FreeBSD libc db [4] - add db41 support [5] - more typos and a few things... Notified by: Oliver Eikemeier <eikemeier@fillmore-labs.com> [1] Discussed with: Oliver Eikemeier <eikemeier@fillmore-labs.com> [2] [3] Requested by: Fritz Heinrichmeyer <fritz.heinrichmeyer@fernuni-hagen.de> [4] Submitted by: <swp@uni-altai.ru> [5] PR: 58739 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Notes
Notes: svn path=/head/; revision=93491
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile66
-rw-r--r--www/apache2/Makefile.modules59
-rw-r--r--www/apache2/files/patch-srclib:apr-util:configure79
-rw-r--r--www/apache2/pkg-plist2
4 files changed, 154 insertions, 52 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index cb909beccf27..ccdce74edc31 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.48
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
@@ -33,23 +34,23 @@ CONFLICTS= apache+ipv6-1.* apache+modssl-1.* apache+ssl-1.* apache-1.* apache_fp
## WITH_MPM: prefork (default)
## worker
## perchild
-## HTTP_PORT: default: 80
+## WITH_HTTP_PORT: default: 80
## WITH_LDAP: Enable LDAP support (mod_auth_ldap)
## WITHOUT_PROXY: Disable proxy support
## WITH_CUSTOM_PROXY: Let you choose which proxy modules you wish
## WITHOUT_AUTH: Disable auth modules
## WITH_CUSTOM_AUTH: Let you choose which auth modules you wish
## WITHOUT_DAV: Disable DAV support
-## IPV6_V6ONLY: Disable IPv4 support
+## WITH_IPV6_V6ONLY: Disable IPv4 support
## WITHOUT_SSL: Disable SSL support
## WITH_THREADS: Enable threads support !! USE IT WITH CARE !!
## WITH_CUSTOM_THREADS: Let you choose which threaded modules you want
## WITH_EXPERIMENTAL: Enable Experimental modules
## WITH_DBM: Choose your DBM: bdb (Berkeley DB), gdbm or ndbm (default)
-## WITH_BERKELEYDB: Choose your BerkeleyDB version: db2, db3 or db4 (default)
+## WITH_BERKELEYDB: Choose your BerkeleyDB version: db2, db3, db4, db41 or FreeBSD (1.85)(default)
## WITH_STATIC_SUPPORT: Build statically linked support binaries
## WITH_STATIC_APACHE: Build a static version of httpd (implies WITH_STATIC_MODULES)
-## WITH_ALL_STATIC_APACHE: All modules statically linked.
+## WITH_ALL_STATIC_MODULES: All modules will be statically linked.
## WITH_STATIC_MODULES: List of modules to build modules statics (usefull for slave ports)
## (They must be already enabled (i.e. WITH_MODULES or with default configuration
## use 'make show-modules', to check if they are enabled)
@@ -60,12 +61,8 @@ CONFLICTS= apache+ipv6-1.* apache+modssl-1.* apache+ssl-1.* apache-1.* apache_fp
##
##
## Port-related:
-## NOPORTDOCS: Do not install documentation
-## NO_CGI: Do not instal www/cgi-bin*
-## NO_ERROR: Do not instal www/error
-## NO_WWWDATA: Do not instal www/data*
-## NO_ICONS: Do not instal www/icons*
-## NO_WWW: Implies NO_CGI, NO_WWWDATA, NO_ICONS and NO_ERROR
+## WITHOUT_WWW: Implies NO_CGI, NO_WWWDATA, NO_ICONS and NO_ERROR
+## WITH_CUSTOM_WWW: Let you choose your ${LOCALBASE}/www components: [cgi|errordocs|icons|wwwdata]
##
## Available make targets:
## show-options: prints this message
@@ -79,7 +76,7 @@ CONFLICTS= apache+ipv6-1.* apache+modssl-1.* apache+ssl-1.* apache-1.* apache_fp
##
WITH_MPM?= prefork # or worker, perchild
-HTTP_PORT?= 80
+HTTP_PORT?= ${WITH_HTTP_PORT}
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
@@ -108,7 +105,7 @@ MAKE_ENV+= NOPORTDOCS=yes
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 suexec.8
-.if !defined(IPV6_V6ONLY)
+.if !defined(WITH_IPV6_V6ONLY)
CONFIGURE_ARGS+= --enable-v4-mapped
.endif
@@ -117,45 +114,32 @@ USE_OPENSSL= yes
.endif
.if defined(WITH_LDAP)
-USE_LDAP= YES
+USE_OPENLDAP= YES
CONFIGURE_ARGS+= --with-ldap \
--with-ldap-lib="${LOCALBASE}/lib" \
--with-ldap-include="${LOCALBASE}/include"
.endif
-.if defined(NO_WWW)
+.if defined(WITHOUT_WWW)
NO_CGI= YES
NO_WWWDATA= YES
NO_ICONS= YES
NO_ERROR= YES
.endif
-.if defined(NO_CGI)
-MAKE_ENV+= NO_CGI=yes
-PLIST_SUB+= CGI="@comment "
-.else
-PLIST_SUB+= CGI=""
-.endif
-
-.if defined(NO_ICONS)
-MAKE_ENV+= NO_ICONS=yes
-PLIST_SUB+= ICONS="@comment "
-.else
-PLIST_SUB+= ICONS=""
-.endif
-
-.if defined(NO_WWWDATA)
-MAKE_ENV+= NO_WWWDATA=yes
-PLIST_SUB+= WWWDATA="@comment "
-.else
-PLIST_SUB+= WWWDATA=""
-.endif
-
-.if defined(NO_ERROR)
-MAKE_ENV+= NO_ERROR=yes
-PLIST_SUB+= ERROR="@comment "
-.else
-PLIST_SUB+= ERROR=""
+.if defined(WITH_CUSTOM_WWW)
+. if ${WITH_CUSTOM_WWW:Mcgi} == ""
+NO_CGI= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Mwwwdata} == ""
+NO_WWWDATA= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Merrordocs} == ""
+NO_ERROR= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Micons} == ""
+NO_ICONS= YES
+. endif
.endif
.if defined(WITH_STATIC_SUPPORT)
@@ -169,7 +153,7 @@ CONFIGURE_ARGS+= --enable-static-support
CONFIGURE_ARGS+= --with-mpm=${WITH_MPM:L} ${CONFIGURE_TARGET}
show-options:
- @${EGREP} '^##' ${.CURDIR}/Makefile | ${SED} 's/##//'
+ @${SED} -ne 's/^##//p' ${.CURDIR}/Makefile
show-modules:
@for module in $(AVAILABLE_MODULES) ; do \
diff --git a/www/apache2/Makefile.modules b/www/apache2/Makefile.modules
index 6ddb369de951..e65bc60bd586 100644
--- a/www/apache2/Makefile.modules
+++ b/www/apache2/Makefile.modules
@@ -35,11 +35,44 @@ PLIST_SUB+= PREFORK="@comment " WORKER="@comment "
PLIST_SUB+= PREFORK="@comment " WORKER="@comment "
.endif
+# Documentation section
+.if defined(NO_CGI)
+MAKE_ENV+= NO_CGI=yes
+PLIST_SUB+= CGI="@comment "
+.else
+PLIST_SUB+= CGI=""
+.endif
+
+.if defined(NO_ICONS)
+MAKE_ENV+= NO_ICONS=yes
+PLIST_SUB+= ICONS="@comment "
+.else
+PLIST_SUB+= ICONS=""
+.endif
+
+.if defined(NO_WWWDATA)
+MAKE_ENV+= NO_WWWDATA=yes
+PLIST_SUB+= WWWDATA="@comment "
+.else
+PLIST_SUB+= WWWDATA=""
+.endif
+
+.if defined(NO_ERROR)
+MAKE_ENV+= NO_ERROR=yes
+PLIST_SUB+= ERROR="@comment "
+.else
+PLIST_SUB+= ERROR=""
+.endif
+
+
# xDBM section
#
.if !defined(WITH_DBM) && defined(WITH_BERKELEYDB)
WITH_DBM=db
.endif
+.if defined(WITH_DBM) && !defined(WITH_BERKELEYDB)
+WITH_BERKELEYDB= FreeBSD
+.endif
.if defined(WITH_DBM)
. if ${WITH_DBM:L} == "sdbm"
@@ -47,23 +80,29 @@ CONFIGURE_ARGS+= --with-dbm=sdbm
. elif ${WITH_DBM:L} == "gdbm"
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE}
-. elif ${WITH_DBM:L} == "db" || defined(WITH_BERKELEYDB)
-. if !defined(WITH_BERKELEYDB)
-LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS+= --with-dbm=db4 \
- --with-berkeley-db=${LOCALBASE}
+. elif ${WITH_DBM:L} == "db"
+. if ${WITH_BERKELEYDB} == "FreeBSD"
+CONFIGURE_ARGS+= --with-dbm=db185 \
+ --with-berkeley-db=/usr
. elif ${WITH_BERKELEYDB} == "db2"
-LIB_DEPENDS= db2:${PORTSDIR}/databases/db2
+LIB_DEPENDS+= db2:${PORTSDIR}/databases/db2
CONFIGURE_ARGS+= --with-dbm=db2 \
--with-berkeley-db=${LOCALBASE}
. elif ${WITH_BERKELEYDB} == "db3"
-LIB_DEPENDS= db2:${PORTSDIR}/databases/db3
+LIB_DEPENDS+= db3:${PORTSDIR}/databases/db3
CONFIGURE_ARGS+= --with-dbm=db3 \
--with-berkeley-db=${LOCALBASE}
. elif ${WITH_BERKELEYDB} == "db4"
-LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
+LIB_DEPENDS+= db4:${PORTSDIR}/databases/db4
CONFIGURE_ARGS+= --with-dbm=db4 \
--with-berkeley-db=${LOCALBASE}
+. if exists(${LOCALBASE}/lib/libdb41.so)
+BROKEN= "It seems you have db41 installed. Current configuration process will choose it. Please use WITH_BERKELEYDB=db41"
+. endif
+. elif ${WITH_BERKELEYDB} == "db41"
+LIB_DEPENDS+= db41:${PORTSDIR}/databases/db41
+CONFIGURE_ARGS+= --with-dbm=db41 \
+ --with-berkeley-db=${LOCALBASE}
. else
BROKEN= "Unknown Berkeley DB version"
. endif
@@ -78,13 +117,13 @@ CONFIGURE_ARGS+= --with-dbm=sdbm
# How does it works ?
# << TO BE WRITTEN >>
# All supported modules
-AUTH_MODULES= auth auth_anon auth_dbm auth_digest
+AUTH_MODULES= access auth auth_anon auth_dbm auth_digest
DAV_MODULES= dav dav_fs
EXPERIMENTAL_MODULES= bucketeer case_filter case_filter_in ext_filter charset_lite \
optional_hook_export optional_hook_import \
optional_fn_import optional_fn_export
LDAP_MODULES= ldap auth_ldap
-MISC_MODULES= access actions alias asis autoindex cache cern_meta \
+MISC_MODULES= actions alias asis autoindex cache cern_meta \
cgi cgid charset_lite deflate dir disk_cache env expires \
file_cache headers imap include info log_config logio mime \
mime_magic negotiation rewrite setenvif speling status \
diff --git a/www/apache2/files/patch-srclib:apr-util:configure b/www/apache2/files/patch-srclib:apr-util:configure
new file mode 100644
index 000000000000..7f28b2950788
--- /dev/null
+++ b/www/apache2/files/patch-srclib:apr-util:configure
@@ -0,0 +1,79 @@
+--- srclib/apr-util/configure.orig Thu Nov 6 13:05:46 2003
++++ srclib/apr-util/configure Thu Nov 6 13:05:30 2003
+@@ -7586,8 +7586,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
+@@ -11281,8 +11281,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db_185.h"
+- bdb_default_search_lib_names="db"
++ bdb_default_search_headers="db.h"
++ bdb_default_search_lib_names="c"
+
+
+ apu_have_db=0
+@@ -13401,8 +13401,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
+@@ -13934,8 +13934,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
+@@ -17113,8 +17113,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
+@@ -22928,8 +22928,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
+@@ -23461,8 +23461,8 @@
+ fi
+ fi
+ bdb_places="$places"
+- bdb_default_search_headers="db4/db.h db.h"
+- bdb_default_search_lib_names="db-4.1 db4 db"
++ bdb_default_search_headers="db41/db.h db4/db.h db.h"
++ bdb_default_search_lib_names="db41 db-4.1 db4 db"
+
+
+ apu_have_db=0
diff --git a/www/apache2/pkg-plist b/www/apache2/pkg-plist
index 6323eeb37395..5579a070b701 100644
--- a/www/apache2/pkg-plist
+++ b/www/apache2/pkg-plist
@@ -1554,4 +1554,4 @@ share/apache2/build/special.mk
@dirrm libexec/apache2
@dirrm lib/apache2
@dirrm include/apache2
-@dirrm etc/apache2
+@unexec rmdir %D/etc/apache2 2> /dev/null || echo "===> If you plan to do not reinstall apache2, you can safely remove %D/etc/apache2."