aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-08-19 00:42:10 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-08-19 00:42:10 +0000
commit1de8d824e6299258e52a0facb6d2a154b93b8468 (patch)
tree1c0808620d7b46bf25cf4100abe9d8c959c46f93 /www/bluefish/Makefile
parenta5f2f98e45f9c67853e4086caaed31187b0be84a (diff)
downloadports-1de8d824e6299258e52a0facb6d2a154b93b8468.tar.gz
ports-1de8d824e6299258e52a0facb6d2a154b93b8468.zip
- Use SF macro.
- Pass maintainer to submitter. PR: ports/137889 Submitted by: Sylvio Cesar <scjamorim@bsd.com.br>
Notes
Notes: svn path=/head/; revision=239912
Diffstat (limited to 'www/bluefish/Makefile')
-rw-r--r--www/bluefish/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index cac1e97beaad..4f5007b54953 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -10,10 +10,10 @@ PORTNAME= bluefish
PORTVERSION= 1.0.7
PORTREVISION= 6
CATEGORIES= www editors
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= scjamorim@bsd.com.br
COMMENT= HTML editor designed for the experienced web designer
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
@@ -27,7 +27,6 @@ RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
.endif
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -71,4 +70,12 @@ pre-install:
USE_GNOME+= libgnomeui
.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.include <bsd.port.post.mk>