aboutsummaryrefslogtreecommitdiff
path: root/www/calendarserver
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /www/calendarserver
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'www/calendarserver')
-rw-r--r--www/calendarserver/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/www/calendarserver/Makefile b/www/calendarserver/Makefile
index 662773b5107f..364ac55670de 100644
--- a/www/calendarserver/Makefile
+++ b/www/calendarserver/Makefile
@@ -12,21 +12,21 @@ COMMENT= Calendar and Contacts Server from Apple (RFC 4791, RFC 6352)
LICENSE= APACHE20
RUN_DEPENDS= memcached:databases/memcached \
- ${PYTHON_PKGNAMEPREFIX}calendar>=2.1:devel/py-calendar \
- ${PYTHON_PKGNAMEPREFIX}PyGreSQL>=5.0:databases/py-PyGreSQL \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=2.5.3:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}pg8000>=1.10.6:databases/py-pg8000 \
- ${PYTHON_PKGNAMEPREFIX}psutil>=4.3.0:sysutils/py-psutil \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2016.7:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity \
- ${PYTHON_PKGNAMEPREFIX}setproctitle>=1.1.10:devel/py-setproctitle \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}twext>=0.20160817:devel/py-twext \
- ${PYTHON_PKGNAMEPREFIX}twisted>=16.4.1:devel/py-twisted \
- ${PYTHON_PKGNAMEPREFIX}xattr>=0.7.8:devel/py-xattr \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>=4.1.3:devel/py-zope.interface
+ ${PYTHON_PKGNAMEPREFIX}calendar>=2.1:devel/py-calendar@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}PyGreSQL>=5.0:databases/py-PyGreSQL@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.5.3:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pg8000>=1.10.6:databases/py-pg8000@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=4.3.0:sysutils/py-psutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2016.7:devel/py-pytz@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setproctitle>=1.1.10:devel/py-setproctitle@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twext>=0.20160817:devel/py-twext@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=16.4.1:devel/py-twisted@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xattr>=0.7.8:devel/py-xattr@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=4.1.3:devel/py-zope.interface@${FLAVOR}
PORTDOCS= *
PORTEXAMPLES= *