aboutsummaryrefslogtreecommitdiff
path: root/www/cgicc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-26 05:46:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-26 05:46:40 +0000
commit7d0ed49196e5083cf2cc2b6fdbadadfeeb4e1abe (patch)
tree99d618d0a1c052f97db672e0ff152b29a738a64f /www/cgicc
parent6217d334eb40cbef8d0374578b107e77da7b48f9 (diff)
downloadports-7d0ed49196e5083cf2cc2b6fdbadadfeeb4e1abe.tar.gz
ports-7d0ed49196e5083cf2cc2b6fdbadadfeeb4e1abe.zip
add cgicc
A C++ class library for writing CGI applications
Notes
Notes: svn path=/head/; revision=40388
Diffstat (limited to 'www/cgicc')
-rw-r--r--www/cgicc/Makefile24
-rw-r--r--www/cgicc/distinfo1
-rw-r--r--www/cgicc/pkg-comment1
-rw-r--r--www/cgicc/pkg-descr16
-rw-r--r--www/cgicc/pkg-plist23
5 files changed, 65 insertions, 0 deletions
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
new file mode 100644
index 000000000000..7e6caf545374
--- /dev/null
+++ b/www/cgicc/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# New ports collection makefile for: cgi++
+# Date created: Mar 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgicc
+PORTVERSION= 3.1.5
+CATEGORIES= www devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/www/cgicc/distinfo b/www/cgicc/distinfo
new file mode 100644
index 000000000000..143672eec225
--- /dev/null
+++ b/www/cgicc/distinfo
@@ -0,0 +1 @@
+MD5 (cgicc-3.1.5.tar.gz) = 6664f5c2fa61d9d9093a9d24b9b0718f
diff --git a/www/cgicc/pkg-comment b/www/cgicc/pkg-comment
new file mode 100644
index 000000000000..e729fefd49a2
--- /dev/null
+++ b/www/cgicc/pkg-comment
@@ -0,0 +1 @@
+A C++ class library for writing CGI applications
diff --git a/www/cgicc/pkg-descr b/www/cgicc/pkg-descr
new file mode 100644
index 000000000000..593ed26aa1c2
--- /dev/null
+++ b/www/cgicc/pkg-descr
@@ -0,0 +1,16 @@
+GNU cgicc is an ANSI C++ compliant class library that greatly simplifies
+the creation of CGI applications for the World Wide Web.
+
+cgicc performs the following functions:
+
+ - Parses both GET and POST form data transparently.
+ - Provides string, integer, floating-point and single- and multiple-choice
+ retrieval methods for form data.
+ - Provides methods for saving and restoring CGI environments to aid in
+ application debugging.
+ - Provides full on-the-fly HTML generation capabilities, with support for
+ cookies.
+ - Supports HTTP file upload.
+ - Compatible with FastCGI.
+
+WWW: http://www.gnu.org/software/cgicc/
diff --git a/www/cgicc/pkg-plist b/www/cgicc/pkg-plist
new file mode 100644
index 000000000000..a8726ca332a3
--- /dev/null
+++ b/www/cgicc/pkg-plist
@@ -0,0 +1,23 @@
+bin/cgicc-config
+include/cgicc/CgiDefs.h
+include/cgicc/CgiEnvironment.h
+include/cgicc/CgiUtils.h
+include/cgicc/Cgicc.h
+include/cgicc/FormEntry.h
+include/cgicc/FormFile.h
+include/cgicc/HTMLAttributes.h
+include/cgicc/HTMLClasses.h
+include/cgicc/HTMLElements.h
+include/cgicc/HTMLGeneric.h
+include/cgicc/HTTPHeaders.h
+include/cgicc/MStreamable.h
+@dirrm include/cgicc
+@unexec install-info --delete %D/info/cgicc.info %D/info/dir
+info/cgicc.info
+info/cgicc.info-1
+info/cgicc.info-2
+info/cgicc.info-3
+@exec install-info %D/info/cgicc.info %D/info/dir
+lib/libcgicc.a
+lib/libcgicc.so
+lib/libcgicc.so.2