aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-15 08:17:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-15 08:17:42 +0000
commite074896f3a1d1f36bce8037505906fbbce2740c3 (patch)
tree997059401be010bc79175cc2fbbeaf1269e6f69c /www/cherokee-devel
parent805b398386e9f1b8a2772f0f76b01732606853f7 (diff)
downloadports-e074896f3a1d1f36bce8037505906fbbce2740c3.tar.gz
ports-e074896f3a1d1f36bce8037505906fbbce2740c3.zip
- Update to 0.5.6
PR: ports/106731 Submitted by: Beech Rintoul <beech@alaskaparadise.com> (maintainer)
Notes
Notes: svn path=/head/; revision=179834
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile4
-rw-r--r--www/cherokee-devel/distinfo6
-rw-r--r--www/cherokee-devel/files/patch-cherokee-connection.c30
-rw-r--r--www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c10
-rw-r--r--www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c16
-rw-r--r--www/cherokee-devel/files/patch-cherokee-socket.c6
-rw-r--r--www/cherokee-devel/files/patch-cherokee-socket.h19
7 files changed, 17 insertions, 74 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index 769bc30ae37a..c8c01cdbfe5d 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.5.5
-PORTREVISION= 2
+PORTVERSION= 0.5.6
+PORTREVISION=
CATEGORIES= www
MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/ \
http://www.alaskaparadise.com/freebsd/
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
index 7d479d4ae9f4..ecafe009b942 100644
--- a/www/cherokee-devel/distinfo
+++ b/www/cherokee-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.5.5.tar.gz) = fb891b3da7eb921c09a5eb93e296f5e1
-SHA256 (cherokee-0.5.5.tar.gz) = e9c6feee2a626a38cd69c726ed31ffbbf55d288386f50fe6f90fa63de410d67a
-SIZE (cherokee-0.5.5.tar.gz) = 1559655
+MD5 (cherokee-0.5.6.tar.gz) = 0c5ae67c296f7e080900b23e533efd0b
+SHA256 (cherokee-0.5.6.tar.gz) = d19ac8a85c252ccfe04c06ce0ec9b03d036b27d07c6db4601ce7d6b33c4e9cc8
+SIZE (cherokee-0.5.6.tar.gz) = 1392282
diff --git a/www/cherokee-devel/files/patch-cherokee-connection.c b/www/cherokee-devel/files/patch-cherokee-connection.c
index dbf057093582..9d990d78957e 100644
--- a/www/cherokee-devel/files/patch-cherokee-connection.c
+++ b/www/cherokee-devel/files/patch-cherokee-connection.c
@@ -1,30 +1,10 @@
---- cherokee/connection.c.orig Wed Aug 30 17:12:13 2006
-+++ cherokee/connection.c Thu Nov 16 00:41:26 2006
-@@ -33,6 +33,9 @@
+--- cherokee/connection.c.orig Mon Dec 11 11:44:26 2006
++++ cherokee/connection.c Thu Dec 14 09:50:08 2006
+@@ -32,6 +32,7 @@
+ #include <fcntl.h>
#include <time.h>
#include <sys/types.h>
-
-+#include <stdlib.h>
+#include <limits.h>
-+
+
#ifdef HAVE_PWD_H
# include <pwd.h>
- #endif
-@@ -1210,7 +1213,7 @@
- }
- tmp[num_len] = '\0';
- if (num_len != 0) {
-- cnt->range_start = atoll (tmp);
-+ cnt->range_start = strtoll(tmp, (char **)NULL, 10);
- if (cnt->range_start < 0) {
- return ret_error;
- }
-@@ -1236,7 +1239,7 @@
- num_len++;
- }
- tmp[num_len] = '\0';
-- cnt->range_end = atoll (tmp);
-+ cnt->range_end = strtoll(tmp, (char **)NULL, 10);
- if (cnt->range_end < 1){
- return ret_error;
- }
diff --git a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c b/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
deleted file mode 100644
index 145916b5486b..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- cherokee/fdpoll-kqueue.c.orig Wed Sep 13 21:45:31 2006
-+++ cherokee/fdpoll-kqueue.c Wed Sep 13 21:45:13 2006
-@@ -27,6 +27,7 @@
- #include "fdpoll-protected.h"
-
- #include <stdio.h>
-+#include <sys/types.h>
- #include <sys/event.h>
- #include <sys/time.h>
- #include <unistd.h>
diff --git a/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c b/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
index f929a12f7e9f..29b5f24a660e 100644
--- a/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
+++ b/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
@@ -1,20 +1,12 @@
---- cherokee/handler_cgi_base.c.orig Fri Aug 18 15:21:03 2006
-+++ cherokee/handler_cgi_base.c Thu Nov 16 00:42:03 2006
-@@ -21,6 +21,8 @@
+--- cherokee/handler_cgi_base.c.orig Mon Dec 11 11:44:26 2006
++++ cherokee/handler_cgi_base.c Thu Dec 14 10:09:38 2006
+@@ -21,7 +21,8 @@
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
* USA
*/
+-
+#include <stdlib.h>
+#include <limits.h>
-
#include "common-internal.h"
#include "handler_cgi_base.h"
-@@ -578,7 +580,7 @@
- cherokee_buffer_t tmp = CHEROKEE_BUF_INIT;
-
- cherokee_buffer_add (&tmp, begin+16, end - (begin+16));
-- cgi->content_length = atoll (tmp.buf);
-+ cgi->content_length = strtoll(tmp.buf, (char **)NULL, 10);
- cherokee_buffer_mrproper (&tmp);
- cherokee_buffer_remove_chunk (buffer, begin - buffer->buf, end2 - begin);
diff --git a/www/cherokee-devel/files/patch-cherokee-socket.c b/www/cherokee-devel/files/patch-cherokee-socket.c
index 27451dba8e0c..c3d2ffb49222 100644
--- a/www/cherokee-devel/files/patch-cherokee-socket.c
+++ b/www/cherokee-devel/files/patch-cherokee-socket.c
@@ -1,6 +1,6 @@
---- cherokee/socket.c.orig Wed Sep 13 21:48:51 2006
-+++ cherokee/socket.c Wed Sep 13 22:06:35 2006
-@@ -1122,13 +1122,17 @@
+--- cherokee/socket.c.orig Thu Dec 7 09:46:29 2006
++++ cherokee/socket.c Thu Dec 14 10:35:48 2006
+@@ -1153,13 +1153,17 @@
cherokee_socket_init_client_tls (cherokee_socket_t *socket)
{
#ifdef HAVE_TLS
diff --git a/www/cherokee-devel/files/patch-cherokee-socket.h b/www/cherokee-devel/files/patch-cherokee-socket.h
deleted file mode 100644
index 1d3eb1b24ad0..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-socket.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- cherokee/socket.h.orig Sun Mar 6 08:09:33 2005
-+++ cherokee/socket.h Fri Apr 1 13:09:44 2005
-@@ -45,12 +45,12 @@
- # include <sys/socket.h>
- #endif
-
--#ifdef HAVE_ARPA_INET_H
--# include <arpa/inet.h>
--#endif
--
- #ifdef HAVE_NETINET_IN_H
- # include <netinet/in.h>
-+#endif
-+
-+#ifdef HAVE_ARPA_INET_H
-+# include <arpa/inet.h>
- #endif
-
- #if defined(HAVE_GNUTLS)