aboutsummaryrefslogtreecommitdiff
path: root/www/chimera2
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-26 07:53:35 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-26 07:53:35 +0000
commit9a863ddecfc5dcb5e1f5897b1f443a90d31c15d1 (patch)
tree4b597c3cf91b4bcd79a90650afed3adb62b47943 /www/chimera2
parent8a39b66a7027031323dc6a397e3ceaff4d99d837 (diff)
downloadports-9a863ddecfc5dcb5e1f5897b1f443a90d31c15d1.tar.gz
ports-9a863ddecfc5dcb5e1f5897b1f443a90d31c15d1.zip
Bring in changes for chimera-2.0a11. A repository copy from
ports/www/chimera was done before. PR: 4248 Submitted by: Bruce Gingery <bgingery@gtcs.com>
Notes
Notes: svn path=/head/; revision=8837
Diffstat (limited to 'www/chimera2')
-rw-r--r--www/chimera2/Makefile24
-rw-r--r--www/chimera2/distinfo2
-rw-r--r--www/chimera2/files/patch-aa72
-rw-r--r--www/chimera2/files/patch-ad42
-rw-r--r--www/chimera2/files/patch-ae12
-rw-r--r--www/chimera2/files/protopng.h3
-rw-r--r--www/chimera2/pkg-comment2
-rw-r--r--www/chimera2/pkg-descr20
-rw-r--r--www/chimera2/pkg-plist12
9 files changed, 134 insertions, 55 deletions
diff --git a/www/chimera2/Makefile b/www/chimera2/Makefile
index 854576428987..f3838030fed3 100644
--- a/www/chimera2/Makefile
+++ b/www/chimera2/Makefile
@@ -1,17 +1,25 @@
# New ports collection makefile for: chimera
-# Version required: 1.65
-# Date created: 26 December 1994
-# Whom: asami
+# Version required: 2.0a11
+# Date created: 24 Nov 1997
+# Whom: Bruce Gingery <bgingery@gtcs.com>
#
-# $Id: Makefile,v 1.10 1995/11/27 04:10:19 asami Exp $
+# $Id: Makefile,v 1.11 1996/11/18 11:40:48 asami Exp $
#
-DISTNAME= chimera-1.65
-CATEGORIES= www
-MASTER_SITES= ftp://ftp.cs.unlv.edu/pub/chimera/
+DISTNAME= chimera-2.0a11
+CATEGORIES= www x11
+MASTER_SITES= ftp://ftp.cs.unlv.edu/pub/chimera-alpha/
-MAINTAINER= asami@FreeBSD.ORG
+MAINTAINER= bgingery@gtcs.com
+
+LIB_DEPENDS= jpeg\\.[67]\\.:${PORTSDIR}/graphics/jpeg \
+ png\\.0\\.:${PORTSDIR}/graphics/png
USE_IMAKE= yes
+post-patch:
+ ${MV} ${WRKSRC}/Common.tmpl.dist ${WRKSRC}/Common.tmpl
+ ${CP} ${FILESDIR}/protopng.h ${WRKSRC}/image/
+ ln -s ${WRKSRC}/chimera ${WRKSRC}/main
+
.include <bsd.port.mk>
diff --git a/www/chimera2/distinfo b/www/chimera2/distinfo
index 61984a5d61a0..a8d3e7e96423 100644
--- a/www/chimera2/distinfo
+++ b/www/chimera2/distinfo
@@ -1 +1 @@
-MD5 (chimera-1.65.tar.gz) = 38b67ecb961ea52803a3c815076cc9fa
+MD5 (chimera-2.0a11.tar.gz) = c422accc01edcf2be5dfcea6df42f0cc
diff --git a/www/chimera2/files/patch-aa b/www/chimera2/files/patch-aa
index 6de08afc4cb0..1ef00250be02 100644
--- a/www/chimera2/files/patch-aa
+++ b/www/chimera2/files/patch-aa
@@ -1,22 +1,50 @@
---- ./Common.tmpl.dist.org Sat Apr 1 19:20:24 1995
-+++ ./Common.tmpl.dist Tue Apr 4 07:51:01 1995
-@@ -80,7 +80,7 @@
- #define NEED_STRCASECMP 0
-
- CEXTRA_DEFINES = -DHAVE_MKTIME -DHAVE_STDLIB_H -DHAVE_STRING_H \
-- -DHAVE_UNISTD_H -DHAVE_MALLOC_H
-+ -DHAVE_UNISTD_H
-
- /*
- * OSF1 needs -D_BSD
---- ./compat/Imakefile.org Mon Mar 13 19:48:00 1995
-+++ ./compat/Imakefile Wed Jun 11 12:42:13 1997
-@@ -31,7 +31,7 @@
-
- DependTarget()
- #else
--all:
-+all::
-
- depend::
- #endif
+*** Imakefile.orig Sun Aug 17 23:18:18 1997
+--- Imakefile Mon Nov 24 10:34:00 1997
+***************
+*** 4,10 ****
+
+ #if HasGcc
+ #ifdef CDebugging
+! #define PassCDebugFlags "CDEBUGFLAGS=-g -Wall"
+ #else
+ #define PassCDebugFlags "CDEBUGFLAGS=-O -Wall"
+ #endif
+--- 4,10 ----
+
+ #if HasGcc
+ #ifdef CDebugging
+! #define PassCDebugFlags "CDEBUGFLAGS=-g -Wall ${CFLAGS}"
+ #else
+ #define PassCDebugFlags "CDEBUGFLAGS=-O -Wall"
+ #endif
+***************
+*** 19,32 ****
+ SUBDIRS = port common image html plain proto mxw chimera
+
+ MakeSubdirs($(SUBDIRS))
+! InstallSubdirs($(SUBDIRS))
+ DependSubdirs($(SUBDIRS))
+ CleanSubdirs($(SUBDIRS))
+ MakefileSubdirs($(SUBDIRS))
+! InstallManSubdirs($(SUBDIRS))
+
+ myclean: clean
+ $(RM) Common.tmpl Makefile Makefile.bak make.err make.out .depend
+! for i in $(SUBDIRS); do \
+ $(RM) $$i/Makefile $$i/Makefile.bak $$i/.depend; \
+ done
+--- 19,32 ----
+ SUBDIRS = port common image html plain proto mxw chimera
+
+ MakeSubdirs($(SUBDIRS))
+! InstallSubdirs(main)
+ DependSubdirs($(SUBDIRS))
+ CleanSubdirs($(SUBDIRS))
+ MakefileSubdirs($(SUBDIRS))
+! InstallManSubdirs(main)
+
+ myclean: clean
+ $(RM) Common.tmpl Makefile Makefile.bak make.err make.out .depend
+! for i in $(SUBDIRS) $(SOSUBDIRS); do \
+ $(RM) $$i/Makefile $$i/Makefile.bak $$i/.depend; \
+ done
diff --git a/www/chimera2/files/patch-ad b/www/chimera2/files/patch-ad
index 7a67c9b1c42c..f24de4b7166c 100644
--- a/www/chimera2/files/patch-ad
+++ b/www/chimera2/files/patch-ad
@@ -1,11 +1,33 @@
---- ./src/url.c.org Sun Mar 26 01:26:06 1995
-+++ ./src/url.c Fri Sep 22 23:53:00 1995
-@@ -173,7 +173,7 @@
- }
+--- Common.tmpl.dist.orig Mon Sep 29 01:32:46 1997
++++ Common.tmpl.dist Tue Nov 25 09:13:24 1997
+@@ -35,22 +35,22 @@
+ */
- len = strlen(protocol) + strlen(hostname) + strlen(filename) +
-- strlen(delim) + 11;
-+ strlen(anchor) + strlen(delim) + strlen(delim2) + strlen(delim3) + 11;
- u = alloc_mem(len + 1);
- if (up->port == 0)
- {
+ /* Uncomment and modify if you have the JPEG 6 library */
+-/*
++
+ #define Use_JPEG
+ JPEGDIR = /usr/local
+ JPEGINCLUDE = -I$(JPEGDIR)/include
+-JPEGLIB = -L$(JPEGDIR)/lib -ljpeg$(IMGLEXT)
+-JPEGDEPLIB = $(JPEGDIR)/lib/libjpeg$(IMGLEXT).a
+-*/
++JPEGLIB = -L$(JPEGDIR)/lib -ljpeg
++JPEGDEPLIB = $(JPEGDIR)/lib/libjpeg.a
++
+
+ /* Uncomment and modify if you have the PNG library */
+-/*
++
+ #define Use_PNG
+ PNGDIR = /usr/local
+ PNGINCLUDE = -I$(PNGDIR)/include
+-PNGLIB = -L$(PNGDIR)/lib -lpng$(IMGLEXT) -lz$(IMGLEXT)
+-PNGDEPLIB = $(PNGDIR)/lib/libpng$(IMGLEXT).a $(PNGDIR)/lib/libz$(IMGLEXT).a
+-*/
++PNGLIB = -L$(PNGDIR)/lib -lpng -lz
++PNGDEPLIB = $(PNGDIR)/lib/libpng.a /usr/lib/libz.a
++
+
+ /*
+ * Uncomment if you need GNU rx. Not actually used right now.
diff --git a/www/chimera2/files/patch-ae b/www/chimera2/files/patch-ae
new file mode 100644
index 000000000000..882497c8d6e6
--- /dev/null
+++ b/www/chimera2/files/patch-ae
@@ -0,0 +1,12 @@
+--- chimera/Imakefile.orig Sun Aug 17 07:10:31 1997
++++ chimera/Imakefile Tue Nov 25 09:23:32 1997
+@@ -19,7 +19,7 @@
+
+ NormalProgramTarget(chimera, $(OBJS), $(CHIMERA_DEPLIBS), MyNull, MyNull)
+
+-InstallProgram(chimera,$(CHIMERA_BINDIR))
+-InstallManPage(chimera,$(CHIMERA_MANDIR))
++InstallProgram(chimera,$(BINDIR))
++InstallManPage(chimera,$(MANDIR))
+
+ DependTarget()
diff --git a/www/chimera2/files/protopng.h b/www/chimera2/files/protopng.h
new file mode 100644
index 000000000000..11c00cfa45aa
--- /dev/null
+++ b/www/chimera2/files/protopng.h
@@ -0,0 +1,3 @@
+/* Eliminate a couple of errors from image/image.c for missing prototype */
+#include "image_format.h"
+void pngInit(void (*lineProc)(void *, int, int), void *closure, struct ifs_vector *ifsv);
diff --git a/www/chimera2/pkg-comment b/www/chimera2/pkg-comment
index 6e188068e4d5..a1715551aaf0 100644
--- a/www/chimera2/pkg-comment
+++ b/www/chimera2/pkg-comment
@@ -1 +1 @@
-X/Athena World-Wide Web client
+X/Athena World-Wide Web client - Wilbur (HTML3.2) compliant
diff --git a/www/chimera2/pkg-descr b/www/chimera2/pkg-descr
index 303aade1fb34..9a48ed99f94b 100644
--- a/www/chimera2/pkg-descr
+++ b/www/chimera2/pkg-descr
@@ -2,4 +2,22 @@ Chimera is a program which allows a user to access World-Wide Web servers
and other information servers. It presents the user with a point-and-click
graphical interface using the X Window System and the Athena Widgets.
-This is version 1.65.
+While it does NOT do Frames, Java, JavaScript, or even embedded Tcl
+(yet at least), it *is* designed to be ``Wilbur'' (HTML v3.2) compliant,
+and handles .gif, .jpg and quite a number of other image formats
+internally. Yet image handling is a little odd, as compared to other
+browsers. Each image is *often* surrounded by scrollbars, rather than
+being resized to a specified size. Hence it makes a good visual tool
+for proper sizing information.
+
+THIS IS AN ALPHA VERSION - so don't be surprised if something doesn't
+properly work OTOH, it *does* do tables and forms, and multiple windows.
+
+Unlike version 1.65 previously distributed, it is an all-in-one binary
+and depends upon X- resources settings for configuration. It may
+be touchy about interrupted image fetches, or other things, as well.
+Each user is expected to create a ~/.chimera subdirectory for
+bookmarks and personal preferences, and a ~/.chimera/cache (which may
+be a symlink to somewhere else).
+
+Ref: <URL: http://www.unlv.edu/chimera/two/ >
diff --git a/www/chimera2/pkg-plist b/www/chimera2/pkg-plist
index 464a2c00cba1..8ebb57d417d2 100644
--- a/www/chimera2/pkg-plist
+++ b/www/chimera2/pkg-plist
@@ -1,14 +1,2 @@
bin/chimera
-lib/cacheinfo
-lib/convert
-lib/help.html
-lib/home.html
-lib/mailcap
-lib/mime.types
-lib/protocol
-lib/chimera/Chimera
-lib/chimera/do3270
-lib/chimera/dotelnet
-lib/chimera/playaudio
-lib/chimera/pstopxm
man/man1/chimera.1.gz