aboutsummaryrefslogtreecommitdiff
path: root/www/conkeror
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 10:52:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 10:52:03 +0000
commitc46fbde3ff282d76904d2900e0aa6bc0952f96c4 (patch)
treea1a85a9be9053e20069fd6b858459aa0b0e2d71b /www/conkeror
parente7997481e1affa5d58746a9c0758032cb3dedc07 (diff)
downloadports-c46fbde3ff282d76904d2900e0aa6bc0952f96c4.tar.gz
ports-c46fbde3ff282d76904d2900e0aa6bc0952f96c4.zip
Conkeror is a mozilla based web browser designed to be
completely keyboard driven, no compromises. It also strives to behave as much like Emacs as possible. This means all the keybindings and to-die-for features of Emacs that can be imitated by a javascript/XUL web browser Just Work. WWW: http://conkeror.mozdev.org/ PR: ports/96462 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Notes
Notes: svn path=/head/; revision=160736
Diffstat (limited to 'www/conkeror')
-rw-r--r--www/conkeror/Makefile34
-rw-r--r--www/conkeror/distinfo3
-rw-r--r--www/conkeror/files/chrome.manifest2
-rw-r--r--www/conkeror/pkg-descr8
4 files changed, 47 insertions, 0 deletions
diff --git a/www/conkeror/Makefile b/www/conkeror/Makefile
new file mode 100644
index 000000000000..9737d2f3337e
--- /dev/null
+++ b/www/conkeror/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: conkeror
+# Date created: 27 April 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= conkeror
+PORTVERSION= 0.30
+DISTVERSIONPREFIX= firefox-
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_MOZDEV}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX?=
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A completely keyboard driven browser based on firefox
+
+RUN_DEPENDS= ${CONK_APP}:${PORTSDIR}/www/${CONK_APP}
+
+CONK_ARGS= -chrome chrome://conkeror/content
+CONK_APP?= ${PKGNAMEPREFIX}firefox
+CONK_EXEC?= ${PKGNAMEPREFIX}${PORTNAME}
+PLIST_FILES= bin/${CONK_EXEC}
+XPI_ID= {a79fe89b-6662-4ff4-8e88-09950ad4dfde}
+XPI_FILES= chrome/conkeror.jar components/nsCrank.js install.rdf chrome.manifest
+XPI_DIRS= chrome components
+
+post-install:
+ @${ECHO_CMD} exec `${WHICH} ${CONK_APP}` ${CONK_ARGS} > ${PREFIX}/bin/${CONK_EXEC}
+ @${CHMOD} 555 ${PREFIX}/bin/${CONK_EXEC}
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/conkeror/distinfo b/www/conkeror/distinfo
new file mode 100644
index 000000000000..96c068dcb276
--- /dev/null
+++ b/www/conkeror/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/conkeror-firefox-0.30.xpi) = 9bd31964885f453c96772a383afc623a
+SHA256 (xpi/conkeror-firefox-0.30.xpi) = 0b6ccb9a3baaa392d08f0bbac9c3e9eaddca2179194db846c62783b32aa9431a
+SIZE (xpi/conkeror-firefox-0.30.xpi) = 55923
diff --git a/www/conkeror/files/chrome.manifest b/www/conkeror/files/chrome.manifest
new file mode 100644
index 000000000000..32155b6ff37d
--- /dev/null
+++ b/www/conkeror/files/chrome.manifest
@@ -0,0 +1,2 @@
+
+content conkeror jar:chrome/conkeror.jar!/conkeror/content/
diff --git a/www/conkeror/pkg-descr b/www/conkeror/pkg-descr
new file mode 100644
index 000000000000..2d3792ce2c5b
--- /dev/null
+++ b/www/conkeror/pkg-descr
@@ -0,0 +1,8 @@
+Conkeror is a mozilla based web browser designed to be
+completely keyboard driven, no compromises. It also
+strives to behave as much like Emacs as possible. This
+means all the keybindings and to-die-for features of
+Emacs that can be imitated by a javascript/XUL web
+browser Just Work.
+
+WWW: http://conkeror.mozdev.org/