aboutsummaryrefslogtreecommitdiff
path: root/www/crawl
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2005-06-02 20:14:55 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2005-06-02 20:14:55 +0000
commita210c68356ff0dded5c7b63ac4b2d501473a84e2 (patch)
tree164b2b2847147e34190e5a058fe3dc8a8e1bec68 /www/crawl
parent90da95b6615d58cff9154218d6beacdf3f753780 (diff)
downloadports-a210c68356ff0dded5c7b63ac4b2d501473a84e2.tar.gz
ports-a210c68356ff0dded5c7b63ac4b2d501473a84e2.zip
Our getaddrinfo(3) never returns EAI_NODATA on 5.2-RELEASE and
later as RFC 3493 deprecated it. So, we have to see EAI_NONAME instead. Approved by: petef
Notes
Notes: svn path=/head/; revision=136687
Diffstat (limited to 'www/crawl')
-rw-r--r--www/crawl/Makefile1
-rw-r--r--www/crawl/files/patch-dns.c24
2 files changed, 16 insertions, 9 deletions
diff --git a/www/crawl/Makefile b/www/crawl/Makefile
index 41d4abeed506..f8fa798b1826 100644
--- a/www/crawl/Makefile
+++ b/www/crawl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crawl
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.monkey.org/~provos/
diff --git a/www/crawl/files/patch-dns.c b/www/crawl/files/patch-dns.c
index c061817985fa..e7d5108de553 100644
--- a/www/crawl/files/patch-dns.c
+++ b/www/crawl/files/patch-dns.c
@@ -1,12 +1,18 @@
$FreeBSD$
---- dns.c.orig Fri Mar 12 07:29:07 2004
-+++ dns.c Fri Mar 12 07:29:19 2004
-@@ -46,6 +46,7 @@
- #include "tree.h"
- #include "http.h"
- #include "dns.h"
-+#include "getaddrinfo.h"
-
- ssize_t atomicio(ssize_t (*f)(), int, void *, size_t);
+--- dns.c.orig Sun May 18 10:21:33 2003
++++ dns.c Mon May 30 16:20:14 2005
+@@ -562,8 +562,13 @@
+ if (res != 0) {
+ fprintf(stderr, "%s: getaddrinfo(%s): %s\n", __func__,
+ ip, gai_strerror(res));
++#ifdef EAI_NODATA
+ if (res != EAI_NODATA)
+ return (-1);
++#else
++ if (res != EAI_NONAME)
++ return (-1);
++#endif
+ /* Negative caching */
+ ai = NULL;