aboutsummaryrefslogtreecommitdiff
path: root/www/cssed
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-30 01:03:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-30 01:03:58 +0000
commitcd77cdc855c8fff3f3d6f772fdd4ac402d17a9ca (patch)
treebe41cbaf69c3e0cdffc1c8c3be279c151befc2e0 /www/cssed
parentad8f963bdca3e4c760c490d0392911cd56d141d3 (diff)
downloadports-cd77cdc855c8fff3f3d6f772fdd4ac402d17a9ca.tar.gz
ports-cd77cdc855c8fff3f3d6f772fdd4ac402d17a9ca.zip
add cssed 0.2.1
An application to help CSS style sheets creation and maintenance
Notes
Notes: svn path=/head/; revision=115049
Diffstat (limited to 'www/cssed')
-rw-r--r--www/cssed/Makefile36
-rw-r--r--www/cssed/distinfo2
-rw-r--r--www/cssed/pkg-descr8
3 files changed, 46 insertions, 0 deletions
diff --git a/www/cssed/Makefile b/www/cssed/Makefile
new file mode 100644
index 000000000000..34b18955f585
--- /dev/null
+++ b/www/cssed/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: cssed
+# Date created: Jul 29, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cssed
+PORTVERSION= 0.2.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An application to help CSS style sheets creation and maintenance
+
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/cssed share/locale/es/LC_MESSAGES/cssed.mo share/locale/fr/LC_MESSAGES/cssed.mo
+MAN1= cssed.1
+
+post-install:
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/cssed/distinfo b/www/cssed/distinfo
new file mode 100644
index 000000000000..613b63a69f88
--- /dev/null
+++ b/www/cssed/distinfo
@@ -0,0 +1,2 @@
+MD5 (cssed-0.2.1.tar.gz) = dd799e6cdbb2ea6e9e13b0bf22af8493
+SIZE (cssed-0.2.1.tar.gz) = 783510
diff --git a/www/cssed/pkg-descr b/www/cssed/pkg-descr
new file mode 100644
index 000000000000..a48bbcd38224
--- /dev/null
+++ b/www/cssed/pkg-descr
@@ -0,0 +1,8 @@
+CSSED is a small developer editor and validator, which tries to ease the CSS
+editing.
+
+It features syntax highlighting, syntax validation, MDI notebook based
+interface, quick CSS properties and values insertion, auto-completion and
+dialog-based insertion of CSS complex values.
+
+WWW: http://cssed.sourceforge.net/