aboutsummaryrefslogtreecommitdiff
path: root/www/davical
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-06-18 06:38:40 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-06-18 06:38:40 +0000
commit928e147ce742a9a9b492a604e702fbe45af7447e (patch)
tree757a3ad3a72b0f817567c814e02eeb20f4eb3c1e /www/davical
parent26b34774b8b9b28355fcb527d55670c0a2ace8e0 (diff)
downloadports-928e147ce742a9a9b492a604e702fbe45af7447e.tar.gz
ports-928e147ce742a9a9b492a604e702fbe45af7447e.zip
New port: www/davical A simple CalDAV server
DAViCal is a CalDAV server. It cal be used to support shared calendars for iCal Evolution etc. There have been many requests for a CalDAV server for FreeBSD. PR: ports/123692 Submitted by: Maurice Castro <maurice@castro.aus.net>
Notes
Notes: svn path=/head/; revision=215045
Diffstat (limited to 'www/davical')
-rw-r--r--www/davical/Makefile55
-rw-r--r--www/davical/distinfo6
-rw-r--r--www/davical/files/httpd-davical.conf.in11
-rw-r--r--www/davical/files/patch-aa11
-rw-r--r--www/davical/files/pkg-message.in28
-rw-r--r--www/davical/pkg-descr4
-rw-r--r--www/davical/pkg-plist165
7 files changed, 280 insertions, 0 deletions
diff --git a/www/davical/Makefile b/www/davical/Makefile
new file mode 100644
index 000000000000..2b9be0de11f5
--- /dev/null
+++ b/www/davical/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: davical
+# Date created: Tue May 13 09:59:22 EST 2008
+# Whom: Maurice Castro <maurice@castro.aus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= davical
+PORTVERSION= 0.9.4
+CATEGORIES?= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rscds
+DISTNAME= libawl-php-0.25.tar.gz \
+ rscds-${PORTVERSION}
+
+MAINTAINER= maurice@castro.aus.net
+COMMENT= A simple CalDAV server using a postgres backend
+
+RUN_DEPENDS= ${LOCALBASE}/include/php/ext/pgsql:${PORTSDIR}/databases/php5-pgsql \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
+ ${LOCALBASE}/bin/pwgen:${PORTSDIR}/sysutils/pwgen
+
+NO_BUILD= yes
+
+SUB_FILES= pkg-message httpd-davical.conf
+WRKSRC= ${WRKDIR}/rscds-${PORTVERSION}
+
+DAVICALDIR?= ${PREFIX}/www/${PORTNAME}
+DOCDIR?= ${PREFIX}/share/doc/DAViCal
+
+do-install:
+ ${MKDIR} ${DAVICALDIR}
+ ${CP} -rpv ${WRKSRC}/htdocs ${DAVICALDIR}
+ ${RM} ${DAVICALDIR}/htdocs/*.orig
+ ${CP} -rpv ${WRKSRC}/inc ${DAVICALDIR}
+ ${CP} -rpv ${WRKDIR}/libawl-php-0.25/inc ${DAVICALDIR}
+ ${CP} -rpv ${WRKDIR}/libawl-php-0.25/dba ${DAVICALDIR}
+ ${MKDIR} ${DAVICALDIR}/config
+ ${CP} -pv ${WRKSRC}/config/example-config.php ${DAVICALDIR}/config/config.php
+ ${MKDIR} ${DOCDIR}
+ ${CP} -prv ${WRKSRC}/config ${DOCDIR}
+ ${CP} -prv ${WRKSRC}/docs ${DOCDIR}
+ ${CP} -prv ${WRKSRC}/scripts ${DOCDIR}
+ ${CP} -prv ${WRKSRC}/dba ${DOCDIR}
+ ${SED} 's:AWLDIR="$${DBADIR}/../../awl":AWLDIR="${PREFIX}/www/davical":' ${WRKSRC}/dba/create-database.sh > ${DOCDIR}/dba/create-database.sh
+ ${CP} -pv ${WRKDIR}/httpd-davical.conf ${DOCDIR}
+ ${CP} -pv ${WRKSRC}/README ${DOCDIR}
+ ${CP} -pv ${WRKSRC}/INSTALL ${DOCDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/davical/distinfo b/www/davical/distinfo
new file mode 100644
index 000000000000..0131fd0dc64c
--- /dev/null
+++ b/www/davical/distinfo
@@ -0,0 +1,6 @@
+MD5 (libawl-php-0.25.tar.gz) = 653bd18a3c85978c57c4bf15454fcf08
+SHA256 (libawl-php-0.25.tar.gz) = 380d5521c0dcfbdc95c89565ee70d881807bec983f1a4a2ef75b527cd71663aa
+SIZE (libawl-php-0.25.tar.gz) = 65725
+MD5 (rscds-0.9.4.tar.gz) = 6f133ea5e64bbb153dadab230e6afeda
+SHA256 (rscds-0.9.4.tar.gz) = 719cecaf22714286a10add824aab3e0153aa37979108c26e199438c4bf6c578e
+SIZE (rscds-0.9.4.tar.gz) = 646086
diff --git a/www/davical/files/httpd-davical.conf.in b/www/davical/files/httpd-davical.conf.in
new file mode 100644
index 000000000000..c951014ca256
--- /dev/null
+++ b/www/davical/files/httpd-davical.conf.in
@@ -0,0 +1,11 @@
+# Settings for davical
+#
+
+Alias /davical "%%PREFIX%%/www/davical/htdocs"
+
+<Directory "%%PREFIX%%/www/davical/htdocs">
+ Options Indexes FollowSymLinks MultiViews
+ AllowOverride All
+ Order allow,deny
+ Allow from all
+</Directory>
diff --git a/www/davical/files/patch-aa b/www/davical/files/patch-aa
new file mode 100644
index 000000000000..dbaa8577e542
--- /dev/null
+++ b/www/davical/files/patch-aa
@@ -0,0 +1,11 @@
+--- htdocs/index.php.orig 2008-05-14 12:54:41.000000000 +1000
++++ htdocs/index.php 2008-05-14 12:55:01.000000000 +1000
+@@ -31,7 +31,7 @@
+
+ <h3>Users, Resources and Groups</h3>
+ <p>These are the things which may have collections of calendar resources (i.e. calendars).</p>
+-<p><a href="../users.php">Here is a list of users (maybe :-)</a>. You can click on any user to see the full detail
++<p><a href="users.php">Here is a list of users (maybe :-)</a>. You can click on any user to see the full detail
+ for that person (or group or resource - but from now we'll just call them users).</p>
+ <p>The primary differences between them are as follows:</p>
+ <ul>
diff --git a/www/davical/files/pkg-message.in b/www/davical/files/pkg-message.in
new file mode 100644
index 000000000000..8ebc23bd9346
--- /dev/null
+++ b/www/davical/files/pkg-message.in
@@ -0,0 +1,28 @@
+To complete the installation of DAViCal:
+
+1. Create the database user:
+
+ createuser -U pgsql -S --no-createdb --no-createrole general
+
+2. Create DAViCal's database
+
+ su pgsql %%PREFIX%%/share/doc/DAViCal/dba/create-database.sh
+
+3. Fix permissions
+
+ psql -U pgsql davical -c "grant all on \
+ awl_db_revision, caldav_data, calendar_item, collection, \
+ dav_resource, dav_resource_type, freebusy_ticket, \
+ group_member, locks, principal, principal_type, privilege, \
+ property, relationship, relationship_type, role_member, \
+ roles, session, supported_locales, time_zone, tmp_password, \
+ usr, usr_setting, dav_id_seq, dav_resource_type_resource_type_id_seq, \
+ principal_principal_id_seq, principal_type_principal_type_id_seq, \
+ relationship_type_rt_id_seq, roles_role_no_seq, \
+ session_session_id_seq, usr_user_no_seq \
+ to general;"
+
+ psql -U pgsql davical -c "grant all on database davical to general;"
+
+6. Enable in apache by copying the httpd-davical.conf from the
+documentation directory to the Apache Include directory and restart Apache.
diff --git a/www/davical/pkg-descr b/www/davical/pkg-descr
new file mode 100644
index 000000000000..bdd8fc6f0b1e
--- /dev/null
+++ b/www/davical/pkg-descr
@@ -0,0 +1,4 @@
+DAViCal is a PHP based CalDAV server which uses a Postgres backend.
+It is administered using a Web interface.
+
+WWW: http://rscds.sourceforge.net/
diff --git a/www/davical/pkg-plist b/www/davical/pkg-plist
new file mode 100644
index 000000000000..3cd6007230c3
--- /dev/null
+++ b/www/davical/pkg-plist
@@ -0,0 +1,165 @@
+share/doc/DAViCal/config/debug-config.php
+share/doc/DAViCal/config/example-administration.yml
+share/doc/DAViCal/config/example-config.php
+share/doc/DAViCal/config/other-config.php
+share/doc/DAViCal/docs/api/phpdoc.ini
+share/doc/DAViCal/docs/website/images/logo.gif
+share/doc/DAViCal/docs/website/inc/page-footer.php
+share/doc/DAViCal/docs/website/inc/page-header.php
+share/doc/DAViCal/docs/website/inc/page-middle.php
+share/doc/DAViCal/docs/website/clients/iCal-screenshot.png
+share/doc/DAViCal/docs/website/clients/Chandler-dialog1.png
+share/doc/DAViCal/docs/website/clients/Chandler-dialog2.png
+share/doc/DAViCal/docs/website/clients/Chandler-dialog3.png
+share/doc/DAViCal/docs/website/clients/Chandler-icon.png
+share/doc/DAViCal/docs/website/clients/Chandler-screenshot.png
+share/doc/DAViCal/docs/website/clients/Evolution-details.php
+share/doc/DAViCal/docs/website/clients/Evolution-dialog1.png
+share/doc/DAViCal/docs/website/clients/Evolution-icon.png
+share/doc/DAViCal/docs/website/clients/Evolution-screenshot.png
+share/doc/DAViCal/docs/website/clients/Interoperability-details.php
+share/doc/DAViCal/docs/website/clients/Mozilla-details.php
+share/doc/DAViCal/docs/website/clients/Mozilla-dialog1.png
+share/doc/DAViCal/docs/website/clients/Mozilla-dialog2.png
+share/doc/DAViCal/docs/website/clients/Mozilla-dialog3.png
+share/doc/DAViCal/docs/website/clients/iCal-dialog.png
+share/doc/DAViCal/docs/website/clients/Mozilla-icon.png
+share/doc/DAViCal/docs/website/clients/Mozilla-screenshot.png
+share/doc/DAViCal/docs/website/clients/Mulberry-details.php
+share/doc/DAViCal/docs/website/clients/Mulberry-dialog1.png
+share/doc/DAViCal/docs/website/clients/Mulberry-dialog2.png
+share/doc/DAViCal/docs/website/clients/Mulberry-icon.png
+share/doc/DAViCal/docs/website/clients/Mulberry-screenshot.png
+share/doc/DAViCal/docs/website/clients/Other-details.php
+share/doc/DAViCal/docs/website/clients/iCal-details.php
+share/doc/DAViCal/docs/website/clients/iCal-icon.png
+share/doc/DAViCal/docs/website/clients/Chandler-details.php
+share/doc/DAViCal/docs/website/installation.php
+share/doc/DAViCal/docs/website/style.css
+share/doc/DAViCal/docs/website/administration.php
+share/doc/DAViCal/docs/website/wikiheader.css
+share/doc/DAViCal/docs/website/clients.php
+share/doc/DAViCal/docs/website/index.php
+share/doc/DAViCal/scripts/po/extract.pl
+share/doc/DAViCal/scripts/po/rebuild-translations.sh
+share/doc/DAViCal/dba/patches/1.2.2.sql
+share/doc/DAViCal/dba/patches/1.1.11.sql
+share/doc/DAViCal/dba/patches/1.1.11a.sql
+share/doc/DAViCal/dba/patches/1.1.12.sql
+share/doc/DAViCal/dba/patches/1.1.12a.sql
+share/doc/DAViCal/dba/patches/1.1.2.sql
+share/doc/DAViCal/dba/patches/1.1.3.sql
+share/doc/DAViCal/dba/patches/1.1.4.sql
+share/doc/DAViCal/dba/patches/1.1.5.sql
+share/doc/DAViCal/dba/patches/1.1.6.sql
+share/doc/DAViCal/dba/patches/1.1.7.sql
+share/doc/DAViCal/dba/patches/1.1.8.sql
+share/doc/DAViCal/dba/patches/1.1.9.sql
+share/doc/DAViCal/dba/patches/1.2.1.sql
+share/doc/DAViCal/dba/patches/1.1.10.sql
+share/doc/DAViCal/dba/windows/awl-tables.sql
+share/doc/DAViCal/dba/windows/create-database.bat
+share/doc/DAViCal/dba/windows/rscds.sql
+share/doc/DAViCal/dba/windows/schema-management.sql
+share/doc/DAViCal/dba/appuser_permissions.txt
+share/doc/DAViCal/dba/create-database.sh
+share/doc/DAViCal/dba/davical.sql
+share/doc/DAViCal/dba/base-data.sql
+share/doc/DAViCal/dba/rrule_functions.sql
+share/doc/DAViCal/dba/sample-data.sql
+share/doc/DAViCal/dba/supported_locales.sql
+share/doc/DAViCal/dba/update-rscds-database
+share/doc/DAViCal/dba/caldav_functions.sql
+share/doc/DAViCal/httpd-davical.conf
+share/doc/DAViCal/README
+share/doc/DAViCal/INSTALL
+www/davical/htdocs/images/down.gif
+www/davical/htdocs/images/up.gif
+www/davical/htdocs/css/browse.css
+www/davical/htdocs/js/browse.js
+www/davical/htdocs/help.php
+www/davical/htdocs/index.php
+www/davical/htdocs/relationship_types.php
+www/davical/htdocs/roles.php
+www/davical/htdocs/rscds.css
+www/davical/htdocs/tools.php
+www/davical/htdocs/users.php
+www/davical/htdocs/caldav.php
+www/davical/htdocs/usr.php
+www/davical/htdocs/collection.php
+www/davical/htdocs/freebusy.php
+www/davical/inc/test-RRULE.php
+www/davical/inc/CalDAVRequest.php
+www/davical/inc/HTTPAuthSession.php
+www/davical/inc/RRule.php
+www/davical/inc/RSCDSSession.php
+www/davical/inc/RSCDSUser.php
+www/davical/inc/always.php
+www/davical/inc/always.php.in
+www/davical/inc/auth-functions.php
+www/davical/inc/caldav-DELETE.php
+www/davical/inc/caldav-GET.php
+www/davical/inc/caldav-LOCK.php
+www/davical/inc/caldav-MKCALENDAR.php
+www/davical/inc/caldav-OPTIONS.php
+www/davical/inc/caldav-PROPFIND.php
+www/davical/inc/caldav-PROPPATCH.php
+www/davical/inc/caldav-PUT-functions.php
+www/davical/inc/caldav-PUT.php
+www/davical/inc/caldav-REPORT-calquery.php
+www/davical/inc/caldav-REPORT-freebusy.php
+www/davical/inc/caldav-REPORT-multiget.php
+www/davical/inc/caldav-REPORT-principal.php
+www/davical/inc/caldav-REPORT.php
+www/davical/inc/caldav-client.php
+www/davical/inc/check_UTF8.php
+www/davical/inc/davical_configuration_missing.php
+www/davical/inc/drivers_ldap.php
+www/davical/inc/drivers_squid_pam.php
+www/davical/inc/freebusy-GET.php
+www/davical/inc/interactive-page.php
+www/davical/inc/other_translated_strings.php
+www/davical/inc/page-footer.php
+www/davical/inc/page-header.php
+www/davical/inc/CalDAVPrincipal.php
+www/davical/inc/vEvent.php
+www/davical/inc/AuthPlugin.php
+www/davical/inc/AuthPlugins.php
+www/davical/inc/DataEntry.php
+www/davical/inc/DataUpdate.php
+www/davical/inc/EMail.php
+www/davical/inc/MenuSet.php
+www/davical/inc/PgQuery.php
+www/davical/inc/Session.php
+www/davical/inc/Translation.php
+www/davical/inc/User.php
+www/davical/inc/Validation.php
+www/davical/inc/XMLElement.php
+www/davical/inc/classBrowser.php
+www/davical/inc/iCalendar.php
+www/davical/inc/AWLUtilities.php
+www/davical/dba/awl-tables.sql
+www/davical/dba/grant-on-all-tables.sh
+www/davical/dba/schema-management.sql
+www/davical/config/config.php
+@dirrm share/doc/DAViCal/config
+@dirrm share/doc/DAViCal/docs/api
+@dirrm share/doc/DAViCal/docs/website/images
+@dirrm share/doc/DAViCal/docs/website/inc
+@dirrm share/doc/DAViCal/docs/website/clients
+@dirrm share/doc/DAViCal/docs/website
+@dirrm share/doc/DAViCal/docs
+@dirrm share/doc/DAViCal/scripts/po
+@dirrm share/doc/DAViCal/scripts
+@dirrm share/doc/DAViCal/dba/patches
+@dirrm share/doc/DAViCal/dba/windows
+@dirrm share/doc/DAViCal/dba
+@dirrm share/doc/DAViCal
+@dirrm www/davical/htdocs/images
+@dirrm www/davical/htdocs/css
+@dirrm www/davical/htdocs/js
+@dirrm www/davical/htdocs
+@dirrm www/davical/inc
+@dirrm www/davical/dba
+@dirrm www/davical/config
+@dirrm www/davical