aboutsummaryrefslogtreecommitdiff
path: root/www/dhttpd
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-24 09:17:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-24 09:17:18 +0000
commit26a0dc74c248a4f9313e6d9afe38e8698c64c889 (patch)
tree365514065636ec7e33e06328317e1e3e983c7733 /www/dhttpd
parent7bb2b0eb02925da7efa29b9dc8adf0cc593ce0e1 (diff)
downloadports-26a0dc74c248a4f9313e6d9afe38e8698c64c889.tar.gz
ports-26a0dc74c248a4f9313e6d9afe38e8698c64c889.zip
add dhttpd 1.02a
Minimal secure webserver. Fast and efficient, no cgi-bin support PR: 39769 Submitted by: Gea-Suan Lin <gslin@Infomath.math.NCTU.edu.tw>
Notes
Notes: svn path=/head/; revision=61873
Diffstat (limited to 'www/dhttpd')
-rw-r--r--www/dhttpd/Makefile34
-rw-r--r--www/dhttpd/distinfo1
-rw-r--r--www/dhttpd/files/dhttpd.sh17
-rw-r--r--www/dhttpd/files/patch-config.hh24
-rw-r--r--www/dhttpd/files/patch-main.cc10
-rw-r--r--www/dhttpd/files/patch-socket.cc27
-rw-r--r--www/dhttpd/pkg-comment1
-rw-r--r--www/dhttpd/pkg-descr7
-rw-r--r--www/dhttpd/pkg-plist2
9 files changed, 123 insertions, 0 deletions
diff --git a/www/dhttpd/Makefile b/www/dhttpd/Makefile
new file mode 100644
index 000000000000..1c7c54a3bef3
--- /dev/null
+++ b/www/dhttpd/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dhttpd
+# Date created: 24 June 2002
+# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhttpd
+PORTVERSION= 1.02a
+CATEGORIES= www
+MASTER_SITES= http://uts.cc.utexas.edu/~foxx/dhttpd/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.02-4
+BUILD_WRKSRC= ${WRKSRC}/src
+
+MAN1= dhttpd.1
+
+STARTUP_SCRIPT= ${PORTNAME}.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/src/config.hh
+ @${SED} -e "s,%%PREFIX%%,${PREFIX}," ${FILESDIR}/${STARTUP_SCRIPT} > ${WRKSRC}/${STARTUP_SCRIPT}
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${STARTUP_SCRIPT} ${PREFIX}/etc/rc.d
+
+.include <bsd.port.mk>
diff --git a/www/dhttpd/distinfo b/www/dhttpd/distinfo
new file mode 100644
index 000000000000..af3578f587ce
--- /dev/null
+++ b/www/dhttpd/distinfo
@@ -0,0 +1 @@
+MD5 (dhttpd-1.02a.tgz) = 6e8669ed4ec52f82559386ed191b1e37
diff --git a/www/dhttpd/files/dhttpd.sh b/www/dhttpd/files/dhttpd.sh
new file mode 100644
index 000000000000..39c0d10d87ca
--- /dev/null
+++ b/www/dhttpd/files/dhttpd.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ if [ -x %%PREFIX%%/sbin/dhttpd ]; then
+ %%PREFIX%%/sbin/dhttpd && echo -n ' dhttpd'
+ fi
+ ;;
+stop)
+ killall dhttpd && echo -n ' dhttpd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/dhttpd/files/patch-config.hh b/www/dhttpd/files/patch-config.hh
new file mode 100644
index 000000000000..231b5dfd208a
--- /dev/null
+++ b/www/dhttpd/files/patch-config.hh
@@ -0,0 +1,24 @@
+--- src/config.hh.orig Mon Jun 24 15:21:37 2002
++++ src/config.hh Mon Jun 24 15:23:14 2002
+@@ -1,17 +1,17 @@
+ /* Set this as the user id number you want dhttpd to use when *
+ * starting it as root. You can get this info from /etc/passwd. */
+-#define UID 65534
++#define UID 80
+
+ /* Set this to the proper group id number of UID above. */
+-#define GID 65534
++#define GID 80
+
+ /* Set your default port number. If you aren't running as *
+ * root, you must use a value >= 1024, such as 8080. */
+ #define DEFAULTPORT 80
+
+ /* This is the directory where the web pages are located. */
+-#define WEBDIRPREFIX "/var/www"
++#define WEBDIRPREFIX "%%PREFIX%%/www/data"
+
+ /* This defines the maximum number of child processes (i.e. *
+ * maximum sockets being serviced by dhttpd). */
+-#define MAXCHILDPROC 100
++#define MAXCHILDPROC 2048
diff --git a/www/dhttpd/files/patch-main.cc b/www/dhttpd/files/patch-main.cc
new file mode 100644
index 000000000000..1572b8060663
--- /dev/null
+++ b/www/dhttpd/files/patch-main.cc
@@ -0,0 +1,10 @@
+--- src/main.cc Tue Mar 4 09:10:41 1997
++++ src/main.cc.orig Mon Jun 24 15:12:32 2002
+@@ -18,7 +18,6 @@
+ */
+
+ #include <errno.h>
+-#include <grp.h>
+ #include <pwd.h>
+ #include <signal.h>
+ #include <stdio.h>
diff --git a/www/dhttpd/files/patch-socket.cc b/www/dhttpd/files/patch-socket.cc
new file mode 100644
index 000000000000..d0cf933ff48b
--- /dev/null
+++ b/www/dhttpd/files/patch-socket.cc
@@ -0,0 +1,27 @@
+--- src/socket.cc.orig Mon Jun 24 15:12:40 2002
++++ src/socket.cc Mon Jun 24 15:13:03 2002
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <sys/types.h>
+ #include <errno.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+@@ -24,7 +25,6 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+@@ -149,7 +149,7 @@
+ do
+ {
+ cSidLen = sizeof( cSid );
+- s = accept( sock, &cSid, &cSidLen );
++ s = accept( sock, &cSid, (socklen_t *) &cSidLen );
+ }
+ while( s==-1 );
+
diff --git a/www/dhttpd/pkg-comment b/www/dhttpd/pkg-comment
new file mode 100644
index 000000000000..97226dbd531e
--- /dev/null
+++ b/www/dhttpd/pkg-comment
@@ -0,0 +1 @@
+Minimal secure webserver. Fast and efficient, no cgi-bin support
diff --git a/www/dhttpd/pkg-descr b/www/dhttpd/pkg-descr
new file mode 100644
index 000000000000..35878f2b98e5
--- /dev/null
+++ b/www/dhttpd/pkg-descr
@@ -0,0 +1,7 @@
+dhttpd is a secure and efficient personal HTTP server. It does not need a
+permanent IP address and can be run from a user account on high ports. Among
+its features, dhttpd supports caching, customized error messages, low profile
+memory usage, little hard disk space, highly portable code, and easy setup.
+dhttpd is the perfect solution for the minimalist in all of us.
+
+WWW: http://uts.cc.utexas.edu/~foxx/dhttpd/
diff --git a/www/dhttpd/pkg-plist b/www/dhttpd/pkg-plist
new file mode 100644
index 000000000000..1bff3de28e1c
--- /dev/null
+++ b/www/dhttpd/pkg-plist
@@ -0,0 +1,2 @@
+etc/rc.d/dhttpd.sh
+sbin/dhttpd