aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-24 14:48:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-24 14:48:38 +0000
commit20224f09cedc4c21a64bc27822f3c74fd24a9a4c (patch)
treeae75a834934badd959d0cb748353051f79357de6 /www/dillo2
parentc481cbe0a013abf5daf05f2163aa4304cf45c62b (diff)
downloadports-20224f09cedc4c21a64bc27822f3c74fd24a9a4c.tar.gz
ports-20224f09cedc4c21a64bc27822f3c74fd24a9a4c.zip
- Update dillo2 port to 2.0 (port by [1]), connect to build
PR: 128139 [1], 128390 [2] Submitted by: bf <bf2006a at yahoo dot com> [1], Thomas-Martin Seck <tmseck at netcologne dot de> [2] Discussed with: Thomas-Martin Seck <tmseck at netcologne dot de> (www/dillo maintainer)
Notes
Notes: svn path=/head/; revision=223331
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile113
-rw-r--r--www/dillo2/distinfo6
-rw-r--r--www/dillo2/files/enable-ssl.patch10
-rw-r--r--www/dillo2/files/patch-configure114
-rw-r--r--www/dillo2/files/patch-dpi-https.c18
-rw-r--r--www/dillo2/files/patch-src-cookies.c11
-rw-r--r--www/dillo2/pkg-descr6
-rw-r--r--www/dillo2/pkg-plist9
8 files changed, 84 insertions, 203 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 2f4b1db46823..a0e5372ceafe 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -1,82 +1,89 @@
# New ports collection makefile for: dillo
-# Date created: 23 February 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
+# Date created: 28 August 2008
+# Whom: bf <bf2006a@yahoo.com>
#
# $FreeBSD$
-#
-# Tunables:
-# WITH_DILLO_SSL: enable experimental SSL support
-# WITH_DILLO_DLGUI: enable experimental FLTK2 based gui for file downloads
-#
PORTNAME= dillo
-PORTVERSION= 0.8.6
-PORTREVISION= 2
+PORTVERSION= 2.0
CATEGORIES= www ipv6
MASTER_SITES= http://www.dillo.org/download/
-MAINTAINER= tmseck@netcologne.de
-COMMENT= A fast, small graphical Web browser built upon GTK+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= A fast, small graphical Web browser built upon fltk2
-RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+BUILD_DEPENDS= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2
+RUN_DEPENDS= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2 \
+ wget:${PORTSDIR}/ftp/wget
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
-USE_GNOME= gnometarget gtk12
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
- --libdir=${PREFIX}/libexec
-.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
+USE_GMAKE= yes
+PORTDOCS= *
+CONFIGURE_ARGS= --libdir=${PREFIX}/libexec
+CONFLICTS= dillo-i18n-[0-9]* \
+ dillo-0*
+
+OPTIONS= COOKIES "Enable cookies" On \
+ DEBUG "Enable profiling and extra logging" Off \
+ IPV6 "Enable ipv6" On \
+ SSL "Enable (experimental) https support" On \
+ THREADED_DNS "Enable re-entrant resolver library" On
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_COOKIES)
+CONFIGURE_ARGS+= --enable-cookies
+.else
+CONFIGURE_ARGS+= --disable-cookies
.endif
-.if defined(WITH_DILLO_SSL)
-CONFIGURE_ARGS+= --enable-ssl
-EXTRA_PATCHES+= ${PATCHDIR}/enable-ssl.patch
-USE_OPENSSL= yes
+.ifdef(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-gprof --enable-rtfl
.else
-CONFIGURE_ARGS+= --disable-ssl
+CONFIGURE_ARGS+= --disable-gprof --disable-rtfl
.endif
-.if defined(WITH_DILLO_DLGUI)
-CONFIGURE_ARGS+= --enable-dlgui
-BUILD_DEPENDS+= fltk>=2.0.r4825:${PORTSDIR}/x11-toolkits/fltk2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+.ifdef(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
.else
-CONFIGURE_ARGS+= --disable-dlgui
+CONFIGURE_ARGS+= --disable-ipv6
.endif
-CONFLICTS= dillo-i18n-*[0-9]*
+.ifdef(WITH_SSL)
+CONFIGURE_ARGS+= --enable-ssl
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.else
+CONFIGURE_ARGS+= --disable-ssl
+.endif
+
+.ifdef(WITH_THREADED_DNS)
+CONFIGURE_ARGS+= --enable-threaded-dns
+CFLAGS+= ${PTHREAD_CFLAGS}
+.else
+CONFIGURE_ARGS+= --disable-threaded-dns
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
- @${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
+.ifdef(WITH_SSL)
+ ${REINPLACE_CMD} -e '/^#undef ENABLE_SSL/d' ${WRKSRC}/dpi/https.c
+.endif
+ @${MV} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.dist
+ @${REINPLACE_CMD} -e "s|dillorc|dillorc.dist|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|dpidrc|dpidrc.dist|g" ${WRKSRC}/dpid/Makefile.in
-pre-configure:
-.if !defined(WITH_DILLO_SSL)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
- @${ECHO_CMD} " commandline to enable experimental SSL support."
+post-install:
+.if !exists(${PREFIX}/etc/dillorc)
+ ${INSTALL_DATA} ${PREFIX}/etc/dillorc.dist ${PREFIX}/etc/dillorc
.endif
-.if !defined(WITH_DILLO_DLGUI)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
- @${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
+.if !exists(${PREFIX}/etc/dpidrc)
+ ${INSTALL_DATA} ${PREFIX}/etc/dpidrc.dist ${PREFIX}/etc/dpidrc
.endif
-.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITHOUT_DILLO_IPV6=yes (or WITHOUT_IPV6=yes) in your make"
- @${ECHO_CMD} " environment or on the commandline to disable IPv6 support."
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
- @${ECHO_CMD} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/dillo2/distinfo b/www/dillo2/distinfo
index 226bf232cbeb..56db74527d40 100644
--- a/www/dillo2/distinfo
+++ b/www/dillo2/distinfo
@@ -1,3 +1,3 @@
-MD5 (dillo-0.8.6.tar.bz2) = b65233d368bbd265a55effcf2c17f84b
-SHA256 (dillo-0.8.6.tar.bz2) = 47e695a5d370eb656f5e41eeb917ad6281b1559bf60172c9eca89b5518a9f9b9
-SIZE (dillo-0.8.6.tar.bz2) = 441739
+MD5 (dillo-2.0.tar.bz2) = bb9999cabeb4db3d915687de465dbeb0
+SHA256 (dillo-2.0.tar.bz2) = 847d1db31bd68ab9ab94b642b0cd40ac8d3cf816900f5d5652124986601df1e9
+SIZE (dillo-2.0.tar.bz2) = 551569
diff --git a/www/dillo2/files/enable-ssl.patch b/www/dillo2/files/enable-ssl.patch
deleted file mode 100644
index c20ccebf7659..000000000000
--- a/www/dillo2/files/enable-ssl.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- dpi/https.c.orig Sat Mar 25 16:46:48 2006
-+++ dpi/https.c Sat Mar 25 16:47:38 2006
-@@ -62,7 +62,6 @@
- #include "dpiutil.h"
-
- #define ENABLE_SSL
--#undef ENABLE_SSL
- #ifdef ENABLE_SSL
-
- #include <openssl/ssl.h>
diff --git a/www/dillo2/files/patch-configure b/www/dillo2/files/patch-configure
deleted file mode 100644
index 5dbc5f4c6290..000000000000
--- a/www/dillo2/files/patch-configure
+++ /dev/null
@@ -1,114 +0,0 @@
---- configure.orig Sat Apr 15 14:01:45 2006
-+++ configure Sun Apr 16 20:20:43 2006
-@@ -309,7 +309,7 @@
- # include <unistd.h>
- #endif"
-
--ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS EGREP LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
-+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS FLTK2_CONFIG EGREP LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
- ac_subst_files=''
-
- # Initialize some variables set by options.
-@@ -1961,16 +1961,6 @@
- enable_threaded_dns=yes
- fi;
-
--
--if test x$enable_dlgui = xyes; then
-- DLGUI_TRUE=
-- DLGUI_FALSE='#'
--else
-- DLGUI_TRUE='#'
-- DLGUI_FALSE=
--fi
--
--
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5884,11 +5874,81 @@
- rm -f conf.gtktest
-
-
-- echo "$as_me:$LINENO: checking Hackish check for FLTK" >&5
--echo $ECHO_N "checking Hackish check for FLTK... $ECHO_C" >&6
-- LIBFLTK_CXXFLAGS=`fltk-config --cxxflags`
-- LIBFLTK_LIBS=`fltk-config --ldflags`
-+if test "x$enable_dlgui" = "xyes"; then
-+ for ac_prog in fltk2-config fltk-config
-+do
-+ # Extract the first word of "$ac_prog", so it can be a program name with args.
-+set dummy $ac_prog; ac_word=$2
-+echo "$as_me:$LINENO: checking for $ac_word" >&5
-+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-+if test "${ac_cv_path_FLTK2_CONFIG+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ case $FLTK2_CONFIG in
-+ [\\/]* | ?:[\\/]*)
-+ ac_cv_path_FLTK2_CONFIG="$FLTK2_CONFIG" # Let the user override the test with a path.
-+ ;;
-+ *)
-+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-+for as_dir in $PATH
-+do
-+ IFS=$as_save_IFS
-+ test -z "$as_dir" && as_dir=.
-+ for ac_exec_ext in '' $ac_executable_extensions; do
-+ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-+ ac_cv_path_FLTK2_CONFIG="$as_dir/$ac_word$ac_exec_ext"
-+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
-+ break 2
-+ fi
-+done
-+done
-+
-+ ;;
-+esac
-+fi
-+FLTK2_CONFIG=$ac_cv_path_FLTK2_CONFIG
-+
-+if test -n "$FLTK2_CONFIG"; then
-+ echo "$as_me:$LINENO: result: $FLTK2_CONFIG" >&5
-+echo "${ECHO_T}$FLTK2_CONFIG" >&6
-+else
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
-+fi
-+
-+ test -n "$FLTK2_CONFIG" && break
-+done
-+test -n "$FLTK2_CONFIG" || FLTK2_CONFIG="NOTFOUND"
-
-+ if test "x$FLTK2_CONFIG" != "xNOTFOUND" && test -x "$FLTK2_CONFIG"; then
-+ fltk_version=`$FLTK2_CONFIG --version`
-+ case "$fltk_version" in
-+ 2.*)
-+ LIBFLTK_CXXFLAGS=`$FLTK2_CONFIG --cxxflags`
-+ LIBFLTK_LIBS=`$FLTK2_CONFIG --ldflags`
-+ fltk2_ok="yes"
-+ ;;
-+ *)
-+ echo "$as_me:$LINENO: result: need fltk2 -- disabling fltk support" >&5
-+echo "${ECHO_T}need fltk2 -- disabling fltk support" >&6
-+ fltk2_ok="no"
-+ ;;
-+ esac
-+ else
-+ fltk2_ok="no"
-+ fi
-+else
-+ fltk2_ok="no"
-+fi
-+
-+
-+if test x$fltk2_ok = xyes; then
-+ DLGUI_TRUE=
-+ DLGUI_FALSE='#'
-+else
-+ DLGUI_TRUE='#'
-+ DLGUI_FALSE=
-+fi
-
- if test "x$enable_jpeg" = "xyes"; then
-
diff --git a/www/dillo2/files/patch-dpi-https.c b/www/dillo2/files/patch-dpi-https.c
deleted file mode 100644
index 4fd698b0f55b..000000000000
--- a/www/dillo2/files/patch-dpi-https.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- dpi/https.c.orig Sat Mar 25 16:49:59 2006
-+++ dpi/https.c Sat Mar 25 16:55:35 2006
-@@ -655,13 +655,8 @@
- "<b>}</b>\n\n"
- " <b>*** Dillo's prototype plugin for https support"
- " is disabled now ***</b>\n\n"
-- " If you want to test this <b>alpha</b> support code, just remove\n"
-- " line 65 from https.c, recompile and reinstall.\n\n"
-- " (beware that this https support is very limited now)\n\n"
-- " To use https and SSL, you must have \n"
-- " the OpenSSL development libraries installed. Check your\n"
-- " O/S distribution provider, or check out\n"
-- " <a href=\"http://www.openssl.org\">www.openssl.org</a>\n\n"
-+ " If you want to test this <b>alpha</b> support code, define\n"
-+ " WITH_DILLO_SSL in your make environment and rebuild the port.\n\n"
- " --\n"
- "</pre></body></html>\n",
- http_query
diff --git a/www/dillo2/files/patch-src-cookies.c b/www/dillo2/files/patch-src-cookies.c
new file mode 100644
index 000000000000..f907e831d09c
--- /dev/null
+++ b/www/dillo2/files/patch-src-cookies.c
@@ -0,0 +1,11 @@
+--- src/cookies.c.orig 2008-09-28 22:57:42.000000000 +0400
++++ src/cookies.c 2008-11-24 17:21:06.000000000 +0300
+@@ -17,6 +17,8 @@
+
+ #ifdef DISABLE_COOKIES
+
++#include "msg.h"
++
+ /*
+ * Initialize the cookies module
+ */
diff --git a/www/dillo2/pkg-descr b/www/dillo2/pkg-descr
index d915e3ead2ef..e404b5276188 100644
--- a/www/dillo2/pkg-descr
+++ b/www/dillo2/pkg-descr
@@ -1,4 +1,6 @@
-Dillo aims to be a multiplatform browser alternative that's small,
-stable, developer-friendly, usable, fast, and extensible.
+Dillo aims to be a multiplatform alternative browser that's small,
+stable, developer-friendly, usable, fast, and extensible. This
+new, experimental version of Dillo is based upon FLTK2 toolkit,
+rather than GTK1, and has been substantially rewritten.
WWW: http://www.dillo.org/
diff --git a/www/dillo2/pkg-plist b/www/dillo2/pkg-plist
index bbe25cdd3a4f..638bfdc8f08d 100644
--- a/www/dillo2/pkg-plist
+++ b/www/dillo2/pkg-plist
@@ -1,9 +1,12 @@
-@comment $FreeBSD$
bin/dillo
bin/dpid
bin/dpidc
-etc/dillorc.sample
-etc/dpidrc
+@unexec if cmp -s %D/etc/dillorc.dist %D/etc/dillorc; then rm -f %D/etc/dillorc; fi
+etc/dillorc.dist
+@exec if [ ! -f %B/dillorc ]; then cp -p %D/%F %B/dillorc; fi
+@unexec if cmp -s %D/etc/dpidrc.dist %D/etc/dpidrc; then rm -f %D/etc/dpidrc; fi
+etc/dpidrc.dist
+@exec if [ ! -f %B/dpidrc ]; then cp -p %D/%F %B/dpidrc; fi
libexec/dillo/dpi/bookmarks/bookmarks.dpi
libexec/dillo/dpi/cookies/cookies.dpi
libexec/dillo/dpi/datauri/datauri.filter.dpi