aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-28 15:23:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-28 15:23:34 +0000
commit824dc5a1d6bd9d904b9bacd0a48292d97db6a2a5 (patch)
treef04ebabdd2472f842bd9bec3ff6dca794068cbd4 /www/dillo2
parentc7d81b3b6e7c1ebe1cac19ea6f7d6b4c88be458e (diff)
downloadports-824dc5a1d6bd9d904b9bacd0a48292d97db6a2a5.tar.gz
ports-824dc5a1d6bd9d904b9bacd0a48292d97db6a2a5.zip
- Update to 0.8.3
PR: ports/73242 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Notes
Notes: svn path=/head/; revision=120397
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile23
-rw-r--r--www/dillo2/distinfo4
-rw-r--r--www/dillo2/files/patch-dpi-https.c26
-rw-r--r--www/dillo2/pkg-descr10
-rw-r--r--www/dillo2/pkg-plist26
5 files changed, 63 insertions, 26 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 284d69b69a7a..4224716da5be 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -4,9 +4,12 @@
#
# $FreeBSD$
#
+# Tunables:
+# WITH_DILLO_SSL: enable experimental SSL support
+#
PORTNAME= dillo
-PORTVERSION= 0.8.2
+PORTVERSION= 0.8.3
CATEGORIES= www
MASTER_SITES= http://www.dillo.org/download/
@@ -24,7 +27,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-ipv6
+CONFIGURE_ARGS= --enable-ipv6 --libdir=${PREFIX}/libexec
+
+.if defined(WITH_DILLO_SSL)
+CONFIGURE_ARGS+= --enable-ssl
+USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+= --disable-ssl
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
@@ -32,4 +42,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
@${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
+pre-configure:
+.if !defined(WITH_DILLO_SSL)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " You can enable dillo's experimental SSL support by specifing"
+ @${ECHO_CMD} " WITH_DILLO_SSL=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline."
+ @${ECHO_CMD} ""
+.endif
+
.include <bsd.port.mk>
diff --git a/www/dillo2/distinfo b/www/dillo2/distinfo
index e8cae47f6691..18a733cc6e08 100644
--- a/www/dillo2/distinfo
+++ b/www/dillo2/distinfo
@@ -1,2 +1,2 @@
-MD5 (dillo-0.8.2.tar.bz2) = 4322f339aa4a4a2a4ba9a11444df9c67
-SIZE (dillo-0.8.2.tar.bz2) = 409961
+MD5 (dillo-0.8.3.tar.bz2) = be772ec9361bcc01515ae0da61de9bda
+SIZE (dillo-0.8.3.tar.bz2) = 418714
diff --git a/www/dillo2/files/patch-dpi-https.c b/www/dillo2/files/patch-dpi-https.c
new file mode 100644
index 000000000000..b3e4173cd8c2
--- /dev/null
+++ b/www/dillo2/files/patch-dpi-https.c
@@ -0,0 +1,26 @@
+--- dpi/https.c.orig Sun Oct 3 17:16:15 2004
++++ dpi/https.c Sun Oct 3 17:17:47 2004
+@@ -53,7 +53,6 @@
+ #include <glib.h>
+ #include "dpiutil.h"
+
+-#undef ENABLE_SSL
+ #ifdef ENABLE_SSL
+
+ #include <openssl/ssl.h>
+@@ -605,13 +616,8 @@ static void no_ssl_support(void)
+ "<b>}</b>\n\n"
+ " <b>*** Dillo's prototype plugin for https support"
+ " is disabled now ***</b>\n\n"
+- " If you want to test this <b>alpha</b> support code, just remove\n"
+- " line 56 from https.c, recompile and reinstall.\n\n"
+- " (beware that this https support is very limited now)\n\n"
+- " To use https and SSL, you must have \n"
+- " the OpenSSL development libraries installed. Check your\n"
+- " O/S distribution provider, or check out\n"
+- " <a href=\"http://www.openssl.org\">www.openssl.org</a>\n\n"
++ " If you want to test this <b>alpha</b> support code, define\n"
++ " WITH_DILLO_SSL in your make environment and rebuild the port.\n\n"
+ " --\n"
+ "</pre></body></html>\n",
+ http_query
diff --git a/www/dillo2/pkg-descr b/www/dillo2/pkg-descr
index e7fc47fd8175..d915e3ead2ef 100644
--- a/www/dillo2/pkg-descr
+++ b/www/dillo2/pkg-descr
@@ -1,14 +1,4 @@
-Dillo is a web browser project completely written in C (currently the code
-is based on gzilla-0.2.2's widget, and a new improved network engine
-written from scratch).
-
-Dillo is small; source is less than 360 kB and binary is less than 270 Kb.
-
Dillo aims to be a multiplatform browser alternative that's small,
stable, developer-friendly, usable, fast, and extensible.
-Dillo is mainly based on GTK+ (GNOME is NOT required!)
-
-Dillo is very fast!
-
WWW: http://www.dillo.org/
diff --git a/www/dillo2/pkg-plist b/www/dillo2/pkg-plist
index b7409a3936da..36cd84b7d98d 100644
--- a/www/dillo2/pkg-plist
+++ b/www/dillo2/pkg-plist
@@ -4,15 +4,17 @@ bin/dpid
bin/dpidc
etc/dillorc.sample
etc/dpidrc
-lib/dillo/dpi/bookmarks/bookmarks.dpi
-lib/dillo/dpi/downloads/downloads.dpi
-lib/dillo/dpi/ftp/ftp.filter.dpi
-lib/dillo/dpi/hello/hello.filter.dpi
-lib/dillo/dpi/https/https.filter.dpi
-@dirrm lib/dillo/dpi/https
-@dirrm lib/dillo/dpi/hello
-@dirrm lib/dillo/dpi/ftp
-@dirrm lib/dillo/dpi/downloads
-@dirrm lib/dillo/dpi/bookmarks
-@dirrm lib/dillo/dpi
-@dirrm lib/dillo
+libexec/dillo/dpi/bookmarks/bookmarks.dpi
+libexec/dillo/dpi/downloads/downloads.dpi
+libexec/dillo/dpi/file/file.dpi
+libexec/dillo/dpi/ftp/ftp.filter.dpi
+libexec/dillo/dpi/hello/hello.filter.dpi
+libexec/dillo/dpi/https/https.filter.dpi
+@dirrm libexec/dillo/dpi/https
+@dirrm libexec/dillo/dpi/hello
+@dirrm libexec/dillo/dpi/ftp
+@dirrm libexec/dillo/dpi/file
+@dirrm libexec/dillo/dpi/downloads
+@dirrm libexec/dillo/dpi/bookmarks
+@dirrm libexec/dillo/dpi
+@dirrm libexec/dillo