aboutsummaryrefslogtreecommitdiff
path: root/www/dokuwiki-devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-04-10 16:49:08 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-04-10 16:49:08 +0000
commit3c43dbd99deeaaa3db7f22d5f4460390b95a4619 (patch)
tree7a17bbef399cb7a7bc7aa475688610c00e033515 /www/dokuwiki-devel
parenta1605b6bcd44226e9b401e24db823bf1606f06c6 (diff)
downloadports-3c43dbd99deeaaa3db7f22d5f4460390b95a4619.tar.gz
ports-3c43dbd99deeaaa3db7f22d5f4460390b95a4619.zip
Add dokuwiki, it's a simple and easy to use wiki.
Submitted by: chinsan <chinsan@mail2000.com.tw>
Notes
Notes: svn path=/head/; revision=132901
Diffstat (limited to 'www/dokuwiki-devel')
-rw-r--r--www/dokuwiki-devel/Makefile51
-rw-r--r--www/dokuwiki-devel/distinfo2
-rw-r--r--www/dokuwiki-devel/pkg-descr8
-rw-r--r--www/dokuwiki-devel/pkg-message9
-rw-r--r--www/dokuwiki-devel/pkg-plist1
5 files changed, 71 insertions, 0 deletions
diff --git a/www/dokuwiki-devel/Makefile b/www/dokuwiki-devel/Makefile
new file mode 100644
index 000000000000..ccc305d029a2
--- /dev/null
+++ b/www/dokuwiki-devel/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: dokuwiki
+# Date created: 2005-04-10
+# Whom: chinsan <chinsan@mail2000.com.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dokuwiki
+PORTVERSION= 20050218
+CATEGORIES= www
+MASTER_SITES= http://www.splitbrain.org/Programming/PHP/DokuWiki/
+DISTNAME= dokuwiki-2005-02-18
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A simple and easy to use wiki, no database required
+
+USE_PHP= pcre session
+PHP4_PORT?= www/mod_php4
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+DOKUWIKIDIR?= www/data-dist/dokuwiki
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ cd ${WRKSRC} && ${FIND} -s . -type f | \
+ ${SED} -e 's|^./||;s|^|${DOKUWIKIDIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${DOKUWIKIDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} ${DOKUWIKIDIR}/changes.log >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${DOKUWIKIDIR} >> ${PLIST}
+
+do-install:
+ # Data files
+ -${MKDIR} ${PREFIX}/${DOKUWIKIDIR}
+ @${CHOWN} www:www ${PREFIX}/${DOKUWIKIDIR}
+ @${CHMOD} 755 ${PREFIX}/${DOKUWIKIDIR}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${DOKUWIKIDIR}
+ # Setup the correct permissions
+ @${TOUCH} ${PREFIX}/${DOKUWIKIDIR}/changes.log
+ @${CHOWN} -R www:www ${PREFIX}/${DOKUWIKIDIR}/changes.log
+ @${CHOWN} -R www:www ${PREFIX}/${DOKUWIKIDIR}/data
+ @${CHOWN} -R www:www ${PREFIX}/${DOKUWIKIDIR}/media
+ @${CHOWN} -R www:www ${PREFIX}/${DOKUWIKIDIR}/attic
+
+post-install:
+ @${SED} -e 's|%%DOKUWIKIDIR%%|${PREFIX}/${DOKUWIKIDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/dokuwiki-devel/distinfo b/www/dokuwiki-devel/distinfo
new file mode 100644
index 000000000000..12cb59496315
--- /dev/null
+++ b/www/dokuwiki-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (dokuwiki-2005-02-18.tgz) = a4cb8233de0926e5ee6922a517c7dfdb
+SIZE (dokuwiki-2005-02-18.tgz) = 337051
diff --git a/www/dokuwiki-devel/pkg-descr b/www/dokuwiki-devel/pkg-descr
new file mode 100644
index 000000000000..325dd3e6997d
--- /dev/null
+++ b/www/dokuwiki-devel/pkg-descr
@@ -0,0 +1,8 @@
+DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at
+creating documentation of any kind. It is targeted at developer teams,
+workgroups and small companies. It has a simple but powerful syntax which
+makes sure the datafiles remain readable outside the Wiki and eases the
+creation of structured texts.
+All data is stored in plain text files ¡V no database is required.
+
+WWW: http://wiki.splitbrain.org/wiki:dokuwiki
diff --git a/www/dokuwiki-devel/pkg-message b/www/dokuwiki-devel/pkg-message
new file mode 100644
index 000000000000..69ab9386a04c
--- /dev/null
+++ b/www/dokuwiki-devel/pkg-message
@@ -0,0 +1,9 @@
+=================================================================
+ **** NOTE ****
+ edit PREFIX/www/data-dist/dokuwiki/conf/dokuwiki.php
+ if you want to change anything within it or (better) create
+ dokuwiki/conf/local.php containing those lines from dokuwiki.php,
+ which you want to change. This way your changes are preserved
+ when overwriting the dokuwiki.php with a new release.
+
+=================================================================
diff --git a/www/dokuwiki-devel/pkg-plist b/www/dokuwiki-devel/pkg-plist
new file mode 100644
index 000000000000..d0ac09258d04
--- /dev/null
+++ b/www/dokuwiki-devel/pkg-plist
@@ -0,0 +1 @@
+@comment real PLIST will be generated in pre-install phase