aboutsummaryrefslogtreecommitdiff
path: root/www/drupal4-textile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-27 23:46:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-27 23:46:01 +0000
commit44d63baffcaec63df4a7da84fc5dd49cfea5ba89 (patch)
tree4af0cb8934d4af77d46f7350764287ca018ec889 /www/drupal4-textile
parent7886867a5ff45e6aaa8fdeaf2b41c341daa339c9 (diff)
downloadports-44d63baffcaec63df4a7da84fc5dd49cfea5ba89.tar.gz
ports-44d63baffcaec63df4a7da84fc5dd49cfea5ba89.zip
- Update to 4.7.x.1.x.d_20061113
PR: 108383 Submitted by: Nick Hilliard <nick@foobar.org> (maintainer)
Notes
Notes: svn path=/head/; revision=183459
Diffstat (limited to 'www/drupal4-textile')
-rw-r--r--www/drupal4-textile/Makefile12
-rw-r--r--www/drupal4-textile/distinfo6
-rw-r--r--www/drupal4-textile/files/patch-DrupalTextile.inc21
-rw-r--r--www/drupal4-textile/files/pkg-install.in27
4 files changed, 31 insertions, 35 deletions
diff --git a/www/drupal4-textile/Makefile b/www/drupal4-textile/Makefile
index 1982d4c3a5ae..75a0611f53fb 100644
--- a/www/drupal4-textile/Makefile
+++ b/www/drupal4-textile/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= textile
-DISTVERSION= ${DRUPAL_VERSION}
-PORTREVISION= 20060511
+DISTVERSION= 4.7.x-1.x-dev
+PORTREVISION= 20061113
CATEGORIES= www textproc
MASTER_SITE_SUBDIR= brooks
@@ -16,16 +16,17 @@ COMMENT= Textile markup module for Drupal
DRUPAL_MODULE= yes
MODULE_DIRS= textilephp
-MODULE_FILES= textile.module textilephp/Textile.php
+MODULE_FILES= textile.module textilephp/Textile.php DrupalTextile.inc
DOC_DIRS= textilephp/doc textilephp
DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt LICENSE.txt README.txt \
- textilephp/doc/classMTLikeTextile-members.html \
+ TODO.txt \
textilephp/doc/Textile_8php-source.html \
textilephp/doc/Textile_8php.html \
textilephp/doc/annotated.html \
- textilephp/doc/classTextile-members.html \
+ textilephp/doc/classMTLikeTextile-members.html \
textilephp/doc/classMTLikeTextile.html \
textilephp/doc/classMTLikeTextile.png \
+ textilephp/doc/classTextile-members.html \
textilephp/doc/classTextile.html \
textilephp/doc/classTextile.png \
textilephp/doc/doxygen.css \
@@ -39,6 +40,7 @@ DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt LICENSE.txt README.txt \
textilephp/textilephp.doxyfile \
textilephp/CHANGELOG \
textilephp/CREDITS \
+ textilephp/LICENSE \
textilephp/README \
textilephp/TODO
diff --git a/www/drupal4-textile/distinfo b/www/drupal4-textile/distinfo
index 02e85eb729fb..c29edcd83e2a 100644
--- a/www/drupal4-textile/distinfo
+++ b/www/drupal4-textile/distinfo
@@ -1,3 +1,3 @@
-MD5 (drupal/textile-4.7.0.tar.gz) = 0836f51df99929b410d45a2ad8079853
-SHA256 (drupal/textile-4.7.0.tar.gz) = 86ba06d109ca305ee263cf02ffc93404817555716225bd67fe3a46e117b22ea6
-SIZE (drupal/textile-4.7.0.tar.gz) = 121007
+MD5 (drupal/textile-4.7.x-1.x-dev.tar.gz) = f921ea2e5f61d2235a37d2ec67c02ecf
+SHA256 (drupal/textile-4.7.x-1.x-dev.tar.gz) = b3cb512155965694fa33ad01d1f78bb5ee76ed2c9c82218fbbf1bbea3f87a477
+SIZE (drupal/textile-4.7.x-1.x-dev.tar.gz) = 120206
diff --git a/www/drupal4-textile/files/patch-DrupalTextile.inc b/www/drupal4-textile/files/patch-DrupalTextile.inc
new file mode 100644
index 000000000000..1ebd18c65e45
--- /dev/null
+++ b/www/drupal4-textile/files/patch-DrupalTextile.inc
@@ -0,0 +1,21 @@
+--- DrupalTextile.inc.orig Fri Dec 8 13:01:07 2006
++++ DrupalTextile.inc Fri Dec 8 13:00:49 2006
+@@ -38,11 +38,17 @@
+ * A <code>string</code> containing the formatted URL.
+ */
+ function format_url($args) {
++ $query = null;
++ if (preg_match ('/([^\?]*)\?(.*)/', $args['url'], $matches)) {
++ $args['url'] = $matches[1];
++ $query = $matches[2];
++ }
++
+ if (preg_match('<^#>', $args['url'])) {
+ $args['url'] = $_GET['q'] . $args['url'];
+ }
+
+- $args['url'] = ($args['url'] ? url($args['url']) : '');
++ $args['url'] = ($args['url'] ? url($args['url'], $query) : '');
+
+ return parent::format_url($args);
+ }
diff --git a/www/drupal4-textile/files/pkg-install.in b/www/drupal4-textile/files/pkg-install.in
deleted file mode 100644
index e18d858c77e8..000000000000
--- a/www/drupal4-textile/files/pkg-install.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-PREFIX=%%PREFIX%%
-CONF_FILES="%%CONF_FILES%%"
-CONF_DIRS="%%CONF_DIRS%%"
-
-case $2 in
-POST-INSTALL)
- for cfgfile in "${CONF_FILES}"; do
- if [ ! -e ${PREFIX}/${cfgfile} ]; then
- cp ${PREFIX}/${cfgfile}-dist ${PREFIX}/${cfgfile}
- fi
- done
- ;;
-DEINSTALL)
- for cfgfile in "${CONF_FILES}"; do
- if cmp -s ${PREFIX}/${cfgfile} ${PREFIX}/${cfgfile}-dist ]; then
- rm ${PREFIX}/${cfgfile}
- fi
- done
- ;;
-POST-DEINSTALL)
- for cfgdir in "${CONF_DIRS}"; do
- rmdir ${PREFIX}/${cfgdir} 2> /dev/null || true
- done
- ;;
-esac