aboutsummaryrefslogtreecommitdiff
path: root/www/drupal7-wysiwyg
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-16 19:47:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-16 19:47:36 +0000
commit5564a348fa710d9791e54112c509dade8d7308d0 (patch)
treefc4dffc6b1c8eeef9faedace35af43ff55814a57 /www/drupal7-wysiwyg
parent3dd54f70fbbaa9a2f34b36e67929cc922d8bce32 (diff)
downloadports-5564a348fa710d9791e54112c509dade8d7308d0.tar.gz
ports-5564a348fa710d9791e54112c509dade8d7308d0.zip
Wysiwyg API allows to use client-side editors (a.k.a. WYSIWYG editors) for
editing content in the Drupal CMS. It simplifies installation of editors and allows you to define which editor to use depending on the input format. This module replaces all existing editor integration modules and no other Drupal module is required. It is capable of supporting any kind of client-side editor as long as there are support files for it that integrate the external library with Wysiwyg API. A client-side editor can be a regular HTML-based editor, a "pseudo-editor" (that just provides buttons to insert HTML markup into a plain textarea), or even a Flash-based editor. Support for various editor libraries is built-in. The Wysiwyg API also allows Drupal modules to register plugins (or "buttons") for editors. WWW: http://drupal.org/project/wysiwyg PR: ports/135230 Submitted by: Nick Hilliard <nick at foobar.org>
Notes
Notes: svn path=/head/; revision=236068
Diffstat (limited to 'www/drupal7-wysiwyg')
-rw-r--r--www/drupal7-wysiwyg/Makefile81
-rw-r--r--www/drupal7-wysiwyg/distinfo3
-rw-r--r--www/drupal7-wysiwyg/pkg-descr17
3 files changed, 101 insertions, 0 deletions
diff --git a/www/drupal7-wysiwyg/Makefile b/www/drupal7-wysiwyg/Makefile
new file mode 100644
index 000000000000..eb8805b88fed
--- /dev/null
+++ b/www/drupal7-wysiwyg/Makefile
@@ -0,0 +1,81 @@
+# New ports collection makefile for: drupal6-wysiwyg
+# Date created: 2 June 2009
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wysiwyg
+DISTVERSION= 6.x-2.0-alpha1
+CATEGORIES= www
+
+MAINTAINER= nick@foobar.org
+COMMENT= Allows implementation of WYSIWYG editors for editing Drupal content
+
+TINYMCEDIR= www/tinymce
+
+# we support either tinymce2 or tinymce3
+RUN_DEPENDS+= ${LOCALBASE}/${TINYMCEDIR}:${PORTSDIR}/www/tinymce3
+
+PLIST_FILES+= ${DRUPAL_MODDIR}/tinymce
+
+DRUPAL6_MODULE= yes
+MODULE_FILES= editors/css/markitup-1.css \
+ editors/css/tinymce-2.css \
+ editors/css/tinymce-3.css \
+ editors/js/fckeditor-2.6.js \
+ editors/js/fckeditor.config.js \
+ editors/js/jwysiwyg.js \
+ editors/js/markitup.js \
+ editors/js/nicedit.js \
+ editors/js/none.js \
+ editors/js/tinymce-2.js \
+ editors/js/tinymce-3.js \
+ editors/js/whizzywig.js \
+ editors/js/yui.js \
+ editors/fckeditor.inc \
+ editors/jwysiwyg.inc \
+ editors/markitup.inc \
+ editors/nicedit.inc \
+ editors/tinymce.inc \
+ editors/whizzywig.inc \
+ editors/yui.inc \
+ wysiwyg-dialog-page.tpl.php \
+ wysiwyg.admin.inc \
+ wysiwyg.api.php \
+ wysiwyg.dialog.inc \
+ wysiwyg.info \
+ wysiwyg.init.js \
+ wysiwyg.install \
+ wysiwyg.js \
+ wysiwyg.module \
+ plugins/break/images/break.gif \
+ plugins/break/images/breaktext.gif \
+ plugins/break/images/spacer.gif \
+ plugins/break/break.css \
+ plugins/break/break.js \
+ plugins/break/langs/ca.js \
+ plugins/break/langs/de.js \
+ plugins/break/langs/en.js \
+ plugins/break/langs/es.js \
+ plugins/break.inc \
+ translations/wysiwyg.pot \
+ translations/da.po \
+ translations/de.po \
+ translations/el.po \
+ translations/fr.po \
+ translations/hu.po \
+ translations/sv.po \
+ translations/tr.po
+
+MODULE_DIRS= editors/css editors/js editors plugins/break/images \
+ plugins/break/langs plugins/break plugins translations
+
+DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
+
+post-install:
+ ${LN} -s ${PREFIX}/${TINYMCEDIR} ${PREFIX}/${DRUPAL_MODDIR}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/drupal5/bsd.drupal.mk"
+.include <bsd.port.post.mk>
diff --git a/www/drupal7-wysiwyg/distinfo b/www/drupal7-wysiwyg/distinfo
new file mode 100644
index 000000000000..8c11a6e57b00
--- /dev/null
+++ b/www/drupal7-wysiwyg/distinfo
@@ -0,0 +1,3 @@
+MD5 (drupal/wysiwyg-6.x-2.0-alpha1.tar.gz) = a745141da5436606e8bdf848cfd6da20
+SHA256 (drupal/wysiwyg-6.x-2.0-alpha1.tar.gz) = b0c093d53ffb50ff2e441b31dc88e72dc76e4f4dbe4691bb7defbad7febbb578
+SIZE (drupal/wysiwyg-6.x-2.0-alpha1.tar.gz) = 80232
diff --git a/www/drupal7-wysiwyg/pkg-descr b/www/drupal7-wysiwyg/pkg-descr
new file mode 100644
index 000000000000..23bbfdd796e7
--- /dev/null
+++ b/www/drupal7-wysiwyg/pkg-descr
@@ -0,0 +1,17 @@
+Wysiwyg API allows to use client-side editors (a.k.a. WYSIWYG editors) for
+editing content in the Drupal CMS. It simplifies installation of editors
+and allows you to define which editor to use depending on the input format.
+This module replaces all existing editor integration modules and no other
+Drupal module is required.
+
+It is capable of supporting any kind of client-side editor as long as there
+are support files for it that integrate the external library with Wysiwyg
+API. A client-side editor can be a regular HTML-based editor, a
+"pseudo-editor" (that just provides buttons to insert HTML markup into a
+plain textarea), or even a Flash-based editor. Support for various editor
+libraries is built-in.
+
+The Wysiwyg API also allows Drupal modules to register plugins (or
+"buttons") for editors.
+
+WWW: http://drupal.org/project/wysiwyg