aboutsummaryrefslogtreecommitdiff
path: root/www/emp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-26 01:00:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-26 01:00:25 +0000
commitbb23e445c64c336a39fbb91c944dac297f0b2790 (patch)
treebb8f2b4069e933094311f515f4a4cbd1b1163c75 /www/emp
parent74303054fca9c1821d23018b4282ea888f0dfd1f (diff)
downloadports-bb23e445c64c336a39fbb91c944dac297f0b2790.tar.gz
ports-bb23e445c64c336a39fbb91c944dac297f0b2790.zip
Add emp, CGI application that creates a hierarchy of categorized links.
PR: ports/60031 Submitted by: Allan Bowhill <abowhill@blarg.net>
Notes
Notes: svn path=/head/; revision=96603
Diffstat (limited to 'www/emp')
-rw-r--r--www/emp/Makefile30
-rw-r--r--www/emp/distinfo1
-rw-r--r--www/emp/pkg-descr5
-rw-r--r--www/emp/pkg-plist6
4 files changed, 42 insertions, 0 deletions
diff --git a/www/emp/Makefile b/www/emp/Makefile
new file mode 100644
index 000000000000..a3cbb35c3ae8
--- /dev/null
+++ b/www/emp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: emp
+# Date created: Oct 20, 2003
+# Whom: Allan Bowhill <abowhill@blarg.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emp
+PORTVERSION= 0.92
+CATEGORIES= www
+MASTER_SITES= http://www.blarg.net/~abowhill/
+
+MAINTAINER= abowhill@blarg.net
+COMMENT= CGI program to deliver hierarchy of web links
+
+HAS_CONFIGURE= yes
+
+CGI_BIN= ${LOCALBASE}/www/cgi-bin
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/emp ${CGI_BIN}/emp.cgi
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Samples/links.sample ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Samples/emp.cfg ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/emp/distinfo b/www/emp/distinfo
new file mode 100644
index 000000000000..423ff737ebe9
--- /dev/null
+++ b/www/emp/distinfo
@@ -0,0 +1 @@
+MD5 (emp-0.92.tar.gz) = 939d086193bda30bf9577356cb6de8d9
diff --git a/www/emp/pkg-descr b/www/emp/pkg-descr
new file mode 100644
index 000000000000..c283dfd9fe8c
--- /dev/null
+++ b/www/emp/pkg-descr
@@ -0,0 +1,5 @@
+EMP (Easy Maintenance Pages) is a heirarchical web delivery system.
+It is written in C++. It is small, fast and has a clean appearance.
+It makes a web site of categorized links that is easy to maintain.
+
+WWW: http://www.blarg.net/~abowhill
diff --git a/www/emp/pkg-plist b/www/emp/pkg-plist
new file mode 100644
index 000000000000..acfc605c4011
--- /dev/null
+++ b/www/emp/pkg-plist
@@ -0,0 +1,6 @@
+www/cgi-bin/emp.cgi
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/links.sample
+%%EXAMPLESDIR%%/emp.cfg
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%