aboutsummaryrefslogtreecommitdiff
path: root/www/erlang-mochiweb-basho
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-07-06 22:34:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-07-06 22:34:11 +0000
commit37893c2bae470a4676caf15fe598c2299f989b56 (patch)
tree3e29cba43e97a56867bc38f2a6f4fec18fcc241a /www/erlang-mochiweb-basho
parenta0b3668460499425f5779bcd059f7ac0ef42e65c (diff)
downloadports-37893c2bae470a4676caf15fe598c2299f989b56.tar.gz
ports-37893c2bae470a4676caf15fe598c2299f989b56.zip
Update the remaining Erlang ports to use erlang.mk.
A few mistakes in plists came up, so these ports get a PORTREVISION bump. Some of the older ports are still left out.
Notes
Notes: svn path=/head/; revision=391484
Diffstat (limited to 'www/erlang-mochiweb-basho')
-rw-r--r--www/erlang-mochiweb-basho/Makefile20
-rw-r--r--www/erlang-mochiweb-basho/pkg-plist13
2 files changed, 15 insertions, 18 deletions
diff --git a/www/erlang-mochiweb-basho/Makefile b/www/erlang-mochiweb-basho/Makefile
index b58188677c31..900b2eee5e23 100644
--- a/www/erlang-mochiweb-basho/Makefile
+++ b/www/erlang-mochiweb-basho/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mochiweb
PORTVERSION= 2.9.0p1
+PORTREVISION= 1
CATEGORIES= www devel
PKGNAMEPREFIX= erlang-
PKGNAMESUFFIX= -basho
@@ -11,30 +12,15 @@ COMMENT= Erlang library for building lightweight HTTP servers (Basho fork)
LICENSE= MIT
-BUILD_DEPENDS= erl:${PORTSDIR}/lang/erlang
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
CONFLICTS= mochiweb-[0-9]*
-PLIST_SUB= VERSION="${PORTVERSION}"
-
+USES= erlang:rebar
USE_GITHUB= yes
GH_ACCOUNT= basho
GH_TAGNAME= ade2a9b # required
-do-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- for FILE in CHANGES.md README.md; do \
- ${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
- done
+post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
- ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
- ${INSTALL_DATA} ${WRKSRC}/include/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
- ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
.include <bsd.port.mk>
diff --git a/www/erlang-mochiweb-basho/pkg-plist b/www/erlang-mochiweb-basho/pkg-plist
index 3a7eb6b8f5ac..643f0eedf58b 100644
--- a/www/erlang-mochiweb-basho/pkg-plist
+++ b/www/erlang-mochiweb-basho/pkg-plist
@@ -36,6 +36,18 @@ lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_util.beam
lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_websocket.beam
lib/erlang/lib/mochiweb-%%VERSION%%/ebin/reloader.beam
lib/erlang/lib/mochiweb-%%VERSION%%/include/internal.hrl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/Makefile
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/priv/www/index.html
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/Makefile
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel.app
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel.hrl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel_app.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel_deps.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel_sup.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/src/skel_web.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/start-dev.sh
+lib/erlang/lib/mochiweb-%%VERSION%%/priv/skel/start.sh
lib/erlang/lib/mochiweb-%%VERSION%%/src/Makefile
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt_records.erl
@@ -75,7 +87,6 @@ lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_sup.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_util.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_websocket.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/reloader.erl
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.md
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api.hrl