aboutsummaryrefslogtreecommitdiff
path: root/www/evolution-caldav
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:33:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:33:02 +0000
commit80b8f841389c94bdb13a30c08752f3e0a38b7b25 (patch)
treed7319af1c4e3b0766874d6532849f116cdae8505 /www/evolution-caldav
parentd84ae449f1004925332825bfe305df58f21567f0 (diff)
downloadports-80b8f841389c94bdb13a30c08752f3e0a38b7b25.tar.gz
ports-80b8f841389c94bdb13a30c08752f3e0a38b7b25.zip
Add evolution-caldav, a CalDAV provider for Evolution. CalDAV is an extension
of WebDAV that offers additional calendaring features such as fanout, recurrance, and notifications. WWW: http://ietf.webdav.org/caldav/home.html
Notes
Notes: svn path=/head/; revision=147329
Diffstat (limited to 'www/evolution-caldav')
-rw-r--r--www/evolution-caldav/Makefile35
-rw-r--r--www/evolution-caldav/distinfo2
-rw-r--r--www/evolution-caldav/files/patch-eplugin.mk5
-rw-r--r--www/evolution-caldav/pkg-descr8
-rw-r--r--www/evolution-caldav/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/www/evolution-caldav/Makefile b/www/evolution-caldav/Makefile
new file mode 100644
index 000000000000..2c0aed13d394
--- /dev/null
+++ b/www/evolution-caldav/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: evolution-caldav
+# Date created: 31 August 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/www/evolution-caldav/Makefile,v 1.1 2005/08/31 21:40:00 marcus Exp $
+#
+
+PORTNAME= caldav
+PORTVERSION= 2.3.99.2
+CATEGORIES= www gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PKGNAMEPREFIX}${PORTNAME}/2.3
+PKGNAMEPREFIX= evolution-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= CalDAV provider for Evolution
+
+BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL= yes
+USE_GNOME= gnomeprefix gnomehack intlhack
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+EVO_VERSION= 2.4
+PLIST_SUB= EVO_VERSION=${EVO_VERSION} EDS_VERSION="1.2"
+
+.include <bsd.port.mk>
diff --git a/www/evolution-caldav/distinfo b/www/evolution-caldav/distinfo
new file mode 100644
index 000000000000..9c4e583b2e5c
--- /dev/null
+++ b/www/evolution-caldav/distinfo
@@ -0,0 +1,2 @@
+MD5 (evolution-caldav-2.3.99.2.tar.bz2) = 017b3739cc1a568708978344d48fc6f5
+SIZE (evolution-caldav-2.3.99.2.tar.bz2) = 256562
diff --git a/www/evolution-caldav/files/patch-eplugin.mk b/www/evolution-caldav/files/patch-eplugin.mk
new file mode 100644
index 000000000000..f36878362a74
--- /dev/null
+++ b/www/evolution-caldav/files/patch-eplugin.mk
@@ -0,0 +1,5 @@
+--- eplugin.mk.orig Wed Aug 31 17:21:09 2005
++++ eplugin.mk Wed Aug 31 17:22:10 2005
+@@ -0,0 +1,2 @@
++%.eplug: %.eplug.in
++ sed -e 's|\@PLUGINDIR\@|$(eplugindir)|;s|\@LOCALEDIR\@|$(localedir)|;s|\@GETTEXT_PACKAGE\@|$(GETTEXT_PACKAGE)|' $< > $@
diff --git a/www/evolution-caldav/pkg-descr b/www/evolution-caldav/pkg-descr
new file mode 100644
index 000000000000..6c436d840241
--- /dev/null
+++ b/www/evolution-caldav/pkg-descr
@@ -0,0 +1,8 @@
+Evolution-caldav is a CalDAV provider for Evolution. CalDAV is an extension
+of WebDAV that offers additional calendaring features such as fanout,
+recurrance, and notifications.
+
+See http://ietf.webdav.org/caldav/home.html for more details on the
+technology.
+
+WWW: http://ietf.webdav.org/caldav/home.html
diff --git a/www/evolution-caldav/pkg-plist b/www/evolution-caldav/pkg-plist
new file mode 100644
index 000000000000..184663a69eae
--- /dev/null
+++ b/www/evolution-caldav/pkg-plist
@@ -0,0 +1,3 @@
+lib/evolution/%%EVO_VERSION%%/plugins/liborg-gnome-evolution-caldav.so
+lib/evolution/%%EVO_VERSION%%/plugins/org-gnome-evolution-caldav.eplug
+lib/evolution-data-server-%%EDS_VERSION%%/extensions/libecalbackendcaldav.so