aboutsummaryrefslogtreecommitdiff
path: root/www/feedonfeeds
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-08 03:31:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-08 03:31:15 +0000
commit0306719dcba0e647cbbcf989bc8a3275389bf413 (patch)
tree956b705e10b9a4fcca07afc9b3c6064d0851e858 /www/feedonfeeds
parentf73c4e7068f1594955b14daff500d575de727f5d (diff)
downloadports-0306719dcba0e647cbbcf989bc8a3275389bf413.tar.gz
ports-0306719dcba0e647cbbcf989bc8a3275389bf413.zip
add feedonfeeds 0.1.7
Server side personal RSS (and Atom) aggregator
Notes
Notes: svn path=/head/; revision=113179
Diffstat (limited to 'www/feedonfeeds')
-rw-r--r--www/feedonfeeds/Makefile26
-rw-r--r--www/feedonfeeds/distinfo2
-rw-r--r--www/feedonfeeds/pkg-descr18
-rw-r--r--www/feedonfeeds/pkg-plist37
4 files changed, 83 insertions, 0 deletions
diff --git a/www/feedonfeeds/Makefile b/www/feedonfeeds/Makefile
new file mode 100644
index 000000000000..16c4eb31a460
--- /dev/null
+++ b/www/feedonfeeds/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: feedonfeeds
+# Date created: Jul 8, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= feedonfeeds
+PORTVERSION= 0.1.7
+CATEGORIES= www
+MASTER_SITES= http://minutillo.com/steve/feedonfeeds/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Server side personal RSS (and Atom) aggregator
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+USE_MYSQL= yes
+NO_BUILD= yes
+DATADIR?= ${PREFIX}/www/data/feedonfeeds
+
+do-install:
+ ${CP} -R ${WRKSRC}/ ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/feedonfeeds/distinfo b/www/feedonfeeds/distinfo
new file mode 100644
index 000000000000..eaa7e9b48120
--- /dev/null
+++ b/www/feedonfeeds/distinfo
@@ -0,0 +1,2 @@
+MD5 (feedonfeeds-0.1.7.tar.gz) = 7ab46dc102bebc54a2711d78cf05054e
+SIZE (feedonfeeds-0.1.7.tar.gz) = 40223
diff --git a/www/feedonfeeds/pkg-descr b/www/feedonfeeds/pkg-descr
new file mode 100644
index 000000000000..4368107637f2
--- /dev/null
+++ b/www/feedonfeeds/pkg-descr
@@ -0,0 +1,18 @@
+Desktop aggregators are great. They sit there all day, pinging away at sites,
+and as soon as they notice something new, they pop up little windows on your
+desktop, and let you read items. But what about when you go home from work?
+Or what about when you are on a trip? You get totally out of sync, and don't
+know what you've read and haven't read. You are enraged.
+
+Feed on Feeds A server side aggregator solves this. It keeps track of what
+items you've read, and keeps happily checking up on your feeds no matter where
+you are. Whenever you want to see what's new, you just bring up a web page and
+scan the newest items. You can mark the items as read so they won't be shown
+again. Or, you can just always show the most recent N items, like the way
+LiveJournal's friends pages work. Also, having the aggregator in your browser
+eliminates the "impedance mismatch" that sometimes occurs between a desktop
+aggregator and your browser. All your native browsing methods work on a
+FEED ON FEEDS page. Open pages in new tabs, bookmark them for later, browse
+whatever way you like.
+
+WWW: http://minutillo.com/steve/feedonfeeds/
diff --git a/www/feedonfeeds/pkg-plist b/www/feedonfeeds/pkg-plist
new file mode 100644
index 000000000000..2b6c77c091a5
--- /dev/null
+++ b/www/feedonfeeds/pkg-plist
@@ -0,0 +1,37 @@
+%%DATADIR%%/CHANGELOG
+%%DATADIR%%/LICENSE
+%%DATADIR%%/add.php
+%%DATADIR%%/config.php
+%%DATADIR%%/delete.php
+%%DATADIR%%/fof.css
+%%DATADIR%%/fof.js
+%%DATADIR%%/frames/feeds.php
+%%DATADIR%%/frames/fof-frames.css
+%%DATADIR%%/frames/index.php
+%%DATADIR%%/frames/menu.php
+%%DATADIR%%/frames/view-action.php
+%%DATADIR%%/frames/view.php
+%%DATADIR%%/index.php
+%%DATADIR%%/init.php
+%%DATADIR%%/install.php
+%%DATADIR%%/magpierss/AUTHORS
+%%DATADIR%%/magpierss/README
+%%DATADIR%%/magpierss/README.FoF
+%%DATADIR%%/magpierss/extlib/Snoopy.class.inc
+%%DATADIR%%/magpierss/rss_cache.inc
+%%DATADIR%%/magpierss/rss_fetch.inc
+%%DATADIR%%/magpierss/rss_parse.inc
+%%DATADIR%%/magpierss/rss_utils.inc
+%%DATADIR%%/mark-read.php
+%%DATADIR%%/opml.php
+%%DATADIR%%/panel-menu.html
+%%DATADIR%%/uninstall.php
+%%DATADIR%%/update-quiet.php
+%%DATADIR%%/update.php
+%%DATADIR%%/view-action.php
+%%DATADIR%%/view-menu.html
+%%DATADIR%%/view.php
+@dirrm %%DATADIR%%/frames
+@dirrm %%DATADIR%%/magpierss/extlib
+@dirrm %%DATADIR%%/magpierss
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true