aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-27 14:42:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-27 14:42:51 +0000
commitc308de0164ec299c9914722e02f9e6176f6c5b89 (patch)
tree87818ee8a7843c06fbfd36d7cfd6ceb05961d08b /www/firefox-esr
parent2e65f711707124d3061bd2821e9efd29b3e61d8f (diff)
downloadports-c308de0164ec299c9914722e02f9e6176f6c5b89.tar.gz
ports-c308de0164ec299c9914722e02f9e6176f6c5b89.zip
- Update Firefox to 36.0
- Update Firefox ESR to 31.5.0 - Update Thunderbird to 31.5.0 - Update libxul to 31.5.0 - Check if NS_NewNativeLocalFile() succeeds before using [1] - Remove DTRACE and GIO descriptions after r377838 and r314893 - bsd.gecko.mk: Prune conditionals for files removed 4 months ago Changes: https://www.mozilla.org/firefox/36.0/releasenotes/ Obtained from: PkgSrc [1] MFH: 2015Q1 X-MFH-With: r377953, r378253, r379485, r378529 Security: https://vuxml.freebsd.org/freebsd/99029172-8253-407d-9d8b-2cfeab9abf81.html
Notes
Notes: svn path=/head/; revision=380090
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile3
-rw-r--r--www/firefox-esr/distinfo4
-rw-r--r--www/firefox-esr/files/patch-bug102176193
-rw-r--r--www/firefox-esr/files/patch-bug1083461156
-rw-r--r--www/firefox-esr/files/patch-bug99125310
5 files changed, 55 insertions, 211 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 8d0de5c2a62b..f50aaa1db271 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 31.4.0
+DISTVERSION= 31.5.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index 7fd1418d0164..5a4686dd6cf6 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-31.4.0esr.source.tar.bz2) = c5ad8b588fb1e7690be5da04f627335f6440277dac4bccd46e6687fcf2fbc23b
-SIZE (firefox-31.4.0esr.source.tar.bz2) = 147935703
+SHA256 (firefox-31.5.0esr.source.tar.bz2) = d4243bf74a4421b590f5580f71486f8608a1a483d4779b44ab0e39d6bbf64b6a
+SIZE (firefox-31.5.0esr.source.tar.bz2) = 147757474
diff --git a/www/firefox-esr/files/patch-bug1021761 b/www/firefox-esr/files/patch-bug1021761
index bd0a689f12c7..1d0cde369c34 100644
--- a/www/firefox-esr/files/patch-bug1021761
+++ b/www/firefox-esr/files/patch-bug1021761
@@ -2,7 +2,7 @@ diff --git configure.in configure.in
index 48e60c0..ec08417 100644
--- configure.in
+++ configure.in
-@@ -5438,6 +5438,60 @@ fi
+@@ -5591,6 +5591,67 @@ fi
AC_SUBST(MOZ_WEBM_ENCODER)
dnl ==================================
@@ -16,33 +16,40 @@ index 48e60c0..ec08417 100644
+ ;;
+esac
+
-+MOZ_ARG_DISABLE_BOOL(oss,
-+[ --disable-oss Disable OpenSoundSystem support],
-+ MOZ_OSS=,
-+ MOZ_OSS=1)
++MOZ_ARG_WITH_STRING(oss,
++[ --with-oss[=PFX] Enable OpenSoundSystem support [installed at prefix PFX]],
++ OSSPREFIX=$withval)
++
++if test -n "$OSSPREFIX"; then
++ if test "$OSSPREFIX" != "no"; then
++ MOZ_OSS=1
++ else
++ MOZ_OSS=
++ fi
++fi
+
+_SAVE_CFLAGS=$CFLAGS
+_SAVE_LIBS=$LIBS
+if test -n "$MOZ_OSS"; then
+ dnl Prefer 4Front implementation
+ AC_MSG_CHECKING([MOZ_OSS_CFLAGS])
-+ if test -z "$MOZ_OSS_CFLAGS"; then
-+ for oss_conf in /etc/oss.conf /usr/local/etc/oss.conf; do
-+ if test -e "$oss_conf"; then
-+ . "$oss_conf"
-+ fi
-+ done
++ if test "$OSSPREFIX" != "yes"; then
++ oss_conf=${OSSPREFIX%/usr}/etc/oss.conf
++ if test -f "$oss_conf"; then
++ . "$oss_conf"
++ else
++ OSSLIBDIR=$OSSPREFIX/lib/oss
++ fi
+ if test -d "$OSSLIBDIR"; then
-+ MOZ_OSS_CFLAGS="-I$OSSLIBDIR/include"
++ MOZ_OSS_CFLAGS="$MOZ_OSS_CFLAGS -I$OSSLIBDIR/include"
+ fi
+ fi
+ AC_MSG_RESULT([$MOZ_OSS_CFLAGS])
+
+ CFLAGS="$CFLAGS $MOZ_OSS_CFLAGS"
-+ MOZ_CHECK_HEADERS(sys/soundcard.h linux/soundcard.h soundcard.h)
++ MOZ_CHECK_HEADERS(sys/soundcard.h soundcard.h)
+
+ if test "$ac_cv_header_sys_soundcard_h" != "yes" -a \
-+ "$ac_cv_header_linux_soundcard_h" != "yes" -a \
+ "$ac_cv_header_soundcard_h" != "yes"; then
+ AC_MSG_ERROR([Need OSS for Ogg, Wave or WebM decoding on $OS_TARGET. Disable with --disable-ogg --disable-wave --disable-webm.])
+ fi
@@ -50,7 +57,7 @@ index 48e60c0..ec08417 100644
+ dnl Assume NetBSD implementation over SunAudio
+ AC_CHECK_LIB(ossaudio, _oss_ioctl,
+ [AC_DEFINE_UNQUOTED(CUBEB_OSS_DEFAULT_OUTPUT, "/dev/sound")
-+ MOZ_OSS_LIBS="-lossaudio"])
++ MOZ_OSS_LIBS="$MOZ_OSS_LIBS -lossaudio"])
+fi
+CFLAGS=$_SAVE_CFLAGS
+LIBS=$_SAVE_LIBS
@@ -63,30 +70,6 @@ index 48e60c0..ec08417 100644
dnl = Check alsa availability on Linux
dnl ==================================
-@@ -5451,12 +5505,23 @@ MOZ_ARG_ENABLE_BOOL(alsa,
- MOZ_ALSA=1,
- MOZ_ALSA=)
-
-+MOZ_ARG_DISABLE_BOOL(alsa-dlopen,
-+[ --disable-alsa-dlopen Disable runtime linking of libasound.so],
-+ DISABLE_LIBASOUND_DLOPEN=1,
-+ DISABLE_LIBASOUND_DLOPEN=)
-+
- if test -n "$MOZ_ALSA"; then
- PKG_CHECK_MODULES(MOZ_ALSA, alsa, ,
- [echo "$MOZ_ALSA_PKG_ERRORS"
- AC_MSG_ERROR([Need alsa for Ogg, Wave or WebM decoding on Linux. Disable with --disable-ogg --disable-wave --disable-webm. (On Ubuntu, you might try installing the package libasound2-dev.)])])
- fi
-
-+if test -n "$DISABLE_LIBASOUND_DLOPEN"; then
-+ AC_DEFINE(DISABLE_LIBASOUND_DLOPEN)
-+else
-+ MOZ_ALSA_LIBS=
-+fi
-+
- AC_SUBST(MOZ_ALSA)
-
- dnl ========================================================
diff --git media/libcubeb/AUTHORS media/libcubeb/AUTHORS
index b441e8a..950d9e5 100644
--- media/libcubeb/AUTHORS
@@ -651,7 +634,7 @@ new file mode 100644
index 0000000..5e38e27
--- /dev/null
+++ media/libcubeb/src/cubeb_oss.c
-@@ -0,0 +1,399 @@
+@@ -0,0 +1,397 @@
+/*
+ * Copyright © 2014 Mozilla Foundation
+ *
@@ -660,8 +643,6 @@ index 0000000..5e38e27
+ */
+#if defined(HAVE_SYS_SOUNDCARD_H)
+#include <sys/soundcard.h>
-+#elif defined(HAVE_LINUX_SOUNDCARD_H)
-+#include <linux/soundcard.h>
+#else
+#include <soundcard.h>
+#endif
@@ -1075,18 +1056,36 @@ index 8b7a0dd..31212ce 100644
+CFLAGS += CONFIG['MOZ_OSS_CFLAGS']
CFLAGS += CONFIG['MOZ_ALSA_CFLAGS']
CFLAGS += CONFIG['MOZ_PULSEAUDIO_CFLAGS']
+diff --git media/webrtc/signaling/test/Makefile.in media/webrtc/signaling/test/Makefile.in
+index 991f03f..3d99eb5 100644
+--- media/webrtc/signaling/test/Makefile.in
++++ media/webrtc/signaling/test/Makefile.in
+@@ -26,9 +26,9 @@ ifdef JS_SHARED_LIBRARY
+ LIBS += $(MOZ_JS_LIBS)
+ endif
+
+-ifdef MOZ_ALSA
++ifdef MOZ_OSS
+ LIBS += \
+- $(MOZ_ALSA_LIBS) \
++ $(MOZ_OSS_LIBS) \
+ $(NULL)
+ endif
+
diff --git toolkit/library/libxul.mk toolkit/library/libxul.mk
index e191f13..4fb268a 100644
--- toolkit/library/libxul.mk
+++ toolkit/library/libxul.mk
-@@ -146,6 +146,10 @@ OS_LIBS += $(call EXPAND_LIBNAME,secur32
+@@ -146,9 +146,9 @@ OS_LIBS += $(call EXPAND_LIBNAME,secur32
endif
endif
+-ifdef MOZ_ALSA
+-EXTRA_DSO_LDOPTS += $(MOZ_ALSA_LIBS)
+-endif
+ifdef MOZ_OSS
+EXTRA_DSO_LDOPTS += $(MOZ_OSS_LIBS)
+endif
-+
- ifdef MOZ_ALSA
- EXTRA_DSO_LDOPTS += $(MOZ_ALSA_LIBS)
- endif
+
+ ifdef HAVE_CLOCK_MONOTONIC
+ EXTRA_DSO_LDOPTS += $(REALTIME_LIBS)
diff --git a/www/firefox-esr/files/patch-bug1083461 b/www/firefox-esr/files/patch-bug1083461
deleted file mode 100644
index 66989e0e7cf6..000000000000
--- a/www/firefox-esr/files/patch-bug1083461
+++ /dev/null
@@ -1,156 +0,0 @@
-commit c97894b
-Author: L. David Baron <dbaron@dbaron.org>
-Date: Sun Oct 19 23:31:39 2014 -0400
-
- Bug 1083461 - Convert nsCSSValue{,Pair}List::operator== back to a static Equal method so that it can be validly called on null pointers. r=bzbarsky approval-mozilla-esr31=bkerensa
----
- layout/style/nsCSSValue.cpp | 28 ++++++++++++++++------------
- layout/style/nsCSSValue.h | 22 ++++++++++++++++------
- layout/style/nsStyleAnimation.cpp | 6 ++++--
- 3 files changed, 36 insertions(+), 20 deletions(-)
-
-diff --git layout/style/nsCSSValue.cpp layout/style/nsCSSValue.cpp
-index 781ef65..4bbc979 100644
---- layout/style/nsCSSValue.cpp
-+++ layout/style/nsCSSValue.cpp
-@@ -253,13 +253,14 @@ bool nsCSSValue::operator==(const nsCSSValue& aOther) const
- return *mValue.mRect == *aOther.mValue.mRect;
- }
- else if (eCSSUnit_List == mUnit) {
-- return *mValue.mList == *aOther.mValue.mList;
-+ return nsCSSValueList::Equal(mValue.mList, aOther.mValue.mList);
- }
- else if (eCSSUnit_SharedList == mUnit) {
- return *mValue.mSharedList == *aOther.mValue.mSharedList;
- }
- else if (eCSSUnit_PairList == mUnit) {
-- return *mValue.mPairList == *aOther.mValue.mPairList;
-+ return nsCSSValuePairList::Equal(mValue.mPairList,
-+ aOther.mValue.mPairList);
- }
- else if (eCSSUnit_GridTemplateAreas == mUnit) {
- return *mValue.mGridTemplateAreas == *aOther.mValue.mGridTemplateAreas;
-@@ -1740,13 +1741,15 @@ nsCSSValueList::AppendToString(nsCSSProperty aProperty, nsAString& aResult,
- }
- }
-
--bool
--nsCSSValueList::operator==(const nsCSSValueList& aOther) const
-+/* static */ bool
-+nsCSSValueList::Equal(const nsCSSValueList* aList1,
-+ const nsCSSValueList* aList2)
- {
-- if (this == &aOther)
-+ if (aList1 == aList2) {
- return true;
-+ }
-
-- const nsCSSValueList *p1 = this, *p2 = &aOther;
-+ const nsCSSValueList *p1 = aList1, *p2 = aList2;
- for ( ; p1 && p2; p1 = p1->mNext, p2 = p2->mNext) {
- if (p1->mValue != p2->mValue)
- return false;
-@@ -1799,8 +1802,7 @@ nsCSSValueSharedList::AppendToString(nsCSSProperty aProperty, nsAString& aResult
- bool
- nsCSSValueSharedList::operator==(const nsCSSValueSharedList& aOther) const
- {
-- return !mHead == !aOther.mHead &&
-- (!mHead || *mHead == *aOther.mHead);
-+ return nsCSSValueList::Equal(mHead, aOther.mHead);
- }
-
- size_t
-@@ -2010,13 +2012,15 @@ nsCSSValuePairList::AppendToString(nsCSSProperty aProperty,
- }
- }
-
--bool
--nsCSSValuePairList::operator==(const nsCSSValuePairList& aOther) const
-+/* static */ bool
-+nsCSSValuePairList::Equal(const nsCSSValuePairList* aList1,
-+ const nsCSSValuePairList* aList2)
- {
-- if (this == &aOther)
-+ if (aList1 == aList2) {
- return true;
-+ }
-
-- const nsCSSValuePairList *p1 = this, *p2 = &aOther;
-+ const nsCSSValuePairList *p1 = aList1, *p2 = aList2;
- for ( ; p1 && p2; p1 = p1->mNext, p2 = p2->mNext) {
- if (p1->mXValue != p2->mXValue ||
- p1->mYValue != p2->mYValue)
-diff --git layout/style/nsCSSValue.h layout/style/nsCSSValue.h
-index 753938c..77eeef0 100644
---- layout/style/nsCSSValue.h
-+++ layout/style/nsCSSValue.h
-@@ -806,9 +806,8 @@ struct nsCSSValueList {
- void AppendToString(nsCSSProperty aProperty, nsAString& aResult,
- nsCSSValue::Serialization aValueSerialization) const;
-
-- bool operator==(nsCSSValueList const& aOther) const;
-- bool operator!=(const nsCSSValueList& aOther) const
-- { return !(*this == aOther); }
-+ static bool Equal(const nsCSSValueList* aList1,
-+ const nsCSSValueList* aList2);
-
- size_t SizeOfIncludingThis(mozilla::MallocSizeOf aMallocSizeOf) const;
-
-@@ -821,6 +820,12 @@ private:
- {
- MOZ_COUNT_CTOR(nsCSSValueList);
- }
-+
-+ // We don't want operator== or operator!= because they wouldn't be
-+ // null-safe, which is generally what we need. Use |Equal| method
-+ // above instead.
-+ bool operator==(nsCSSValueList const& aOther) const MOZ_DELETE;
-+ bool operator!=(const nsCSSValueList& aOther) const MOZ_DELETE;
- };
-
- // nsCSSValueList_heap differs from nsCSSValueList only in being
-@@ -1199,9 +1204,8 @@ struct nsCSSValuePairList {
- void AppendToString(nsCSSProperty aProperty, nsAString& aResult,
- nsCSSValue::Serialization aValueSerialization) const;
-
-- bool operator==(const nsCSSValuePairList& aOther) const;
-- bool operator!=(const nsCSSValuePairList& aOther) const
-- { return !(*this == aOther); }
-+ static bool Equal(const nsCSSValuePairList* aList1,
-+ const nsCSSValuePairList* aList2);
-
- size_t SizeOfIncludingThis(mozilla::MallocSizeOf aMallocSizeOf) const;
-
-@@ -1215,6 +1219,12 @@ private:
- {
- MOZ_COUNT_CTOR(nsCSSValuePairList);
- }
-+
-+ // We don't want operator== or operator!= because they wouldn't be
-+ // null-safe, which is generally what we need. Use |Equal| method
-+ // above instead.
-+ bool operator==(const nsCSSValuePairList& aOther) const MOZ_DELETE;
-+ bool operator!=(const nsCSSValuePairList& aOther) const MOZ_DELETE;
- };
-
- // nsCSSValuePairList_heap differs from nsCSSValuePairList only in being
-diff --git layout/style/nsStyleAnimation.cpp layout/style/nsStyleAnimation.cpp
-index 6c2ccb0..8dbe404 100644
---- layout/style/nsStyleAnimation.cpp
-+++ layout/style/nsStyleAnimation.cpp
-@@ -3816,11 +3816,13 @@ nsStyleAnimation::Value::operator==(const Value& aOther) const
- case eUnit_Filter:
- case eUnit_Shadow:
- case eUnit_BackgroundPosition:
-- return *mValue.mCSSValueList == *aOther.mValue.mCSSValueList;
-+ return nsCSSValueList::Equal(mValue.mCSSValueList,
-+ aOther.mValue.mCSSValueList);
- case eUnit_Transform:
- return *mValue.mCSSValueSharedList == *aOther.mValue.mCSSValueSharedList;
- case eUnit_CSSValuePairList:
-- return *mValue.mCSSValuePairList == *aOther.mValue.mCSSValuePairList;
-+ return nsCSSValuePairList::Equal(mValue.mCSSValuePairList,
-+ aOther.mValue.mCSSValuePairList);
- case eUnit_UnparsedString:
- return (NS_strcmp(GetStringBufferValue(),
- aOther.GetStringBufferValue()) == 0);
diff --git a/www/firefox-esr/files/patch-bug991253 b/www/firefox-esr/files/patch-bug991253
index 161feb2ca7b5..73d71610ab03 100644
--- a/www/firefox-esr/files/patch-bug991253
+++ b/www/firefox-esr/files/patch-bug991253
@@ -1,14 +1,16 @@
--- extensions/spellcheck/hunspell/src/mozHunspell.cpp~
+++ extensions/spellcheck/hunspell/src/mozHunspell.cpp
-@@ -400,6 +400,12 @@ mozHunspell::LoadDictionaryList()
+@@ -400,6 +400,14 @@ mozHunspell::LoadDictionaryList(bool aNo
}
}
+ // load system hunspell dictionaries
-+ nsIFile* hunDir;
++ nsCOMPtr<nsIFile> hunDir;
+ NS_NewNativeLocalFile(NS_LITERAL_CSTRING("%%LOCALBASE%%/share/hunspell"),
-+ true, &hunDir);
-+ LoadDictionariesFromDir(hunDir);
++ true, getter_AddRefs(hunDir));
++ if (hunDir) {
++ LoadDictionariesFromDir(hunDir);
++ }
+
// find dictionaries from extensions requiring restart
nsCOMPtr<nsISimpleEnumerator> dictDirs;