aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-06-09 14:25:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-06-09 14:25:41 +0000
commitf2fc9d6de460a59d2ca4633a80086dc32e24c086 (patch)
tree2ac32e924ca63b881b3775b37ea4a9ca3a11cc2c /www/firefox-esr
parent6828ea7d03181d2c9cef8349278476494f34aeaa (diff)
downloadports-f2fc9d6de460a59d2ca4633a80086dc32e24c086.tar.gz
ports-f2fc9d6de460a59d2ca4633a80086dc32e24c086.zip
multimedia/libvpx: update to 1.4.0
ABI isn't compatible, so bump PORTREVISION in consumers. Changes: https://chromium.googlesource.com/webm/libvpx/+/v1.4.0 Differential Revision: https://reviews.freebsd.org/D2570 Exp-run by: antoine Approved by: ashish, multimedia (kwm) Approved by: maintainer timeout (ale, dinoex; 2 weeks)
Notes
Notes: svn path=/head/; revision=388940
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox-esr/files/patch-bug106737778
2 files changed, 79 insertions, 0 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 9252ec301135..2968564da825 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,6 +4,7 @@
PORTNAME= firefox
DISTVERSION= 31.7.0
DISTVERSIONSUFFIX=esr.source
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1067377 b/www/firefox-esr/files/patch-bug1067377
new file mode 100644
index 000000000000..898af08b7cab
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1067377
@@ -0,0 +1,78 @@
+diff --git content/media/encoder/VP8TrackEncoder.cpp content/media/encoder/VP8TrackEncoder.cpp
+index 452821c..ede21c5 100644
+--- content/media/encoder/VP8TrackEncoder.cpp
++++ content/media/encoder/VP8TrackEncoder.cpp
+@@ -84,7 +84,7 @@ VP8TrackEncoder::Init(int32_t aWidth, int32_t aHeight, int32_t aDisplayWidth,
+ // Creating a wrapper to the image - setting image data to NULL. Actual
+ // pointer will be set in encode. Setting align to 1, as it is meaningless
+ // (actual memory is not allocated).
+- vpx_img_wrap(mVPXImageWrapper, IMG_FMT_I420,
++ vpx_img_wrap(mVPXImageWrapper, VPX_IMG_FMT_I420,
+ mFrameWidth, mFrameHeight, 1, nullptr);
+
+ config.g_w = mFrameWidth;
+@@ -239,9 +239,9 @@ void VP8TrackEncoder::PrepareMutedFrame()
+ uint8_t *cb = mMuteFrame.Elements() + yPlaneSize;
+ uint8_t *cr = mMuteFrame.Elements() + yPlaneSize + uvPlaneSize;
+
+- mVPXImageWrapper->planes[PLANE_Y] = y;
+- mVPXImageWrapper->planes[PLANE_U] = cb;
+- mVPXImageWrapper->planes[PLANE_V] = cr;
++ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
++ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
++ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
+ mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
+ mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
+ mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
+@@ -297,9 +297,9 @@ nsresult VP8TrackEncoder::PrepareRawFrame(VideoChunk &aChunk)
+ const PlanarYCbCrImage::Data *data = yuv->GetData();
+
+ if (isYUV420(data) && !data->mCbSkip) { // 420 planar
+- mVPXImageWrapper->planes[PLANE_Y] = data->mYChannel;
+- mVPXImageWrapper->planes[PLANE_U] = data->mCbChannel;
+- mVPXImageWrapper->planes[PLANE_V] = data->mCrChannel;
++ mVPXImageWrapper->planes[VPX_PLANE_Y] = data->mYChannel;
++ mVPXImageWrapper->planes[VPX_PLANE_U] = data->mCbChannel;
++ mVPXImageWrapper->planes[VPX_PLANE_V] = data->mCrChannel;
+ mVPXImageWrapper->stride[VPX_PLANE_Y] = data->mYStride;
+ mVPXImageWrapper->stride[VPX_PLANE_U] = data->mCbCrStride;
+ mVPXImageWrapper->stride[VPX_PLANE_V] = data->mCbCrStride;
+@@ -355,9 +355,9 @@ nsresult VP8TrackEncoder::PrepareRawFrame(VideoChunk &aChunk)
+ return NS_ERROR_NOT_IMPLEMENTED;
+ }
+
+- mVPXImageWrapper->planes[PLANE_Y] = y;
+- mVPXImageWrapper->planes[PLANE_U] = cb;
+- mVPXImageWrapper->planes[PLANE_V] = cr;
++ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
++ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
++ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
+ mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
+ mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
+ mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
+diff --git media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
+index d9c3a22..75195ae 100644
+--- media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
++++ media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
+@@ -180,7 +180,7 @@ int VP8EncoderImpl::InitEncode(const VideoCodec* inst,
+ // Creating a wrapper to the image - setting image data to NULL. Actual
+ // pointer will be set in encode. Setting align to 1, as it is meaningless
+ // (actual memory is not allocated).
+- raw_ = vpx_img_wrap(NULL, IMG_FMT_I420, codec_.width, codec_.height,
++ raw_ = vpx_img_wrap(NULL, VPX_IMG_FMT_I420, codec_.width, codec_.height,
+ 1, NULL);
+ // populate encoder configuration with default values
+ if (vpx_codec_enc_config_default(vpx_codec_vp8_cx(), config_, 0)) {
+@@ -349,9 +349,9 @@ int VP8EncoderImpl::Encode(const I420VideoFrame& input_image,
+ }
+ // Image in vpx_image_t format.
+ // Input image is const. VP8's raw image is not defined as const.
+- raw_->planes[PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
+- raw_->planes[PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
+- raw_->planes[PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
++ raw_->planes[VPX_PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
++ raw_->planes[VPX_PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
++ raw_->planes[VPX_PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
+ // TODO(mikhal): Stride should be set in initialization.
+ raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
+ raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);