aboutsummaryrefslogtreecommitdiff
path: root/www/firefox10
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-02-11 22:02:15 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-02-11 22:02:15 +0000
commit075bf4ee3d9fe6c8e48ff7652660ed38913f3769 (patch)
tree6ce8b5dc12377f93fb517ba4fc066a10b8d1d2cf /www/firefox10
parent0512440803fdfb494ca851ee0263eb700a252893 (diff)
downloadports-075bf4ee3d9fe6c8e48ff7652660ed38913f3769.tar.gz
ports-075bf4ee3d9fe6c8e48ff7652660ed38913f3769.zip
Add comments explaining the installation process.
Notes
Notes: svn path=/head/; revision=100715
Diffstat (limited to 'www/firefox10')
-rw-r--r--www/firefox10/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install: