aboutsummaryrefslogtreecommitdiff
path: root/www/firefox15
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-02-19 22:23:03 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-02-19 22:23:03 +0000
commit55b05955baa2d0dd0cbe5c429f2d1a088cc26abe (patch)
tree60dccd08b4977e7b233610e4ca619a167c16b2f1 /www/firefox15
parent8fd1dade69b9fdb0410f2d650c212f2338a3e5f4 (diff)
downloadports-55b05955baa2d0dd0cbe5c429f2d1a088cc26abe.tar.gz
ports-55b05955baa2d0dd0cbe5c429f2d1a088cc26abe.zip
Fix a problem where Firefox creates its ~/.mozilla directory using stack
garbage. PR: 92899 Submitted by: truckman
Notes
Notes: svn path=/head/; revision=156416
Diffstat (limited to 'www/firefox15')
-rw-r--r--www/firefox15/Makefile1
-rw-r--r--www/firefox15/files/patch-toolkit_xre_nsXREDirProvider.cpp19
2 files changed, 20 insertions, 0 deletions
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index a1487e7a1c1b..27ae5726bcb7 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -8,6 +8,7 @@
PORTNAME= firefox
DISTVERSION= 1.5.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox15/files/patch-toolkit_xre_nsXREDirProvider.cpp b/www/firefox15/files/patch-toolkit_xre_nsXREDirProvider.cpp
new file mode 100644
index 000000000000..0c5a07ab210d
--- /dev/null
+++ b/www/firefox15/files/patch-toolkit_xre_nsXREDirProvider.cpp
@@ -0,0 +1,19 @@
+--- toolkit/xre/nsXREDirProvider.cpp.orig Tue Oct 4 11:46:26 2005
++++ toolkit/xre/nsXREDirProvider.cpp Sun Feb 5 23:54:31 2006
+@@ -820,6 +820,7 @@
+
+ char* appNameFolder = nsnull;
+ char profileFolderName[MAXPATHLEN] = ".";
++ char temp[MAXPATHLEN];
+
+ // Offset 1 for the outermost folder to make it hidden (i.e. using the ".")
+ char* writing = profileFolderName + 1;
+@@ -829,7 +830,6 @@
+ rv = localDir->AppendNative(nsDependentCString(profileFolderName));
+ NS_ENSURE_SUCCESS(rv, rv);
+
+- char temp[MAXPATHLEN];
+ GetProfileFolderName(temp, gAppData->name);
+ appNameFolder = temp;
+ }
+