aboutsummaryrefslogtreecommitdiff
path: root/www/firefox3-devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-04 09:47:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-04 09:47:27 +0000
commit403955523cb287018d5a39d14b824adf826c7a52 (patch)
tree24790a6dd021d66894f68317de6c08baa7e9ff40 /www/firefox3-devel
parenteba98ce530fc6892eb28e658358202fa1e021acd (diff)
downloadports-403955523cb287018d5a39d14b824adf826c7a52.tar.gz
ports-403955523cb287018d5a39d14b824adf826c7a52.zip
Be sure to create the browser_plugins during package install as well. Some
ports (e.g. www/ump) depend on this directory being there. Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=123091
Diffstat (limited to 'www/firefox3-devel')
-rw-r--r--www/firefox3-devel/Makefile1
-rw-r--r--www/firefox3-devel/pkg-install.in4
2 files changed, 5 insertions, 0 deletions
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index 4eb85744734b..83de1a8e522c 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -126,6 +126,7 @@ post-extract::
post-patch:
@${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${FIREFOX}|g ; \
+ s|%%PREFIX%%|${PREFIX}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${FIREFOX}|g' \
diff --git a/www/firefox3-devel/pkg-install.in b/www/firefox3-devel/pkg-install.in
index 8f8dbd0c6cc3..f25aa135197d 100644
--- a/www/firefox3-devel/pkg-install.in
+++ b/www/firefox3-devel/pkg-install.in
@@ -29,4 +29,8 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGCHROME} || true
./run-mozilla.sh ${FIREFOX} -register > /dev/null 2>&1
+if [ ! -d %%PREFIX%%/lib/browser_plugins ]; then
+ mkdir -p %%PREFIX%%/lib/browser_plugins
+fi
+
exit 0