aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-22 04:04:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-22 04:04:52 +0000
commit43baba8dc134e8905b66072b05ebb86d140f5abe (patch)
tree45bc94f74c0c721b870c29e3e2794e061b53f772 /www/firefox36
parentc4a389c5051fc07a3fbbaa011d04dc407888f210 (diff)
downloadports-43baba8dc134e8905b66072b05ebb86d140f5abe.tar.gz
ports-43baba8dc134e8905b66072b05ebb86d140f5abe.zip
Use -Bsymbolic when linking nss to avoid symbol conflicts with libraries
that include OpenSSL (e.g. CUPS). This may help alleviate the problem with Firefox crashing when trying to print when using CUPS.
Notes
Notes: svn path=/head/; revision=122115
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile2
-rw-r--r--www/firefox36/files/patch-security-coreconf-FreeBSD.mk24
2 files changed, 20 insertions, 6 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index ec76e0eb1c33..4eb85744734b 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox36/files/patch-security-coreconf-FreeBSD.mk b/www/firefox36/files/patch-security-coreconf-FreeBSD.mk
index 73292a7362d5..3e0e14acaaf2 100644
--- a/www/firefox36/files/patch-security-coreconf-FreeBSD.mk
+++ b/www/firefox36/files/patch-security-coreconf-FreeBSD.mk
@@ -1,14 +1,28 @@
-$FreeBSD$
-
---- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
-+++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
-@@ -44,5 +44,9 @@
+--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
++++ security/coreconf/FreeBSD.mk Sun Nov 21 22:59:49 2004
+@@ -43,8 +43,12 @@
+ ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
+ endif
+endif
+
+ OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
+
+@@ -71,7 +75,11 @@
+ DLL_SUFFIX = so.1.0
endif
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
++ifneq (,$(filter alpha ia64,$(OS_TEST)))
++MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
++else
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
++endif
+ ifdef MAPFILE
+ # Add LD options to restrict exported symbols to those in the map file
+ endif