aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-12-28 00:51:58 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-12-28 00:51:58 +0000
commitb18bfe20763cad5c0ccbb4d65a2c21b9fce3cd92 (patch)
treea5c2f71b53741700d64b54e5ed12ab71016fa830 /www/firefox36
parent5387a16e23212ffcaefb4d9ba26bb4f5410a2db0 (diff)
downloadports-b18bfe20763cad5c0ccbb4d65a2c21b9fce3cd92.tar.gz
ports-b18bfe20763cad5c0ccbb4d65a2c21b9fce3cd92.zip
- Remove WITH_NEW_ICON knob
- Mozilla license team has approved the FreeBSD Gnome team to use official branding for firefox and thunderbird [1] o Add --enable-official-branding to mozconfig o Install official thunderbird/firefox icon as default.xpm icon - Fix error when running firefox/thunderbird -v [2] - Bump PORTREVISION References: http://www.mozilla.org/foundation/licensing.html [1] http://people.freebsd.org/~ahze/firefox_thunderbird-approved.txt [1] PR: ports/75262 [2] Submitted by: girgen [2]
Notes
Notes: svn path=/head/; revision=125299
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile11
-rw-r--r--www/firefox36/files/mozconfig.in3
-rw-r--r--www/firefox36/files/patch-browser_app_mozilla.in20
3 files changed, 24 insertions, 10 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 3a517a8a51cb..dcfe38d03564 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -66,8 +66,7 @@ OPTIONS= DEBUG "Build a debugging image" off \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
XFT "Enable support for anti-aliased fonts" on \
- SMB "Enable smb:// URI support using gnomevfs" off \
- NEW_ICON "Install the new Firefox branding icon" off
+ SMB "Enable smb:// URI support using gnomevfs" off
.include <bsd.port.pre.mk>
@@ -237,11 +236,9 @@ post-install:
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor
-.if defined(WITH_NEW_ICON)
- ${INSTALL_DATA} ${WRKSRC}/other-licenses/branding/firefox/default.xpm \
- ${PREFIX}/lib/${FIREFOX}/chrome/icons/default/default.xpm
-.endif # defined(WITH_NEW_ICON)
${INSTALL_DATA} ${FIREFOX_ICON_SRC} ${PREFIX}/share/gnome/pixmaps/${FIREFOX_ICON}
${INSTALL_DATA} ${WRKDIR}/firefox.desktop ${PREFIX}/share/gnome/applications
+ ${INSTALL_DATA} ${WRKSRC}/other-licenses/branding/firefox/default.xpm \
+ ${PREFIX}/lib/${FIREFOX}/chrome/icons/default/default.xpm
.include <bsd.port.post.mk>
diff --git a/www/firefox36/files/mozconfig.in b/www/firefox36/files/mozconfig.in
index a2c8dccba3ac..a354709bf72a 100644
--- a/www/firefox36/files/mozconfig.in
+++ b/www/firefox36/files/mozconfig.in
@@ -9,6 +9,9 @@ ac_add_options --disable-tests
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-default-toolkit=gtk2
+# See the following URL for approval email for using official branding
+# http://people.freebsd.org/~ahze/firefox_thunderbird-approved.txt
+ac_add_options --enable-official-branding
######################################################################
# FBSD specific
export CPPFLAGS="@CPPFLAGS@"
diff --git a/www/firefox36/files/patch-browser_app_mozilla.in b/www/firefox36/files/patch-browser_app_mozilla.in
index 3d5c7203e32b..d576c95816b8 100644
--- a/www/firefox36/files/patch-browser_app_mozilla.in
+++ b/www/firefox36/files/patch-browser_app_mozilla.in
@@ -1,5 +1,5 @@
---- browser/app/mozilla.in.orig Sat Nov 13 00:54:51 2004
-+++ browser/app/mozilla.in Sat Nov 13 00:57:22 2004
+--- browser/app/mozilla.in.orig Tue Oct 26 05:26:11 2004
++++ browser/app/mozilla.in Mon Dec 27 19:15:52 2004
@@ -110,6 +110,7 @@
# Check default compile-time libdir
if [ -x "$moz_libdir/run-mozilla.sh" ]; then
@@ -8,7 +8,21 @@
else
echo "Cannot find mozilla runtime directory. Exiting."
exit 1
-@@ -207,12 +207,31 @@
+@@ -160,11 +161,11 @@
+ _optLast="${i}"
+ done #last arg
+
+-if [ `expr "${_optLast}" : '.*:/.*'` -eq 0 -a \( -f "${_optLast}" -o -d "${_optLast}" \) ]; then
++if [ `expr -- "${_optLast}" : '.*:/.*'` -eq 0 -a \( -f "${_optLast}" -o -d "${_optLast}" \) ]; then
+ # Last argument seems to be a local file/directory
+ # Check, if it is absolutely specified (ie. /home/foo/file vs. ./file)
+ # If it is just "relatively" (./file) specified, make it absolutely
+- [ `expr "${_optLast}" : '/.*'` -eq 0 ] && _optLast="file://`pwd`/${_optLast}"
++ [ `expr -- "${_optLast}" : '/.*'` -eq 0 ] && _optLast="file://`pwd`/${_optLast}"
+ fi
+ ################################################################ Parse Arguments
+
+@@ -207,12 +208,31 @@
script_args="$script_args -d $2"
shift 2
;;