aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-20 06:55:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-20 06:55:07 +0000
commitbf3fff33fe5b9841b51276c6f7d970866e5e6068 (patch)
tree03bd1c834430ba478eb37a9b4703f349b1fd6c38 /www/firefox
parent1eca23797184ed14573221152bb9344e5ebf0ef9 (diff)
downloadports-bf3fff33fe5b9841b51276c6f7d970866e5e6068.tar.gz
ports-bf3fff33fe5b9841b51276c6f7d970866e5e6068.zip
Add a post-rendered Extensions.rdf so that the default theme and extension
shows up. Tested by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
Notes
Notes: svn path=/head/; revision=111837
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile7
-rw-r--r--www/firefox/files/Extensions.rdf37
-rw-r--r--www/firefox/pkg-install.in6
3 files changed, 45 insertions, 5 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 6c77fb3bc839..1d30ff57a4a3 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -138,8 +138,6 @@ pre-configure:
post-build:
# XXX This works around an install problem that is triggered when
# toolkit/profile/src is built after profile/src.
-# @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
-# .)
@${TOUCH} -f ${WRKSRC}/profile/build/libprofile.so
pre-install:
@@ -148,6 +146,7 @@ pre-install:
# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
+ @${MKDIR} ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
Makefile ${MAKE_ARGS} install
.for ii in mac win
@@ -155,6 +154,8 @@ pre-install:
@${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
+ @${INSTALL_DATA} ${FILESDIR}/Extensions.rdf \
+ ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
@${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
diff --git a/www/firefox/files/Extensions.rdf b/www/firefox/files/Extensions.rdf
new file mode 100644
index 000000000000..93e1e38a5e02
--- /dev/null
+++ b/www/firefox/files/Extensions.rdf
@@ -0,0 +1,37 @@
+<?xml version="1.0"?>
+<RDF:RDF xmlns:em="http://www.mozilla.org/2004/em-rdf#"
+ xmlns:NC="http://home.netscape.com/NC-rdf#"
+ xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
+ <RDF:Description RDF:about="urn:mozilla:extension:{641d8d09-7dda-4850-8228-ac0ab65e2ac9}"
+ em:version="1.0"
+ em:name="DOM Inspector"
+ em:description="A powerful tool for viewing and manipulating documents."
+ em:creator="Joe Hewitt"
+ em:locked="true">
+ <em:targetApplication RDF:resource="rdf:#$BfYhZ3"/>
+ </RDF:Description>
+ <RDF:Description RDF:about="rdf:#$BfYhZ3"
+ em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
+ em:minVersion="0.9"
+ em:maxVersion="0.9" />
+ <RDF:Description RDF:about="rdf:#$pfYhZ3"
+ em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
+ em:minVersion="0.9"
+ em:maxVersion="0.9" />
+ <RDF:Description RDF:about="urn:mozilla:theme:{972ce4c6-7e08-4474-a285-3208198ce6fd}"
+ em:version="2.0"
+ em:name="Firefox (default)"
+ em:description="The default theme"
+ em:creator="Gerich and Horlander"
+ em:internalName="classic/1.0"
+ em:locked="true"
+ em:contributor="Mozilla Contributors">
+ <em:targetApplication RDF:resource="rdf:#$pfYhZ3"/>
+ </RDF:Description>
+ <RDF:Seq RDF:about="urn:mozilla:theme:root">
+ <RDF:li RDF:resource="urn:mozilla:theme:{972ce4c6-7e08-4474-a285-3208198ce6fd}"/>
+ </RDF:Seq>
+ <RDF:Seq RDF:about="urn:mozilla:extension:root">
+ <RDF:li RDF:resource="urn:mozilla:extension:{641d8d09-7dda-4850-8228-ac0ab65e2ac9}"/>
+ </RDF:Seq>
+</RDF:RDF>
diff --git a/www/firefox/pkg-install.in b/www/firefox/pkg-install.in
index a39e85bff19f..5de485a7716a 100644
--- a/www/firefox/pkg-install.in
+++ b/www/firefox/pkg-install.in
@@ -27,8 +27,10 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
mkdir -p ${MOZDIR}/extensions
-cp -p ${MOZDIR}/defaults/profile/extensions/Extensions.rdf ${MOZDIR}/extensions
-cp -p ${MOZDIR}/defaults/profile/extensions/installed-extensions.txt \
+cp -rp ${MOZDIR}/defaults/profile/extensions/* ${MOZDIR}/extensions
+mv -f ${MOZDIR}/extensions/installed-extensions.txt \
${MOZDIR}/extensions/installed-extensions-processed.txt
+cp -p ${MOZDIR}/extensions.port/Extensions.rdf \
+ ${MOZDIR}/extensions
exit 0