aboutsummaryrefslogtreecommitdiff
path: root/www/flock/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /www/flock/Makefile
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175261
Diffstat (limited to 'www/flock/Makefile')
-rw-r--r--www/flock/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/www/flock/Makefile b/www/flock/Makefile
index 701b3236aa53..376b5a3381ea 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -3,11 +3,12 @@
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/firefox/Makefile,v 1.29 2006/02/01 02:11:23 ahze Exp $
+# $MCom: ports/www/flock/Makefile,v 1.2 2006/10/05 21:37:18 mezz Exp $
#
PORTNAME= flock
DISTVERSION= 0.7
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
# http://ftp.osuosl.org/pub/${PORTNAME}/source/${PORTVERSION}/:flock
@@ -23,7 +24,6 @@ LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
MOZILLA_NAME= Flock
CLUCENE_WRKSRC= ${WRKDIR}/clucene
-USE_X_PREFIX= yes
WANT_GNOME= yes
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
@@ -52,10 +52,6 @@ OPTIONS= SMB "Enable smb:// URI support using gnomevfs" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= Does not build on amd64
-.endif
-
.if ${ARCH}=="alpha" || ${ARCH}=="ia64"
IGNORE= core dumps on ${ARCH}
.endif
@@ -89,6 +85,7 @@ pre-install:
${ECHO_CMD} 'share/applications/${MOZILLA}.desktop' >> ${PLIST}
${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${PLIST}
${ECHO_CMD} 'share/pixmaps/${FLOCK_ICON}' >> ${PLIST}
+ ${ECHO_CMD} "@dirrmtry share/pixmaps" >> ${PLIST}
do-install:
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
@@ -108,5 +105,5 @@ post-install:
${LN} -sf ${FLOCK_ICON_SRC} ${PREFIX}/lib/${MOZILLA}/chrome/icons/default/default.xpm
${LN} -sf ${FLOCK_ICON_SRC} ${PREFIX}/share/pixmaps/${FLOCK_ICON}
-.include "${.CURDIR}/../mozilla/Makefile.common"
+.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>