aboutsummaryrefslogtreecommitdiff
path: root/www/flock/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-10 00:58:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-10 00:58:53 +0000
commita2f636b22c166cdd9d0aff3de359058c87bb2228 (patch)
treef6b46909d4ed983b35bbff912417b1bd46c9a4c8 /www/flock/Makefile
parent75b4d76535284f53992e66c6c38ee98dcb33a117 (diff)
downloadports-a2f636b22c166cdd9d0aff3de359058c87bb2228.tar.gz
ports-a2f636b22c166cdd9d0aff3de359058c87bb2228.zip
* Update to 1.0
* Install a firefox desktop entry for the GNOME desktop [1] * Fix the post-install plug-in repository generation when root is using a non-default shell [2] Submitted by: ahze [1] Clemens Fischer <ino-qc@spotteswoode.de.eu.org> [2]
Notes
Notes: svn path=/head/; revision=121265
Diffstat (limited to 'www/flock/Makefile')
-rw-r--r--www/flock/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/www/flock/Makefile b/www/flock/Makefile
index 3de712b3d316..1e9c0c738f32 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= firefox
-PORTVERSION= 1.0.r2
-PORTREVISION= 1
+PORTVERSION= 1.0
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= ${PORTNAME}/releases/1.0rc2/source
-DISTNAME= ${PORTNAME}-1.0rc2-source
+MASTER_SITE_SUBDIR= ${PORTNAME}/releases/1.0/source
+DISTNAME= ${PORTNAME}-1.0-source
MAINTAINER= gnome@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
@@ -35,7 +34,7 @@ PLIST= ${WRKDIR}/plist
PLUGINSDIR= ${PREFIX}/lib/browser_plugins
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 libidl
+USE_GNOME= gtk20 libidl gnomehier
USE_ICONV= yes
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
@@ -43,6 +42,9 @@ WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+FIREFOX_ICON= firefox.png
+FIREFOX_ICON_SRC=${WRKSRC}/other-licenses/branding/firefox/content/alert-exclam.png
+
PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
mozilla-nspr mozilla-nss mozilla-plugin
@@ -121,6 +123,8 @@ post-extract::
-e 's|@PREFIX@|${FAKEDIR}/lib/firefox|' \
-e 's|@PERL@|${PERL5}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+ @${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' \
+ <${FILESDIR}/firefox.desktop.in >${WRKDIR}/firefox.desktop
post-patch:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' \
@@ -191,6 +195,8 @@ pre-install:
"s:^:@unexec ${RMDIR} %D/:" -e "s:$$: || true:" >> ${PLIST}; \
${FIND} * -type d ! -empty | ${SORT} -r | ${SED} -e "s:^:@dirrm :" | \
${GREP} / >> ${PLIST}
+ ${ECHO_CMD} 'share/gnome/pixmaps/${FIREFOX_ICON}' >> ${PLIST}
+ ${ECHO_CMD} 'share/gnome/applications/firefox.desktop' >> ${PLIST}
do-install:
# This is the actual installation. First, the contents of FAKEDIR are
@@ -228,5 +234,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/other-licenses/branding/firefox/default.xpm \
${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}/chrome/icons/default/default.xpm
.endif # defined(WITH_NEW_ICON)
+ ${INSTALL_DATA} ${FIREFOX_ICON_SRC} ${PREFIX}/share/gnome/pixmaps/${FIREFOX_ICON}
+ ${INSTALL_DATA} ${WRKDIR}/firefox.desktop ${PREFIX}/share/gnome/applications
.include <bsd.port.post.mk>