aboutsummaryrefslogtreecommitdiff
path: root/www/flock/Makefile
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-11-10 18:05:10 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-11-10 18:05:10 +0000
commitc7685d56b96e054215e9a79614977c83df024a00 (patch)
tree4c68b6b6e2ebd5f015c572761de380f4c0123a44 /www/flock/Makefile
parent4b883802206c8c48c4834114223789e48adbab17 (diff)
downloadports-c7685d56b96e054215e9a79614977c83df024a00.tar.gz
ports-c7685d56b96e054215e9a79614977c83df024a00.zip
* PORTREVISION ==> 7.
* Allow building under -CURRENT. * Changes in LDFLAGS and CPPFLAGS passed to configure. * Removed stale javascript dirs (venkman) from plist. * Updated mkdistfile to remove more unneeded dirs. Used to make a new distfile from a cvs checkout. For maintainers only, really. * Disable bi-directional text in config. * Remove dupes from mozconfig.in. The problem with the martian file selection dialogs is gone. I am not sure of the cause, but apparently it had to do with either which version of the NSPR libs phoenix runs with or the link order of libraries. I don't care, as long as it doesn't do it, 'cause I do not read Martian. Should be running against its own set of NSPR libs now. (Note: you can't just use ldd to check this since the startup scripts play all kinds of fun games.) You are advised to remove $HOME/.phoenix before running the new version.
Notes
Notes: svn path=/head/; revision=69826
Diffstat (limited to 'www/flock/Makefile')
-rw-r--r--www/flock/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/www/flock/Makefile b/www/flock/Makefile
index e1f36bdd8f87..03a82750137a 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -9,15 +9,14 @@
PORTNAME= phoenix
PORTVERSION= 0.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www # pita
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
MAINTAINER= phoenix@freebsd.org # alane@fbsd and trevor@fbsd
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
@@ -39,18 +38,21 @@ HAS_CONFIGURE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 orbit
+CPPFLAGS+= -I${X11BASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${X11BASE}/lib
LIBS+= ${PTHREAD_LIBS}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/mozilla
LOCAL_PREFIX= ${PREFIX}/lib/${PORTNAME}
-MAKE_ENV+= XP_UNIX=1
-MAKE_ARGS+= XP_UNIX=1
.include <bsd.port.pre.mk>
.if !defined(PERL_LEVEL)
+.if !exists(${LOCALBASE}/bin/perl)
+PERL_LEVEL=0
+.endif # !exists(${LOCALBASE}/bin/perl)
perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
perl_minor=${_perl_minor:C|^.*(...)|\1|}
@@ -66,20 +68,12 @@ PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-.if ${OSVERSION} > 500038
-
-BROKEN= "on -CURRENT, can only be used with local files. You can run"
-BROKEN+="make with -DNO_IGNORE to override this message"
-
-.endif
-
.if ${PERL_LEVEL} < 500601
.undef NO_IGNORE
BROKEN= "right now, we can only support the ports versions of Perl."
BROKEN+="We are working on the problem. Sorry for the inconvenience."
BROKEN+="If you have installed a Perl port, and are getting this message,"
BROKEN+="please make sure you have issued the command 'use.perl port'"
-
.endif # ${PERL_LEVEL} < 500601
pre-extract::
@@ -88,7 +82,9 @@ pre-extract::
@${ECHO_MSG}
post-extract::
- @${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
+ @${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
+ -e 's|@CFLAGS@|${CFLAGS}|' \
+ -e 's|@LDFLAGS@|${LDFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
-e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
@@ -110,7 +106,7 @@ post-install:
@${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/phoenix-config
@${CAT} ${PKGMESSAGE} 2>/dev/null; sleep 5
- @${RM} -fr ${LOCAL_PREFIX}/share
+ @${RM} -fr ${LOCAL_PREFIX}/share/idl
@${RM} -fr ${LOCAL_PREFIX}/include
.include <bsd.port.post.mk>