aboutsummaryrefslogtreecommitdiff
path: root/www/flot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:29:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:29:07 +0000
commitad97fa692379193ccbe030259a613dfa6814fb33 (patch)
treee738ed66e08fbebc87eab6c1f4328e7d6c59e703 /www/flot
parent49d03f5ff394ef2796bd39e537fb02896ec39089 (diff)
downloadports-ad97fa692379193ccbe030259a613dfa6814fb33.tar.gz
ports-ad97fa692379193ccbe030259a613dfa6814fb33.zip
- Update to version 0.8.2
- Stage support PR: 187969 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=352212
Diffstat (limited to 'www/flot')
-rw-r--r--www/flot/Makefile48
-rw-r--r--www/flot/distinfo4
-rw-r--r--www/flot/pkg-descr10
-rw-r--r--www/flot/pkg-plist12
4 files changed, 38 insertions, 36 deletions
diff --git a/www/flot/Makefile b/www/flot/Makefile
index 759f15670511..0900477df677 100644
--- a/www/flot/Makefile
+++ b/www/flot/Makefile
@@ -1,49 +1,39 @@
# $FreeBSD$
PORTNAME= flot
-PORTVERSION= 0.7
+PORTVERSION= 0.8.2
CATEGORIES= www devel
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= http://www.flotcharts.org/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= JavaScript plotting library for jQuery
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USES= zip
USERS= www
GROUPS= www
-NO_BUILD= YES
-
-PORTDOCS= API.txt \
- FAQ.txt \
- NEWS.txt \
- PLUGINS.txt \
- README.txt
+PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
-do-install:
- @${INSTALL} -d -g ${USERS} -o ${GROUPS} ${WWWDIR}
- ${INSTALL_DATA} -o www -g www ${WRKSRC}/*.js ${WWWDIR}
-
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
-.endif
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.js \
+ ${STAGEDIR}${WWWDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.md \
+ ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} "*" \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/www/flot/distinfo b/www/flot/distinfo
index b8f0f03ee7c5..1cee44a10d28 100644
--- a/www/flot/distinfo
+++ b/www/flot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flot-0.7.tar.gz) = bc24f661d6de1d38496b93147604174dd82b6c54359824cb1c9c4acd5eb55730
-SIZE (flot-0.7.tar.gz) = 288107
+SHA256 (flot-0.8.2.zip) = 7bcb8dd13e0569cee7ebd25182623663b8558585bea512141d7140106846c4fe
+SIZE (flot-0.8.2.zip) = 646470
diff --git a/www/flot/pkg-descr b/www/flot/pkg-descr
index a86e4880cf90..7cb97255075d 100644
--- a/www/flot/pkg-descr
+++ b/www/flot/pkg-descr
@@ -1,6 +1,6 @@
-Flot is a pure Javascript plotting library for jQuery. It produces graphical
-plots of arbitrary datasets on-the-fly client-side. The focus is on simple
-usage (all settings are optional), attractive looks and interactive features
-like zooming and mouse tracking.
+Flot is a pure Javascript plotting library for jQuery. It produces
+graphical plots of arbitrary datasets on-the-fly client-side. The focus
+is on simple usage (all settings are optional), attractive looks and
+interactive features like zooming and mouse tracking.
-WWW: http://code.google.com/p/flot/
+WWW: http://www.flotcharts.org/
diff --git a/www/flot/pkg-plist b/www/flot/pkg-plist
index 08dd18a963f4..22b525da09ea 100644
--- a/www/flot/pkg-plist
+++ b/www/flot/pkg-plist
@@ -1,9 +1,17 @@
+@group www
+@owner www
%%WWWDIR%%/excanvas.js
%%WWWDIR%%/excanvas.min.js
%%WWWDIR%%/jquery.colorhelpers.js
%%WWWDIR%%/jquery.colorhelpers.min.js
+%%WWWDIR%%/jquery.flot.canvas.js
+%%WWWDIR%%/jquery.flot.canvas.min.js
+%%WWWDIR%%/jquery.flot.categories.js
+%%WWWDIR%%/jquery.flot.categories.min.js
%%WWWDIR%%/jquery.flot.crosshair.js
%%WWWDIR%%/jquery.flot.crosshair.min.js
+%%WWWDIR%%/jquery.flot.errorbars.js
+%%WWWDIR%%/jquery.flot.errorbars.min.js
%%WWWDIR%%/jquery.flot.fillbetween.js
%%WWWDIR%%/jquery.flot.fillbetween.min.js
%%WWWDIR%%/jquery.flot.image.js
@@ -24,6 +32,10 @@
%%WWWDIR%%/jquery.flot.symbol.min.js
%%WWWDIR%%/jquery.flot.threshold.js
%%WWWDIR%%/jquery.flot.threshold.min.js
+%%WWWDIR%%/jquery.flot.time.js
+%%WWWDIR%%/jquery.flot.time.min.js
%%WWWDIR%%/jquery.js
%%WWWDIR%%/jquery.min.js
+@owner
+@group
@dirrmtry %%WWWDIR%%