aboutsummaryrefslogtreecommitdiff
path: root/www/gatling/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-02 17:37:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-02 17:37:00 +0000
commit805c1fc00c786fc2ccb3b5a8feff34009df90421 (patch)
tree74be83d9431ca7445f11029e964e2b51bd545cc9 /www/gatling/Makefile
parentdf4d71f4d9261f3d6c3afc0e032c48afb4a06e84 (diff)
downloadports-805c1fc00c786fc2ccb3b5a8feff34009df90421.tar.gz
ports-805c1fc00c786fc2ccb3b5a8feff34009df90421.zip
- Update to 0.6
PR: ports/76980 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Notes
Notes: svn path=/head/; revision=127921
Diffstat (limited to 'www/gatling/Makefile')
-rw-r--r--www/gatling/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 9bb02e54542a..ecce27243a31 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gatling
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
@@ -17,17 +16,21 @@ COMMENT= A high performance webserver with scalability benchmark tools
BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
USE_BZIP2= yes
+USE_OPENSSL= yes
-MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+CFLAGS+= -I${LOCALBASE}/include/libowfat -I${OPENSSLINC}
+LDFLAGS+= -L${LOCALBASE}/lib -lowfat -L${OPENSSLLIB}
-bin= dl gatling
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+bin= dl
examples= run-gatling
examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+sbin= gatling tlsgatling
MAN8= gatling.8
.if !defined(NOPORTDOCS)
-PORTDOCS= CHANGES README README.ftp README.http README.performance \
- README.prefetch README.proxy README.redirect
+PORTDOCS= CHANGES README README.ftp README.htaccess README.http \
+ README.performance README.prefetch README.proxy README.redirect
.endif
OPTIONS= BENCHMARKS "Install system benchmark programs" on
@@ -43,13 +46,15 @@ examples+= prep run-bench
.endif
PLIST_DIRS= ${examplesdir}
-PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,}
+PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,} \
+ ${sbin:S,^,sbin/,}
pre-install:
@cd ${WRKSRC} && ${CP} gatling.1 gatling.8
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${sbin} ${PREFIX}/sbin
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${examples} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8