aboutsummaryrefslogtreecommitdiff
path: root/www/gatling/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-12 16:13:10 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-12 16:13:10 +0000
commitefb357d4d1e699e27948a8aa6b7ee4337ead0767 (patch)
treeb8a8a4092ce8724cff63cbdcc3410e1ff2a5c925 /www/gatling/Makefile
parent0618ffc8feec942e2d35a6b1b7cc63e21917b639 (diff)
downloadports-efb357d4d1e699e27948a8aa6b7ee4337ead0767.tar.gz
ports-efb357d4d1e699e27948a8aa6b7ee4337ead0767.zip
Fix a manpage install
Fix build on 4.x PR: ports/70111 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=116044
Diffstat (limited to 'www/gatling/Makefile')
-rw-r--r--www/gatling/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index a502724a457c..7006f50977bb 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -7,7 +7,8 @@
PORTNAME= gatling
PORTVERSION= 0.5
-CATEGORIES= www benchmarks
+PORTREVISION= 1
+CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
MAINTAINER= tmseck@netcologne.de
@@ -17,13 +18,13 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
USE_BZIP2= yes
-CFLAGS+= -I${LOCALBASE}/include/libowfat
MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
bin= dl gatling
examples= run-gatling
examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+MAN8= gatling.8
.if !defined(NOPORTDOCS)
PORTDOCS= CHANGES README README.ftp README.http README.performance \
README.prefetch README.proxy README.redirect
@@ -44,10 +45,14 @@ examples+= prep run-bench
PLIST_DIRS= ${examplesdir}
PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,}
+pre-install:
+ @cd ${WRKSRC} && ${CP} gatling.1 gatling.8
+
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${examples} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}