aboutsummaryrefslogtreecommitdiff
path: root/www/geolizer
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-11-11 19:48:09 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2004-11-11 19:48:09 +0000
commit912e002c0e55fe32ce7f2458c3dede99e3b4f61a (patch)
tree12f51035efdf0f735fdd3a91d5ae8fb90995f321 /www/geolizer
parent40ace6f64aec48bb38510e40d893ec87147f6f0c (diff)
downloadports-912e002c0e55fe32ce7f2458c3dede99e3b4f61a.tar.gz
ports-912e002c0e55fe32ce7f2458c3dede99e3b4f61a.zip
Add optional languages support
Submitted by: Nikolaj Karpov <kolya@astrons.com>
Notes
Notes: svn path=/head/; revision=121409
Diffstat (limited to 'www/geolizer')
-rw-r--r--www/geolizer/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/www/geolizer/Makefile b/www/geolizer/Makefile
index 720c92f89905..f71b6a5ecc80 100644
--- a/www/geolizer/Makefile
+++ b/www/geolizer/Makefile
@@ -31,6 +31,14 @@ DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}webalizer
EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}webalizer
GD_PORT?= graphics/gd
+SUPP_LANG= catalan chinese croatian czech danish dutch english \
+ estonian finnish french galician german greek hungarian \
+ icelandic indonesian italian japanese korean latvian \
+ malay norwegian polish portuguese portuguese_brazil \
+ romanian romanian-iso-8859-2 russian serbian \
+ simplified_chinese slowak slovene spanish swedish \
+ turkish ukrainian
+
CONFLICTS= webalizer-2*
.include <bsd.port.pre.mk>
@@ -44,7 +52,10 @@ CONFIGURE_ARGS+= --enable-dns \
--with-geoip-inc=${LOCALBASE}/include \
--with-png=${LOCALBASE}/lib \
--with-png-inc=${LOCALBASE}/include \
- --with-language=english
+
+.if defined(GEOLIZER_LANG)
+CONFIGURE_ARGS+= --with-language=${GEOLIZER_LANG}
+.endif
CFLAGS+= -DLINKLIST_MAX_STRING=256
MAN1= ${PKGNAMEPREFIX}webalizer.1
@@ -55,6 +66,12 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-src$//}
PLIST_SUB+= PKGNAMEPREFIX=${PKGNAMEPREFIX}
pre-configure:
+.if !defined(GEOLIZER_LANG)
+ @${ECHO_MSG} "You can customize the language by typing"
+ @${ECHO_MSG} " make GEOLIZER_LANG=<lang>"
+ @${ECHO_MSG} "where <lang> is one of:"
+ @${ECHO_MSG} ${SUPP_LANG}
+.endif
@${MV} ${WRKSRC}/webalizer.1 ${WRKSRC}/webalizer.1.sed
${SED} -e "s=/etc=${PREFIX}/etc=" \
${WRKSRC}/webalizer.1.sed > ${WRKSRC}/webalizer.1