aboutsummaryrefslogtreecommitdiff
path: root/www/harvest
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-03-31 03:10:17 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-03-31 03:10:17 +0000
commit0d089f0cc8af77a0192118f92602c80382aac9a2 (patch)
treea24591a073731e03093436cdffc3f6100a7f922a /www/harvest
parentafd252143d18ad46f3115049819bec6da02f289b (diff)
downloadports-0d089f0cc8af77a0192118f92602c80382aac9a2.tar.gz
ports-0d089f0cc8af77a0192118f92602c80382aac9a2.zip
Remove #include <malloc.h>
Don't statically initialize a FILE *
Notes
Notes: svn path=/head/; revision=57005
Diffstat (limited to 'www/harvest')
-rw-r--r--www/harvest/Makefile7
-rw-r--r--www/harvest/files/patch-aa20
2 files changed, 27 insertions, 0 deletions
diff --git a/www/harvest/Makefile b/www/harvest/Makefile
index 2c1077f9186d..56a303be326b 100644
--- a/www/harvest/Makefile
+++ b/www/harvest/Makefile
@@ -17,6 +17,13 @@ EXTRACT_SUFX= -src.tar.gz
MAINTAINER= ports@FreeBSD.org
+pre-patch:
+ @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ ${WRKSRC}/src/configure ${WRKSRC}/src/broker/broker.h \
+ ${WRKSRC}/src/gatherer/essence/main.c \
+ ${WRKSRC}/src/gatherer/include/essence.h \
+ ${WRKSRC}/components/gatherer/standard/dvi2tty/dvi2tty.h
+
pre-install:
${MKDIR} ${PREFIX}/harvest
diff --git a/www/harvest/files/patch-aa b/www/harvest/files/patch-aa
new file mode 100644
index 000000000000..90e5aae10b26
--- /dev/null
+++ b/www/harvest/files/patch-aa
@@ -0,0 +1,20 @@
+--- components/gatherer/standard/skim/skim.c.orig Sat Mar 30 18:54:27 2002
++++ components/gatherer/standard/skim/skim.c Sat Mar 30 18:54:45 2002
+@@ -15,7 +15,7 @@
+
+ int Argc;
+ char **Argv;
+-FILE *InputFile = stdin;
++FILE *InputFile;
+
+ main(argc, argv)
+ int argc;
+@@ -25,6 +25,8 @@
+ int Skipping = 0, nlines = 0;
+ char *Ptr;
+ char *EndLine;
++
++ InputFile = stdin;
+
+ /* Set up globals */
+ Argc = argc;