aboutsummaryrefslogtreecommitdiff
path: root/www/hastymail
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-18 22:55:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-18 22:55:43 +0000
commit5b5d978c24a35eee0fda39d399763dae38fff498 (patch)
treedd4f08b322a7187faa81045c7f10ac6b9bca5a4a /www/hastymail
parent793b724c23f41355f770505af4fcb5daa0438c9b (diff)
downloadports-5b5d978c24a35eee0fda39d399763dae38fff498.tar.gz
ports-5b5d978c24a35eee0fda39d399763dae38fff498.zip
Hastymail is a streamlined, secure, fast web based IMAP client written
in PHP. Hastymail is designed to have low server requirements and follow internet standards for MIME, IMAP and SMTP communications. Hastymail is also designed to work with all the major and not so major web browsers available. Hastymail does not use frames, javascript, or cookies and all output is 100% W3C compliant 4.01 transitional HTML. WWW: http://hastymail.sourceforge.net/ PR: ports/105646 Submitted by: Bartlomiej Rutkowski <r at robakdesign.com>
Notes
Notes: svn path=/head/; revision=177534
Diffstat (limited to 'www/hastymail')
-rw-r--r--www/hastymail/Makefile42
-rw-r--r--www/hastymail/distinfo3
-rw-r--r--www/hastymail/files/pkg-message.in12
-rw-r--r--www/hastymail/pkg-descr8
4 files changed, 65 insertions, 0 deletions
diff --git a/www/hastymail/Makefile b/www/hastymail/Makefile
new file mode 100644
index 000000000000..b4f55b7b9478
--- /dev/null
+++ b/www/hastymail/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: hastymail
+# Date created: 2006-11-04
+# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hastymail
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= hastymail
+
+MAINTAINER= r@robakdesign.com
+COMMENT= Small, fast and secure yet powerful IMAP webmail
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+WWWOWN?= www
+WWWGRP?= www
+INSTALL_DIR?= www/data/${PORTNAME}
+
+WANT_PHP_WEB= yes
+USE_PHP= session imap
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/hastymail/distinfo b/www/hastymail/distinfo
new file mode 100644
index 000000000000..6e9c34754986
--- /dev/null
+++ b/www/hastymail/distinfo
@@ -0,0 +1,3 @@
+MD5 (hastymail-1.5.tar.gz) = ca6699b30b59c87027eebc67a633384b
+SHA256 (hastymail-1.5.tar.gz) = ea3a147e0a78650bf598e8ffe862eb6e50e2bf4e61e818efa241e03d51946eac
+SIZE (hastymail-1.5.tar.gz) = 361269
diff --git a/www/hastymail/files/pkg-message.in b/www/hastymail/files/pkg-message.in
new file mode 100644
index 000000000000..d4bbccf29d59
--- /dev/null
+++ b/www/hastymail/files/pkg-message.in
@@ -0,0 +1,12 @@
+******************************************************
+
+You have successfully installed Hastymail webmail client.
+Dont forget to move config file to proper directory and
+to change that variable in hastymail/lib/constant.php
+
+$config_file = '/etc/hastymail.conf';
+
+as needed. After that, follow the instructions in INSTALL
+file to configure Hastymail finally.
+
+******************************************************
diff --git a/www/hastymail/pkg-descr b/www/hastymail/pkg-descr
new file mode 100644
index 000000000000..5bbf7bc1cfe7
--- /dev/null
+++ b/www/hastymail/pkg-descr
@@ -0,0 +1,8 @@
+Hastymail is a streamlined, secure, fast web based IMAP client written
+in PHP. Hastymail is designed to have low server requirements and follow
+internet standards for MIME, IMAP and SMTP communications. Hastymail is also
+designed to work with all the major and not so major web browsers available.
+Hastymail does not use frames, javascript, or cookies and all output is 100%
+W3C compliant 4.01 transitional HTML.
+
+WWW: http://hastymail.sourceforge.net/