aboutsummaryrefslogtreecommitdiff
path: root/www/havp/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-06-18 04:54:26 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-06-18 04:54:26 +0000
commit72e48206fb0f3b024b4bb9d25824133b3102eb06 (patch)
tree4b5cc83d6b26ee3d2ab0aa00bbef8c663fb9c2c6 /www/havp/Makefile
parent944f6613ac1b3b9d1541a10d58e59b8a8409cc4a (diff)
downloadports-72e48206fb0f3b024b4bb9d25824133b3102eb06.tar.gz
ports-72e48206fb0f3b024b4bb9d25824133b3102eb06.zip
HAVP (HTTP Antivirus Proxy) is a proxy with a ClamAV anti-virus scanner. The
main aims are continuous, non-blocking downloads and smooth scanning of dynamic and password protected HTTP traffic. Havp antivirus proxy has a parent and transparent proxy mode. It can be used with squid or standalone. WWW: http://www.server-side.de/ PR: ports/99073 Submitted by: Elisey Savateev <b3k@mail.ru>
Notes
Notes: svn path=/head/; revision=165675
Diffstat (limited to 'www/havp/Makefile')
-rw-r--r--www/havp/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/www/havp/Makefile b/www/havp/Makefile
new file mode 100644
index 000000000000..ccb4a0126a3a
--- /dev/null
+++ b/www/havp/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: havp
+# Date created: 17 June 2006
+# Whom: Elisey Savateev <b3k@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= havp
+PORTVERSION= 0.81
+CATEGORIES= www
+MASTER_SITES= http://www.server-side.de/download/ \
+ http://bio3k.softboard.ru/uploads/arch/
+
+MAINTAINER= b3k@mail.ru
+COMMENT= HTTP Antivirus Proxy
+
+LIB_DEPENDS= clamav.1:${PORTSDIR}/security/clamav
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_RC_SUBR= havp
+
+LOG_DIR= /var/log/havp
+TMP_DIR= /var/tmp/havp
+RUN_DIR= /var/run/havp
+PLIST_SUB+= LOG_DIR=${LOG_DIR} TMP_DIR=${TMP_DIR} RUN_DIR=${RUN_DIR}
+
+SUB_FILES= pkg-install pkg-deinstall
+SUB_LIST= LOG_DIR=${LOG_DIR} TMP_DIR=${TMP_DIR} RUN_DIR=${RUN_DIR}
+
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+post-install:
+ @[ -f ${PREFIX}/etc/havp/havp.config ] || \
+ ${CP} -p ${PREFIX}/etc/havp/havp.config.default ${PREFIX}/etc/havp/havp.config
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} ${WRKSRC}/etc/havp/blacklist ${EXAMPLESDIR}/blacklist.sample
+ @${CP} -R ${WRKSRC}/etc/havp/templates ${EXAMPLESDIR}
+ @${CP} ${WRKSRC}/etc/havp/whitelist ${EXAMPLESDIR}/whitelist.sample
+ @${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
+
+.include <bsd.port.mk>