aboutsummaryrefslogtreecommitdiff
path: root/www/horde
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-13 08:22:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-13 08:22:47 +0000
commit892776f70f958ff1b4cc9c5a573ddeeac4f1dace (patch)
tree92a4987779e5d631c4ad21b355e8976447da5470 /www/horde
parent70206e37b50fa7add106f514b98f5b7f2ae7d8c3 (diff)
downloadports-892776f70f958ff1b4cc9c5a573ddeeac4f1dace.tar.gz
ports-892776f70f958ff1b4cc9c5a573ddeeac4f1dace.zip
upgrade to 1.2.7
PR: 31937 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=49976
Diffstat (limited to 'www/horde')
-rw-r--r--www/horde/Makefile18
-rw-r--r--www/horde/distinfo2
-rw-r--r--www/horde/pkg-deinstall12
3 files changed, 26 insertions, 6 deletions
diff --git a/www/horde/Makefile b/www/horde/Makefile
index ca44ebd65d3c..06a3efeb08ba 100644
--- a/www/horde/Makefile
+++ b/www/horde/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= horde
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.2.7
CATEGORIES= www
MASTER_SITES= ftp://ftp.horde.org/pub/horde/tarballs/
@@ -68,6 +67,14 @@ pre-everything::
@${ECHO_MSG} ""
.endif
+pre-install:
+ @if [ -f ${HORDEDIR}/index.php ]; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please deinstall the port www/horde-devel." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+
do-install:
${MKDIR} ${HORDEDIR}
${MKDIR} ${PHPLIBDIR}
@@ -83,6 +90,8 @@ do-install:
${PERL} -pi -e "s:config/horde:${HORDEDIR}/config/horde:g" ${HORDESBIN}/horde_setup.sh
${PERL} -pi -e "s:imp/config:${HORDEDIR}/imp/config:g" ${HORDESBIN}/horde_setup.sh
${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_setup.sh
+ ${CHMOD} u+x ${HORDESBIN}/horde_secure.sh
+ ${CHMOD} u+x ${HORDESBIN}/horde_setup.sh
${PERL} -pi -e "s:go to the top level directory for your installation and run:run:g" ${HORDEDIR}/setup.php3
${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/templates/index/horde_notconfigured.inc
@@ -108,15 +117,14 @@ do-install:
@(if [ -f ${APACHE_CONF} ] ; then \
(if [ ! -f ${APACHE_CONF}.beforeHorde ] ; then \
${ECHO} "===> Updating httpd.conf..." ; \
- ${CP} -p ${.CURDIR}/httpd.conf.phplib ${WRKDIR}/httpd.conf.phplib.orig ; \
+ ${CP} -p ${MASTERDIR}/httpd.conf.phplib ${WRKDIR}/httpd.conf.phplib ; \
${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
${PERL} -pi -e "s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
${GREP} -qw 'phplib' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.phplib >> ${APACHE_CONF} ; \
- ${RM} ${.CURDIR}/httpd.conf.phplib ; \
- ${MV} ${.CURDIR}/httpd.conf.phplib.orig ${.CURDIR}/httpd.conf.phplib ; \
fi) ; \
fi)
+ ${CHOWN} -R www:www ${HORDEDIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
diff --git a/www/horde/distinfo b/www/horde/distinfo
index 8f25c5c4a63a..083f86d7b801 100644
--- a/www/horde/distinfo
+++ b/www/horde/distinfo
@@ -1 +1 @@
-MD5 (horde-1.2.6.tar.gz) = 123d9b8b91f2526ece1595271d33d52c
+MD5 (horde-1.2.7.tar.gz) = 2433ed0e67739c41021b1a9397130a96
diff --git a/www/horde/pkg-deinstall b/www/horde/pkg-deinstall
new file mode 100644
index 000000000000..8277aa19805c
--- /dev/null
+++ b/www/horde/pkg-deinstall
@@ -0,0 +1,12 @@
+#!/bin/sh
+# Try to restore httpd.conf when deinstalling Horde
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -f ${PKG_PREFIX}/etc/apache/httpd.conf.beforeHorde ] ; then
+ echo "Restoring httpd.conf..."
+ cp ${PKG_PREFIX}/etc/apache/httpd.conf ${PKG_PREFIX}/etc/apache/httpd.conf.deinstHorde
+ mv ${PKG_PREFIX}/etc/apache/httpd.conf.beforeHorde ${PKG_PREFIX}/etc/apache/httpd.conf
+fi