aboutsummaryrefslogtreecommitdiff
path: root/www/htmlcompressor/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2010-11-20 18:25:22 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2010-11-20 18:25:22 +0000
commit89fe94f66ef4942967605e5097f599152a762709 (patch)
tree25aa919c36c964dc7a4cb827f106621fc3e45746 /www/htmlcompressor/Makefile
parent32e5c55fcd9d12e408d579a60de120a1f446270d (diff)
downloadports-89fe94f66ef4942967605e5097f599152a762709.tar.gz
ports-89fe94f66ef4942967605e5097f599152a762709.zip
Add htmlcompressor 0.9.4, HTML/XML Compressor.
Notes
Notes: svn path=/head/; revision=264850
Diffstat (limited to 'www/htmlcompressor/Makefile')
-rw-r--r--www/htmlcompressor/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/htmlcompressor/Makefile b/www/htmlcompressor/Makefile
new file mode 100644
index 000000000000..78a9d2383ed1
--- /dev/null
+++ b/www/htmlcompressor/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: htmlcompressor
+# Date created: 20 Nov 2010
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlcompressor
+PORTVERSION= 0.9.4
+CATEGORIES= www java
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= HTML/XML Compressor
+
+LICENSE= ASL
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= bin/htmlcompressor %%DATADIR%%/htmlcompressor.jar
+PLIST_DIRS= %%DATADIR%%
+SUB_FILES= htmlcompressor
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/build/htmlcompressor-${PORTVERSION}.jar ${DATADIR}/htmlcompressor.jar
+ ${INSTALL_SCRIPT} ${WRKDIR}/htmlcompressor ${PREFIX}/bin
+
+.include <bsd.port.post.mk>