aboutsummaryrefslogtreecommitdiff
path: root/www/htmlpp
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1998-07-20 23:20:24 +0000
committerDonald Burr <dburr@FreeBSD.org>1998-07-20 23:20:24 +0000
commit29851fe46e7e6dc0670d8bc193d21f95f63fdb9b (patch)
tree22a595761e26875a1adf5c095e6029e6a9277791 /www/htmlpp
parent3f8fb1f1e6af765989ec19eaf5f612d3bd9e474e (diff)
downloadports-29851fe46e7e6dc0670d8bc193d21f95f63fdb9b.tar.gz
ports-29851fe46e7e6dc0670d8bc193d21f95f63fdb9b.zip
PR: ports/4985
Submitted by: myself Import of new port www/htmlpp, a tool that allows you to easily maintain web sites of any size.
Notes
Notes: svn path=/head/; revision=12036
Diffstat (limited to 'www/htmlpp')
-rw-r--r--www/htmlpp/Makefile43
-rw-r--r--www/htmlpp/distinfo1
-rw-r--r--www/htmlpp/pkg-comment1
-rw-r--r--www/htmlpp/pkg-descr10
-rw-r--r--www/htmlpp/pkg-plist25
5 files changed, 80 insertions, 0 deletions
diff --git a/www/htmlpp/Makefile b/www/htmlpp/Makefile
new file mode 100644
index 000000000000..2d6d4a04563c
--- /dev/null
+++ b/www/htmlpp/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: htmlpp
+# Version required: 3.9d
+# Date created: 9 Nov 1997
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= htmlpp
+PKGNAME= htmlpp-3.9d
+CATEGORIES= www
+MASTER_SITES= http://www.imatix.com/pub/tools/
+EXTRACT_SUFX= .zip
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+EXTRACT_CMD= unzip
+EXTRACT_ARGS= -qa
+
+USE_PERL5= YES
+
+NO_WRKSUBDIR= yes
+
+do-build:
+ ${SED} -e '1,1s:/usr/bin/perl:${PREFIX}/bin/perl5.00404:' \
+ ${WRKDIR}/htmlpp > ${WRKDIR}/htmlpp.temp
+ ${RM} -f ${WRKDIR}/htmlpp
+ ${MV} ${WRKDIR}/htmlpp.temp ${WRKDIR}/htmlpp
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/htmlpp ${PREFIX}/bin/htmlpp
+ ${INSTALL_DATA} ${WRKDIR}/htmlpp.d ${PREFIX}/lib/perl5/site_perl/htmlpp.d
+ (cd ${WRKDIR}; for FILE in *.pl; do ${INSTALL_DATA} $${FILE} ${PREFIX}/lib/perl5/site_perl/$${FILE}; done)
+ (cd ${WRKDIR}; for FILE in *.def; do ${INSTALL_DATA} $${FILE} ${PREFIX}/bin/$${FILE}; done)
+ ${INSTALL_DATA} ${WRKDIR}/guru_opt.fmt ${PREFIX}/bin/guru.fmt
+ ${INSTALL_DATA} ${WRKDIR}/htmlpp.l ${PREFIX}/bin/htmlpp.l
+ (cd ${WRKDIR}; ${MKDIR} ${PREFIX}/share/doc/htmlpp; for FILE in *.htm; do ${INSTALL_DATA} $${FILE} ${PREFIX}/share/doc/htmlpp/$${FILE}l; done)
+ (cd ${WRKDIR}; for FILE in *.gif; do ${INSTALL_DATA} $${FILE} ${PREFIX}/share/doc/htmlpp/$${FILE}; done)
+ (cd ${WRKDIR}; for FILE in *.txt; do ${INSTALL_DATA} $${FILE} ${PREFIX}/share/doc/htmlpp/$${FILE}; done)
+
+.include <bsd.port.mk>
diff --git a/www/htmlpp/distinfo b/www/htmlpp/distinfo
new file mode 100644
index 000000000000..4ed021440f80
--- /dev/null
+++ b/www/htmlpp/distinfo
@@ -0,0 +1 @@
+MD5 (htmlpp.zip) = 66451d3900084b2331823420506d71d9
diff --git a/www/htmlpp/pkg-comment b/www/htmlpp/pkg-comment
new file mode 100644
index 000000000000..298ba570b7ab
--- /dev/null
+++ b/www/htmlpp/pkg-comment
@@ -0,0 +1 @@
+A Perl script to allow easy creation of HTML from template files
diff --git a/www/htmlpp/pkg-descr b/www/htmlpp/pkg-descr
new file mode 100644
index 000000000000..d05098153925
--- /dev/null
+++ b/www/htmlpp/pkg-descr
@@ -0,0 +1,10 @@
+htmlpp is a Perl[45] script that allows easy maintaining of Web sites of
+any size, by allowing you to create "template" HTML files using a form of
+page description language. It will even turn plain-text files into
+quick-n-dirty, yet nicely formatted HTML using the "GURU mode" feature.
+Documentation is included in HTML format
+(stored in /usr/local/share/doc/htmlpp), and since the documentation was
+produced using htmlpp itself, you can take a look at the source file (also
+installed) to see an example of how to use htmlpp.
+
+[ This port is maintained by Donald Burr <dburr@FreeBSD.ORG>. ]
diff --git a/www/htmlpp/pkg-plist b/www/htmlpp/pkg-plist
new file mode 100644
index 000000000000..f3a31c4fb41b
--- /dev/null
+++ b/www/htmlpp/pkg-plist
@@ -0,0 +1,25 @@
+bin/htmlpp
+bin/contents.def
+bin/filetype.def
+bin/guru.def
+bin/macros.def
+bin/prelude.def
+bin/guru.fmt
+bin/htmlpp.l
+lib/perl5/site_perl/htmlpp.d
+lib/perl5/site_perl/findfile.pl
+lib/perl5/site_perl/sflcvdp.pl
+lib/perl5/site_perl/sfldate.pl
+lib/perl5/site_perl/shellwd.pl
+share/doc/htmlpp/index.html
+share/doc/htmlpp/index1.html
+share/doc/htmlpp/index2.html
+share/doc/htmlpp/index3.html
+share/doc/htmlpp/index4.html
+share/doc/htmlpp/index5.html
+share/doc/htmlpp/htmlpp1.gif
+share/doc/htmlpp/im0096c.gif
+share/doc/htmlpp/newstone.gif
+share/doc/htmlpp/gurutst.txt
+share/doc/htmlpp/htmlpp.txt
+@dirrm share/doc/htmlpp