aboutsummaryrefslogtreecommitdiff
path: root/www/jericho-html
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-28 16:21:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-28 16:21:05 +0000
commit627a3c6b7e45bba867da7492fa686e943f1dd636 (patch)
tree611618e5543291832caaa93f3c11537275860b84 /www/jericho-html
parentbcd644ece401a03f21a3de53235281e5e4f45983 (diff)
downloadports-627a3c6b7e45bba867da7492fa686e943f1dd636.tar.gz
ports-627a3c6b7e45bba867da7492fa686e943f1dd636.zip
- Stage support
Notes
Notes: svn path=/head/; revision=346551
Diffstat (limited to 'www/jericho-html')
-rw-r--r--www/jericho-html/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/jericho-html/Makefile b/www/jericho-html/Makefile
index 12f9c9ad21eb..5f283ba2ae98 100644
--- a/www/jericho-html/Makefile
+++ b/www/jericho-html/Makefile
@@ -19,7 +19,6 @@ INTERFACES:= "compile-time-dependencies/slf4j-api-1.6.1.jar:\
PORTDOCS= *
PLIST_FILES+= %%JAVAJARDIR%%/${PORTNAME}.jar
-NO_STAGE= yes
do-build:
(cd ${WRKSRC} && ${RM} -rf classes/* && ${JAVAC} \
-classpath ${INTERFACES:S, ,,g} \
@@ -30,10 +29,9 @@ do-build:
-C ${WRKSRC}/classes .
do-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR})
-.endif
+ ${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>