aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-04-01 12:05:06 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-04-01 12:05:06 +0000
commitbc2f3505522ad516a24f6789b5e6cf7cd046ea19 (patch)
treebad06c8d6b1597412b99e2a7c869a3faae9aebcf /www/libapreq2
parentabbc1b404816bb9035cee7ce699fda57ab1bad08 (diff)
downloadports-bc2f3505522ad516a24f6789b5e6cf7cd046ea19.tar.gz
ports-bc2f3505522ad516a24f6789b5e6cf7cd046ea19.zip
Unbreak build: set SHLIB_MAJOR to 8 for obsolete (but still default)
Apache version 2.0
Notes
Notes: svn path=/head/; revision=188934
Diffstat (limited to 'www/libapreq2')
-rw-r--r--www/libapreq2/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 0a201824959f..b02bb3e06c6e 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -14,14 +14,11 @@ MASTER_SITE_SUBDIR=libapreq
MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache2 Request Library
-BROKEN= Incorrect pkg-plist
-
USE_APACHE= 2.0+
-USE_LDCONFIG=yes
-GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf:259 libtool:15
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
-SHLIB_MAJOR= 9
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
.if defined (WITH_MODPERL2)
@@ -57,4 +54,12 @@ post-patch:
PLIST_SUB+= WITH_MODPERL2="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} == 20
+SHLIB_MAJOR= 8
+.else
+SHLIB_MAJOR= 9
+.endif
+
+.include <bsd.port.post.mk>