aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-05-01 05:29:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-05-01 05:29:08 +0000
commit3d25b2953ae3bcd0fa44f71157d690a0d67e57a0 (patch)
tree3a53b13f346cc5f079624a2713ae3cad28a9a655 /www/libxul
parent8535e2e3cc7f402140f03f89635b654155b7ab01 (diff)
downloadports-3d25b2953ae3bcd0fa44f71157d690a0d67e57a0.tar.gz
ports-3d25b2953ae3bcd0fa44f71157d690a0d67e57a0.zip
gecko: unbreak WebRTC microphone selection popup with ALSA=on
On FreeBSD sound(4) is enabled by default while alsa-plugins-oss assumes a soundcard is always available. https://bugzilla.mozilla.org/show_bug.cgi?id=1269165 MFH: 2016Q2
Notes
Notes: svn path=/head/; revision=414386
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile1
-rw-r--r--www/libxul/files/patch-bug126916524
2 files changed, 25 insertions, 0 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index a6f59ad1939b..2047822bb416 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.1.0
+PORTREVISION= 1
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/libxul/files/patch-bug1269165 b/www/libxul/files/patch-bug1269165
new file mode 100644
index 000000000000..f88f018866a5
--- /dev/null
+++ b/www/libxul/files/patch-bug1269165
@@ -0,0 +1,24 @@
+# getUserMedia fails to enumerate ALSA plugins
+
+--- media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc.orig 2016-04-22 00:37:17 UTC
++++ media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc
+@@ -1752,7 +1752,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ // Don't use snd_device_name_hint(-1,..) since there is a access violation
+ // inside this ALSA API with libasound.so.2.0.0.
+ int card = -1;
++#ifdef WEBRTC_LINUX
+ while (!(LATE(snd_card_next)(&card)) && (card >= 0) && keepSearching) {
++#endif
+ void **hints;
+ err = LATE(snd_device_name_hint)(card, "pcm", &hints);
+ if (err != 0)
+@@ -1878,7 +1880,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ LATE(snd_strerror)(err));
+ // Continue and return true anyway, since we did get the whole list.
+ }
++#ifdef WEBRTC_LINUX
+ }
++#endif
+
+ if (FUNC_GET_NUM_OF_DEVICE == function)
+ {