aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-10-06 22:15:16 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-10-06 22:15:16 +0000
commit8e0c198f864611cd663879f07167acf4d7ae86a0 (patch)
tree22f3116c4cb620d0fcabbbbf3e92b228145530d4 /www/lighttpd/Makefile
parentbed434d7a5e3ecdd6b9818e46e5f2c78e9001521 (diff)
downloadports-8e0c198f864611cd663879f07167acf4d7ae86a0.tar.gz
ports-8e0c198f864611cd663879f07167acf4d7ae86a0.zip
- Use autotools only if building lighttpd modules
Notes
Notes: svn path=/head/; revision=262538
Diffstat (limited to 'www/lighttpd/Makefile')
-rw-r--r--www/lighttpd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 4b96588e1ca8..766a9bdc39f9 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -20,8 +20,13 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
+
+.if !defined(_BUILDING_LIGHTTPD_MODULE)
+USE_AUTOTOOLS= libtool:22
+.else
USE_AUTOTOOLS= autoconf:267 autoheader:267 aclocal:111 automake:111 libtool:22
ACLOCAL_ARGS= -I m4
+.endif
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd --enable-static
CFLAGS+= -I${LOCALBASE}/include